HACS - Communication issue? - Could not authenticate with GitHub

When I tried to install the HACS integration into HAOS, It kept failing. While I’m able to connect to GitHub and confirm the needed port is open using PING, NC, and NMAP, the install process is failing with a UI message, ‘Could not authenticate with GitHub’, and a log message, ‘Cannot connect to host github.com:443 ssl:default [Try again]’.

Does this make sense to anyone? I don’t come from a Linux background, so I still finding my way under the hood.

I posted this problem at the developer’s GitHub page. The detailed writeup and screen shots are at: https://github.com/hacs/integration/issues/3252. The developer suggested the problem is a communication issue, not a HACS issue. I’m inclined to trust his suggestion as I’m not finding other posts about this problem.

Any suggestions or ideas?

I’m having the same issue. It looks like aiogithubapi may be the problem as the github url its trying to connect to does not exist, hence the 404 error. Not sure what the fix is though.


Found a solution that worked for me. Apparently the problem was related to using BalenaEtcher to write HAOS to the server hard drive (BE would stall at 31%, but HAOS would still boot, making it appear that everything was fine). So I started over and used USBimager according to Flashing hard drive get stuck at 31% (balena fetcher) - #48 by Damos. Had a successful install of HAOS and all the problems I was having (this one and other integrations like radiobrowser that need to access URLs) went away.