Flashing hard drive get stuck at 31% (balena fetcher)

I have successfully connected to HA via ZeroTier One from the outside of my home network, so network-wise everything seems good so far.

Lol - it legit worked. I had literally 0 hope of resolving that but it actually worked.

Thanks A LOT @keydi !!!

Met.no works, radio works, hacs install is currently going on - I am SO relieved !

@Damos, I confirm it works on Ubuntu LTS - please download USBimager Ubuntu LTS version, then open it with the native software installer from Ubuntu. Ping me if you need any help !

@keydi, thanks again and @all thanks everyone for your shot at trying to help that f*cking issue !

4 Likes

Wow - love the energy here.

So is this the case where there might be compatibility issues with Balena Etcher and HAOS, so that if we use USBImager instead of Balena Etcher, we would be fine?

In my opinion (and experience) it’s a little bit more convoluted than just “Balena Etcher + HAOS” issue. According to my experience, it’s rather “HAOS + Balena Etcher on live Linux booted from SD/USB + flashing SSD on thin-client-like hardware”:

  • I’ve used Etcher on Windows to flash HAOS to SD/USB (but not SDD) → no freezing
  • I’ve used Etcher on live Linux to flash HAOS to USB (but not SDD) → no freezing

But Etcher on live Linux flashing HAOS to SDD → freezing of OS.

1 Like

:slight_smile:

I concur with Keydi’s conclusions. This seems to be this very specific set of inputs that lead to the issue.

1 Like

In short: I confirm the solution worked! :blush:
Here are the steps (from the beginning):

  1. create bootable Ubuntu LTS USB Stick
  2. UEFI boot the machine from the USB stick
  3. “try” Ubuntu (live from USB stick)
  4. download haos_generic-x86-64-10.5.img.xz
  5. download USBimager & extract from zip file
  6. delete everything from the MMC disk with the disk utility
  7. create one big Ext4 file system partion with disk utility
  8. move haos_generic-x86-64-10.5.img.xz to /tmp (for finding it easier later as sudo)
  9. sudo usbimager in a terminal window (otherwise it didn’t let me flash the disk)
  10. flash the mmc disk
  11. Reboot the Mini-PC and remove the USB stick

HAOS started right away

Additional steps:

  • Instead of starting with a vanilly system I uploaded a most recent backup file and rebooted again
  • Logged in - everything was working at first look! :blush:

Well, not everything. My add-ons didn’t start at the beginning. I had to reboot the host another time, now everything seems to be fine.

@nukem1232, @keydi, @k8gg, @everyone, thanks a lot for your support, and your dedication!

@nukem1232, apparently I lost the bet, a beer on me! :wink:

Whoever might need support: happy to help!
Damos

6 Likes

Great that you got it working but it seems way to complicated for a normal user to install this on a standard x64 system. It seems though that there is no easier way currently.

I don’t think that’s too complicated if you consider Home Assistant as a platform. It wouldn’t be manageable by a „normal user“ anyways.

Even if you’d take a Yellow, configuring HA and maintaining it needs a fair understanding of IT.

I did the installation from a Live USB Ubuntu onto a M.2 SSD Sata Drive in my newly purchased Lenovo M700.
I used Balena Etcher and I never got confirmation it flashed properly but HASS OS did boot up.
After restoring from a Full Backup, I ended up with some weird behavior with HACS. It came down to hassio-dns completely failing with a segmentation fault error.

cont-init: info: /etc/cont-init.d/corefile.sh exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun coredns (no readiness notification)
s6-rc: info: service legacy-services successfully started
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x17 pc=0xc00057]
goroutine 1 [running]:
gopkg.in/DataDog/dd-trace-go.v1/ddtrace/tracer.(*span).setTagError(0x136bf00, 0x7, 0x0, 0x7)
	/go/pkg/mod/gopkg.in/!data!dog/[email protected]/ddtrace/tracer/span.go:131 +0x57
[11:16:17] WARNING: Halt DNS plug-in with exit code 2

This results in DNS resolution issues for Components.

I’m currently reinstalling using the step from @Damos with USBimager.
I’ll update if this resolved my issue or not.

Thank you

EDIT:
image

It’s working flawlessly from the start. So Etcher + Live USB + SSD x86-664 generic Storage does screw up things.
Thank you @Damos, you solve my headaches better than any acetaminophen.

1 Like

@irogoff, thanks for sharing.

I think, using USBimager as an alternative should be mentioned in the documentation. I will raise an issue there.

Best -
Damos

Hi, Thanks for the walkthrough. This is my first venture into Home Assistant. It is terribly hard. I used the supervised installation, but couldn’t install etcher. When found the dependencies, it hanged at 32%. The image still seemed to work but with all cloud based integrations not working.

I have used RPi’s and have experience with programming and CLI. I tried the most basic installation method and I still can’t get it to work. I use a HP ELITEDESK 800 G3 MINI i5-7500T. I’ve got resilience, but even setting up home assistant seems to be too difficult for me :(.

3d day: I’ve been trying these steps but usbimager doesn’t show my SSD card, just the USB stick I use to boot. I followed all steps up untill step 10. There the SSD doesn’t show up in the dropdown of USBImager. Any ideas?

@JvDUnleashed, I recommend, when you start Ubuntu from the USB stick to start the hard disk utility (or whatever it is called), deleted all partitions from the SSD, and create one big ext4 partition.
Did this work?

Like the docs from usbimager suggested this is the default behavior but it can be as easy as attaching
-a when executing usbimager to have it shown all devices :point_down:

With ‘-a’, all devices will be listed, even system disks and large disks. With this you can seriously damage your computer, be careful!
bzt / usbimager · GitLab

:100:

And it should be seriously considered for a privacy respecting software like HA to ditch the suggestion of that etcher spyware completely. Not that it has a lot’s of bugs and is build on a EOL browser it probably also violates the GDPR, only works with advertisements and leaks data to various companies around the globe before it can be disabled (opt-in). In all this fancy dd to write & verify a disk image has grown bigger than HaOS! As today etcher takes more than half a gigabyte with dependencies. That HA suggest a software which does not respect privacy and user choice (opt-in instead of opt-out like HA does it) is something quite sad - many projects stopped already suggesting balena etcher adware / spyware :point_down:

USBImager shows that if you build a etcher like software without ads, trackers, eol browser and other dependencies it can do the same with a size smaller than half a megabyte (that’s thousand times less than etcher :warning:)

1 Like

Hi, That did work. Also, orange-assistant’s suggestion worked. Etcher did it’s job, USBImager did it faster. Apart from initial setup, HA’s versatility and usablilty amaze me to no end. I’m so happy

1 Like

Hey, thanks for taking time writing the manual. I’m trying it the same way as you’rem using Ubuntu.
I did everything, but my Usbimager doesn’t seem to see the ssd disk, even launched using sudo.
Any ideas on why that could be?

Yes, just read the last posts in this thread because four posts before yours @JvDUnleashed just asked the exact same question and confirmed it working just in the post before of yours! :man_facepalming:

And welcome to the community by the way :wave::wink:

Tried it, sudo usbimager -a
Still nothing , although I see the SSD in the system with ext4 file system and mounted

1 Like

@vsetotje, maybe the issue (and steps to check and solve it) are described here:

1 Like

doesn’t look that way. Also they are talking about usb .

couldn’t make it work on Ubuntu. But worked great on Windows 10 custom live USB after using it with -a .
So yeah, overall is looks like Usbimager solves the problem when balena freezes on 4 percent or 31 or what even number you get.

My homeassistant loaded before after 31 percent freeze and it seems fine, but it doest not work properly.
So now hopefully it will work. So thanks for the tip!

UPD: works like a charm!

1 Like