HACS question about adding repositories

So you added the repos… is it them listing the cards in the store?

And you select and tap install on the card you want? How do you know it hasn’t copied the card? (Not being funny but say WinSCP if you don’t refresh it it won’t show newly added cards) Also HACS does seem to need to refresh which takes a little time…

Thanks for the reply. I’m not able to check anything now but will do so later (or most probably tomorrow).

Some of Thomas’ repos added to default in HACS 0.7 now…


I could find card-mod which not only seems to have had its name changed from card-modder to card-mod and from a type: js to type: module without warning but also doesn’t seem to work…
(I have done browser refresh)


I wonder what that extra main.js file is?


Browser errors/warnings

card-mod and card-modder is not the same thing

1 Like
1 Like

Yeah as Ludeeus said it’s a different card that will eventually replace card-modder.

1 Like



Ok after being side tracked by card-mod I have tried again to install some other cards but maybe I am doing something wrong as none of them seem to work.



Gives me this:


And this:

2019-06-14 17:11:08 [custom_components.hacs.frontend] GET POST call for repository_register with new
2019-06-14 17:11:08 [custom_components.hacs.frontend] GET POST call for thomasloven/fold-entity-row with integration
2019-06-14 17:11:08 [custom_components.hacs.hacs] Starting repository registration for thomasloven/fold-entity-row
2019-06-14 17:11:08 [custom_components.hacs.hacs] thomasloven/fold-entity-row - Not Found
2019-06-14 17:11:08 [custom_components.hacs.hacs] thomasloven/fold-entity-row - Could not register.
2019-06-14 17:11:10 [custom_components.hacs.frontend] GET API call for log with get

I’m happy to raise an issue on GitHub if it really isn’t something I’m doing wrong.

It is something you are doing wrong, that repository does not exist :wink:
Every repo @thomasloven have for Lovelace plugins are prefixed by lovelace- :wink:

Thank you, I guessed it was me :roll_eyes:

Am I right in thinking that they are not all compatible yet?

Maybe :man_shrugging: I have never tried

Maybe… I add them as this url:
so maybe your shorthand isn’t working? I don’t use this card so speculation.

pasting thomasloven/lovelace-toggle-lock-entity-row and selecting plugin worked in my test

The shorthand worked in other cases, but not this one (and some others)…
Shall I raise an issue?

2019-06-15 09:13:29 [custom_components.hacs.frontend] GET POST call for repository_register with new
2019-06-15 09:13:29 [custom_components.hacs.frontend] GET POST call for thomasloven/lovelace-toggle-lock-entity-row  with plugin
2019-06-15 09:13:29 [custom_components.hacs.hacs] Starting repository registration for thomasloven/lovelace-toggle-lock-entity-row 
2019-06-15 09:13:29 [custom_components.hacs.hacs] thomasloven/lovelace-toggle-lock-entity-row  - Not Found
2019-06-15 09:13:29 [custom_components.hacs.hacs] thomasloven/lovelace-toggle-lock-entity-row  - Could not register.
2019-06-15 09:14:55 [custom_components.hacs.frontend] GET API call for log with get

Can you create a issue for it? That should have worked…

Done - let me know if you need anything else

1 Like

I just installed HACS on Hass.io and am now trying to add my icloud3 repository to it on the Settings page as a custom repository. I will be submit it to the store as store when I get a handle on how it works.

The repository is gcobb321/icloud3.
The device_tracker.py file is in icloud3/custom_components directory.

I have tried all kinds of file name combinations and can not get it to find the device_tracker.py file and an not figure out how it should be added. I’ve tried…


Changed the directory structure to custom_components/icloud3 and tried:
gcobb321/icloud (it starts scanning but still can not find anything)

The file type I’ve used in Integration since it is a custom component.

Every combination resulted in File Not Found error and Could Not Register message

Any help would be appreciated.

is correct.

The reason it did not work when you tested: