Hassio on PI4 with official SSD released bios support

Looks like they just released 5.8 as stable production.

Yes saw that today.

But also got a person with problems, his installation wouldn’t start up anymore.
There was a short blink on the ssd and then it stopped, he went back to 5.4 ( seems like there was a problem with his raspberry, version 5.4 doesn’t work…he is going to try a sd card again)

later today I will give it a try, and see if I can get 5.8 to work.

I tried to update to version 5.8 using the UI. But as @DavyRoswinkel mentioned, also on my Pi4 the HomeAssistant did’t start up anymore. I’ll check what’s possible …

I updated and it works fine for me.
My friend is back on a sdcard, as the ssd doesn’t seem to work anymore.
Broken or damaged ssd?? Or wrong settings for the Raspberry to bootup?? I don’t know yet.

I was able to fix the SSD boot problem after upgrading the OS from 5.4 to 5.8: For unknown reason, the boot partition of the SSD drive wasn’t updated correctly. Hence, I executed the following steps:

  • Download HassIO 5.8 image
  • Create an SD card with the new OS 5.8
  • Booting up HA with the new OS on the SD card
  • Shutdown the Pi
  • Copy the files of the SD card boot partition to the SSD boot partition (partition still existed after the OS update from 5.4 to 5.8)
  • Reconnect the SSD to the Pi4
  • HA boots from the SSD again as before.

I understand, that booting HA from SSD is not supported (yet). Hence, booting from the SD card and keeping the data files on the SSD might be hassle free for future updates.

1 Like

It is supported: Installing Home Assistant on a RPi 4b 8GB with SSD boot

Thank you for the link.

During the Home Assistant Conference (13.12.2020) Pascal Vizeli explained that the recommended way to use USB disks is for data only. The OS shall be loaded on the SD card (see conference video at 0h 20’ 30"). I should have written ‘not recommended’ instead of ‘not supported’.

Now I’m confused even more. The whole point of the USB disk is to remove the SD card once and for all. I even got Argon 40 M2 case to use M2 SSD drive with Raspberry Pi 4. Too many cards broken for me.
I guess I need to watch that part again and ask for clarification.

Thanks for the link :slight_smile:

1 Like

My argon one m2 is also ordered… so very interested in this thread

I see with the 5.8 update there is now an easy way to move the data from the sd to a ssd. Is there an easy way to update from 5.8 32 bit to 64 bit?

If you install HassOS 5.8 64bit it is not a problem to use a recovery backup which is 32bit. This is how I used it when switching from SD card to SSD disk.

Thanks. I understood this. I was asking if there was a way of doing this without going through the snapshot restore. How did you restore your recovery? All except os? Also can you just restore the snapshot thought the initial screen after HA comes up?
I believe this was added a couple of versions ago. Been waiting to go from sd to ssd for months. I have been reluctant as everything has been working so well.

I took snapshots of the original system, wrote a HassOS 5.8 64bit image to the SSD and had it run on Rpi without an SD card. I installed SSH and Samba and copied it to HA and then restored the backup.

Did you restore everything?

Yes, everything has been restored. No problem and everything works fine.

1 Like

Watch that part again. Pascal clearly said:

the data disc is only usable for boards with sd card only support.

So I guess that’s not the case with Raspberry Pi 4 :slight_smile:

read this:

1 Like

I want to tell you in advance that it is not against anything and no one. I know that this is a voluntary and leisure project, and I am glad that it exists and is evolving.
If I go back to running the SSD. I asked myself, why is it not recommended? Problems reported by the user, whether incompatible with the device, software, firmware. Yes, these issues are reported by users, but why? Yes, they want to have a stable system for several years, because it is not a toy, but it controls our home. They don’t report that their SD card has been destroyed, they just buy another one and continue. I see the main problem here, because no one knows how many such devices were affected by the destroyed SD card.
I believe that the SSD boot will be tuned and supported in the future, but it is still a long way off.

2 Likes

Did you database restore correctly? I just saw on discord that the database needs to be stopped prior to the snapshot of it will be corrupted. I’m going to try again and see if it works for me.

Yes db was restored correctly. Today I run on a stable system Rpi4 8Gb HA 2020.12.1 HassOS 5.9