Hassio WIreless config

I can’t seem to figure out how to enable the wireless adapter on the Pi 3 using the Hassio image. Any help? TIA.

I appreciate the help but, is there no way to do this ssh’d into the pi? Seems like the settings I put in the file should be accessible somewhere. What happens if I change my wireless info? Do I have to turn off the pi and then pull out the card, mount in my computer change the file and then put it back into the pi? Seems crazy.

1 Like

After you burn the image to your SD card, mount the card on your computer and edit the file: /system-connections/resin-sample (or copy it to a new file like resin-wifi which is what I did…)

Edit the information so that it is something like this:

[connection]
id=resin-wifi
type=wifi

[wifi]
hidden=true
mode=infrastructure
ssid=My Awesome Wifi Ssid

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

[wifi-security]
auth-alg=open
key-mgmt=wpa-psk
psk=super_secret_wifi_password

Eject the SD card from your computer, then put it in your Raspberry Pi. That should get you connected. Once it is up and running (takes about 20 minutes with a fast internet connection) you can install the SSH components and then connect as normal.

2 Likes

i tried the resin config file and it did nto connect to wifi router. I have it up and running on ehternet(eth0).

After SSH install ifconfig doe not show the wifi interface.
Someone with Docker image expertise - please post how to troubleshoot/configure wifi

You cannot update wifi through SSH ( that is what people are trying to tell you). You have to install it by adding the config file in your PC. SSH does not have access to the /boot partition where the config files reside.

Read the link @fabaff gave you; that is everything you will need. Worked perfectly for me.

1 Like

Did you update to the correct SSID and Password?

Change “My Awesome Wifi Ssid” to the SSID of your wireless network and “super_secret_wifi_password” to be the correct WiFi password in the example i gave above.

The only other thing I can think of is are you using wpa-psk as your security on your WiFi?

Yes. I got it working. It was just surprising to me that it could not be done from an ssh terminal. Sorry for the late reply. Thanks for the assistance.

Hello,

I had the same issue and I solved it in 2 hours.
I tried all solutions above, what helped was:

  • formatted the SD card (I use 128GB) again in FAT on my macbook
  • i ejected the same hassio to the SD card
  • entered my wifi and passwort like mentioned above

i did this three times and then it worked …

hope this helps…I can also only enter the file by the IP: 192.168.2.109:8123 which I got out of my router

Hi all, I can’t login with wifi, configuration as above. Are there any resin logs? I haven’t found yet, but they would help very much. Is there any chance to change the wifi without always moving the sd card from raspbian to pc (like https://docs.resin.io/deployment/network/2.x/#changing-the-network-at-runtime)? It takes very long just to try if parameter tweaks have any effect.

It’s working for me, but I found out that Hassio drops the WiFi connection as soon/as long as there is a LAN cable connected.

Thank you , I was trying to figure out why the wifi card wasn’t being displayed using ifconfig.

I was able to connect to wifi using the NetworkManager interface at the command line while booted in the pi. Key was to have my pi connected to a keyboard and monitor rather than through ssh. When it boots, login as “root” to get to the HASSIO application, then at the hassio prompt, type “login” and it will dump you to the shell prompt of the OS.

Once there, you can connect to a wifi access point via:

nmcli d wifi connect <WiFiSSID> password <WiFiPassword>

that will connect you and generate a file /etc/NetworkManger/system-connections/ all filled in for you

7 Likes

Thanks @baharris18 for the assist. I wanted to change my SSID and password as well, without editing the SD card and found the network manager command to work, with a slight tweak: `nmcli d wifi connect “my ssid” password “my_password” . I had a terminal and keyboard already set up so it was easy to access the PI command line from the terminal console.

1 Like

thanks, edited my post (didn’t check how it rendered with braces <> first… doh)

Once wifi is setup can ethernet still be used? Is there a way to set connection preference? Can I use both at the same time?

I’m looking for the ability to go wired or wireless if I need to relocate the rPI for configuration w/o needing to login and change anything.

hello @baharris18 will you please help me out i’m getting below error when i try this

Nmcli d wifi connect MYSSID password MYPASSWORD

it shows error: connection activation failed: (7) Secrets were required, but not provided.

1 Like

This is a great thing to find! Thanks!

Now, the interesting problem.

I’ve been testing/settting up home-assistant at my apartment in preparation for moving it (and me) aboard my sailboat. The SSID that I will be connecting to on the boat is not available here at the apartment, and I don’t have a keyboard/monitor available at the boat.

When you run the “nmcli d wifi connect”, it assumes that the wireless network is available at the time that you run the command… (sigh).

Any ideas on how to configure this without the SSID being available?

Can you set the ssid at the boat?

Why so serious?

Enter

nmtui

and have Fun