HassOS 3 released! Raspberry Pi 4 support

A bit behind the original timeline, but we happy to announce, we’ve released version 3 of Hass.io Operating System: HassOS. Just in time for Christmas!

TL;DR; A quick summary of the changes:

- Official RPi4 support
- Linux LT 4.19
- Buildroot LT 2019
- USB-boot capabilities for the RPi3
- SMS integrations with USB/GSM modem
- Qemu Agent support
- Optimized kernel for virtual appliances
- Improved automatic disk expansion
- Initial foundation for offloading the data partition

Raspberry Pi

We support now officially the Raspberry Pi 4 on this stable version of HassOS! The Raspberry Pi 4 is a great and powerful device to get you started on Hass.io and Home Assistant.

@rbray89 worked hard on this release to add the very often requested USB-boot support! Please note, this is currently limited to RPi3 devices. carefully read how the USB boot works and be aware of the limited supported hardware

Hypervisors / Running HassOS on a Virtual Machine

The HassOS image for virtual appliances did get some beautiful updates as well. We have optimized the Linux kernel to support more virtual hardware.

We have now included the Qemu Agent in HassOS. So if you are running on a Hypervisor that is Qemu based (e.g., Proxmox), you now have a lot more information in your Hypervisor control panel, proper shutdown support and improved support for backing up/snapshotting your virtual machine.

Finally, the automated disk expansion got some updates. So if you need more disk space in your virtual appliance, add it in your Hypervisor and HassOS automatically pick it up at the next boot.

We want to emphasize that running Hass.io as a virtual machine is the only supported method to run Hass.io on a virtualized system. We’ve lately seen some funky tutorials on how to run Hass.io inside a container like Docker or LXC, which we DO NOT recommend, you will end up having issues.

How to update to HassOS 3

If you are already running HassOS, you have the full flavor of Hass.io, and thus, all the comfort it has to offer, making this upgrade a breeze!

To update via the user interface, go to the Home Assistant frontend, click on Hass.io in the sidebar to go into the Hass.io Panel. Next, click on the System tab and press the UPDATE button in the “Host system” panel. In case the update isn’t showing up yet, push the RELOAD button on the “Hass.io supervisor” box first, which makes your system look for updates instantly.

Another option is to our powerful CLI that is shipped with the SSH add-on. Run the following command to trigger the upgrade: hassio os update --version 3.7.

This is a companion discussion topic for the original entry at https://www.home-assistant.io/blog/2019/12/17/hassos-release-3/

Happy holidays

Thanks for the holiday gift!

So this method is not supported any longer, since it’s running HassIO in docker?


@flamingm0e you’re talking about Hass.io, but the news about HassOS.

Perhaps you should re-read the paragraph I quoted.

+1, VirtualizationStation on QNAP, Ubuntu as Host-OS. Also not supported? Cos it’s working as hell :wink:

1 Like

Happy holidays 2UAll!

Still got the problem my RasPi 4 is getting really hot because the PoE-HAT ventilator is never running.

Please help!

Does the USB boot mode work with the “Special bootcode.bin-only boot mode” mentioned here?

Edit: where you keep the SD card in the Pi with the latest bootcode.bin file?

which image should I use for Proxmox / Libvirt (qcow2)? Unfortunately only the following hard disk files are available: vdi, vhdx, vmdk.

That method is still supported. Let me clarify a little.

The thing that keeps popping up, is running Hass.io + Docker + Home Assistant + the add-ons in a single (Docker or LXC) container. So it becomes a sort of Docker ecosystem running inside a single Docker container construction (Docker in Docker for short, a containerized system).

Running Hass.io on top of a Ubuntu Server + Docker (referred to as the Generic Linux installation) is supported and documented (Either bare metal or virtualized system).

I’ve not seen this.

I have seen people running hassio in LXC, but not seen ANYBODY recommend docker inside of docker (that’s just stupid anyway). But the OP does not state it in a clear manner. It only muddies the waters, yet again, with the naming conventions.

Again, the OP does not reflect this, and since this is an official announcement, it’s only going to confuse people. A lot of people refer to the “Generic Linux Install” as HassIO in Docker.

1 Like

There is no such thing as running Hass.io in Docker. We do not use and actively discourage that term all the time since it is confusing on many levels.

Yes, and they should not. Since Hass.io itself doesn’t support LXC, so it must be a Docker ecosystem running inside the LXC (since LXC and Docker are both containerized, it became the container inside a container construction). We had a lot of issues created, because of that setup.

Will adjust that, since this is the second platform I’ve got feedback on that.

1 Like

Hi, for all of You update work smoothly?

i get an error in log
Can’t fetch versions from https://github.com/home-assistant/hassos/releases/download/3.7/hassos_rpi4-3.7.raucb:

I tried download just file from url

no success

I understand, but you have to realize the audience that we are dealing with are jumping in on this not understanding how any of the technology works. It is very commonly referred to as running HassIO in Docker. Correcting them merely creates conflict…

Totally agree.

Thank you.

Hmm interesting.

That URL works on my end? I’ve just downloaded it with my browser. So if I understand correctly, you are unable to download that file on your regular computer as well?

We never gave in to that, and will not give in to that, because it is technically wrong and incorrect. Accepting that term will cause more damage in the long run. That statement is not a brand name or term, it is just factly wrong. There is no where we can go with that.

Hi, Yes, tried via

  1. update button
  2. command line

and error as mentioned earlier

3rd option I planned to downolad file from link and update via usb, but not able to finish download on PC browser

ok, after few attempts finally I was able to download file and update via usb

by, update button, | was no able to upgrade

I’ve tried to download the file from GitHub from multiple locations multiple times, and all succeeded. I’m sorry, I cannot think of anything that might have caused your issue. However, I’m happy you managed to punch through.

Thanks for this (personally and for many others looking for a halfway house before a NUC)
I have a hub on order (for z wave stick) and when it arrives I’ll be doing this ! :+1:

Given the rpi3 boot from usb, would I be right in assuming that an rpi4 update will be coming shortly ? (6 to 12 months ?)

Thanks again for all the great work
I will be toasting ALL the devs and other contributors tonight :beer:

Edit: This is NOT going to happen quickly, it is dependent upon many things, not all under HA control, see kanga_who’s post below for the detail.