HassOS installation/network problem on Intel NUC

I’m trying to run Home Assistant OS on a brand new Intel NUC NUC11PAQi7 Panther Canyon.
The problem is that after plugging in an Ethernet cable and installing HassOS, the device does not show up in my network (I’ve used a network scanner and also checked the router config page).
http://homeassistant.local:8123 can’t be reached.

So far, I’ve done this:

  1. Tested Ubuntu Desktop on the same Nuc to verify that WiFi and Ethernet are both working properly to rule out any hardware issues. I was able to discover the device with a network scanner.
  2. Flashed hassos_intel-nuc-5.13.img.xz to the M.2 SSD with Balena Etcher and an external M.2 USB-C enclosure.
  3. Connected a working Ethernet cable
  4. Waited >30 minutes after booting the NUC

A connected monitor displays:

Welcome to Home Assistant
home assistant login: [ 62.6480831] hdaudio hdaudioC0D2: Unable to bind the codec

After logging in with root and typing “network info”, I get:

 interface: hassio
host_internet: false
interfaces: []
supervisor_internet: false

Could it be that the network adapter for this Nuc is still unsupported?

Please, confirm if your client pc address you’re trying to reach home-assistant with is not in the 172.30.x.x range.

Could be. I had this exact issue on a newer PC I tried to set up.

Installing supervised worked as the NIC driver was included in the Ubuntu LTS OS (this was before Debian was made the official OS).

The client PC is in the 192.168.x.x range

Interesting – where could I raise this point and request for inclusion of the appropriate drivers for the new Nucs?

Possibly the GitHub home assistant OS repo, however it may be classed as a feature request and you may be directed to that category of these forums.

Thanks, I’ll give that a shot.

excuse me but when u say supervised worked
what do u mean ?
did u install ubuntu and then HA on a docker ?
or HA directly on nuc ?

im trying to install HA as an OS on nuc, but cant get it to reconize the NIC

Yes I installed a Linux operating system that supported my NIC then installed Home Assistant OS using the Supervised installation method. See this guide:

as i thought
so basically theres no way to install HA as OS on my nuc11?

and which linux OS did u install
i tried debian buster countless times but ran into a lot of issues

Not if it does not have the required network driver.

Supervised is essentially the same thing, you just have to keep the system OS up to date yourself.

It’s like the container install method, but with the supervisor container to manage addons.

If you are comfortable with Docker, you could use the container install method. Instead of addons you manage the extra containers yourself.

I used Ubuntu server LTS. But that was a long time ago. I would not recommend it. Only Debian (not its derivatives) is officially supported. See the link I posted above.

yes looking at that link
i tried those versions and they all stop at installation because not finding the driver for the NIC

I am having exactly the same problem with a new NUC 11 i5.:
Installed 5.13 onto the internal SSD, and Hass OS appears to run, also complaining about hdaudio, but no network - WiFi or wired.
There also was a network when booting into Ubuntu.

(I don’t want to go supervised as I don’t use *nix otherwise, so it would add an unnecessary extra layer I’d have to manage.)

… trying the supervised method: tried to install Debian 10.9.0, and the installer says it can’t find the ethernet card…

I created a new issue in the Home Assistant OS repo as advised by @tom_l. Agners already made a commit to resolve the networking issue. The fix should be included in the next release.

Currently I’m running the dev build haos_generic-x86-64-6.0.dev20210419.img.xz from https://os-builds.home-assistant.io/ and I can confirm that this build connects to my network with no problems.


Thanks guys!

are you running this version on your intel nuc 11 ?


having the same issue still, ended up working with a usb to ethernet card for now but obviously not an optimal solution

That build is an older one from 26 February and does not include the relevant commit.

Hi All,

I want to get me a NUC 11, is the issue resolved? The NIC (2.5GbE) is working now? I want to run HA generic. Thanks.