Installing Home Assistant on a RPi 4b with SSD boot

Tags: #<Tag:0x00007fc418161fa0> #<Tag:0x00007fc418161eb0>

Is there a cli command in home Assistant to find the firmware version?

When you hit the three dots in the supervisor, where does the backup file need to be?

Maybe there is a command via the terminal. I haven’t found it yet. I checked the fw version when I updated Rpi before I installed HassOs.

If you update via the boot utility with no keyboard or monitor I don’t believe you can get there?

In step one I downloaded the latest snap shot to my PC. When it came to restoring the system I used the upload snapshot feature to upload it from my PC to the Pi.

1 Like

I basically used the same things that are described here.
Yes, if you use SD and fw to update then you only rely on having the last one.

In putty, I verified the version using the command: vcgencmd bootloader_version

It would be nice if you could do a similar command from cli once home assistant is installed.

Maybe it would be enough if the fw version was in the information overview.

2 Likes

How long did the restore take?

The restore seems to work with 4 errors in my logs. I believe all are related to the maridb.

The following integrations and platforms could not be set up:
recorder
history
logbook
default_config
Any ideas on how to fix these?
Found the issue. The db (maria) was corrupted. You must stop the maria add-on prior to creating the snapshot. I tried again and no errors or need to uninstall mariadb.

1 Like

When I switched from SD to SSD, I also had some db errors. I knew I would delete the history, delete the db, and restart HA. The database started to create a new one and no more errors. Maybe there’s another way to keep history, but I don’t know which one.

I had to uninstall mariaDB reboot and reinstall. Still having an issue with recorder. I had

##  db_url: mysql://[email protected]/homeassistant?charset=utf8

It gets errors with this. Not sure what changed, but something did as this was the identical file.

I’m using default db so I really don’t know where to look. Maybe someone else can advise.

1 Like

Something has changed from my update to the SSD. If I setup the recorder as called out in the docs, it fails.

recorder:
  db_url: mysql://homeassistant:[email protected]/homeassistant?charset=utf8

Can’t find database. WIth the SD card no issue.

Simply kick out the db_url line and recorder will default to the built-in sql lite database. No need for Maria with the RPi4 and SSD.

Thanks. What I did is changed the charset=utf8 to charset=usf8mb4 (no idea what the difference is) and t works again. By the way, the boot image directions above worked for me also and very it was very quick. Only issue on the restore was with mariadb and it is now working again.

Better make that charset=utf8mb4
There is no usf…
Actually this charset should only be needed if you store Chinese or emoticons or maybe Klingon in your database.

It is utf8mb4. Typo above. I have no idea what it should be. Nothing in the recorder docs or mariadb. I just copied the default.

https://lmgtfy.app/?q=utf8mb4

I would support this idea. I guess a request for this “functionality” is required on github or on this forum in the section for new requests ? Which is better ?

FYI. I am running RPi4B with 4GB on SSD since Dec. 4 (Unitek Y-1039B USB-SSD adapter and Samsung SSD 860EVO 500GB) and today made upgrade to 2020.12.1 and then OS to 5.8 from Supervisor UI. Both went fine in few minutes.
Then I rebooted the host (also from Supervisor UI) since my MCP23017 integration did not work (this is known issue and not related to latest upgrades - I have to reboot after each OS upgrade or in other specific cases) and also with no issues system came back in few minutes - this time everything is working fine.