Hassos will not update

I’ve raised an issue for this on the hassos github, but am also seeing if anyone has had a similar problem here.

Screen shot:

There is no further detail after the yellow message (but do also note the red text 502 bad gateway). A single time, it said:

Cannot connect to host github-production-release-asset-2e65be.s3.amazonaws.com:443 ssl:None [Try again]

but I have tried several times (at least 15) and normally there is no follow up message.

Anyone else having any similar issues or know a solution?

Hass.os issue: https://github.com/home-assistant/hassos/issues/346

Yep. Exactly the same issue.

19-02-10 23:53:58 WARNING (MainThread) [hassio.hassos] Can't fetch versions from https://github.com/home-assistant/hassos/releases/download/2.8/hassos_rpi3-2.8.raucb: Cannot connect to host github.com:443 ssl:None [Try again]

Had similar problems updating, but it worked as I started the update from the command line (ssh). Maybe it’s worth a try?

Hi, I did the update from 1.13 to 2.8 yesterday without issue.

I’m using wired ethernet on a RPi 3

I would check your internet connectivity, are you able to manually download the hassOS images from github?

I am; on my phone or laptop connected to the same network. (but my pi is wired ethernet).

How do you do this? Is this the Hassio SSH or the Host SSH?

Ok, which Pi are you using?

On your laptop, are you able to download any of the files form the hassOS releases page here:

I have downloaded them successfully over the last couple of days, but I’m not currently home to be able to try again.

I have a Raspberry Pi 3B running my home assistant.

I think there’s a way to do some sort of offline update to hassos.

You may be able to copy hassos_rpi3-2.8.raucb to a usb stick and then do an offline update

EDIT: One more thing to try is disabling any HASSIO addons, a firewall or DNS addon could be causing network issues


Yeah, I’ve read about that offline method. But I’d prefer to try and fix this issue first. This method has always proven reliable to me; I’m concerned I’ll get something wrong doing a more manual update!

Well, I did it with hass.io SSH, see here for all commands:

Good luck!

Thanks - but looks like “hassio host update” is no longer available; I can only do

hassio host info/options/reboot/reload/shutdown

Upps, NoNoNo, just use hassio homeassistant update
Your Host-System should not be touched!

But doesn’t that just update Home Assistant? I’m looking to update Hass.Os.

You’re right, thats another topic :wink:

In this case I strongly recommend

  1. backup the configuration (YAML and all other custom files…)
  2. “Bare Metal” installation of hass.io
  3. reinstall add-ons
  4. restore your configuration

Definitely the cleanest solution, and by the way, the ideal opportunity to replace your used SD card with a new quality SD card. Just to be on the safe side…

I have the same issue with 101.2

19-11-05 03:24:36 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.101.2
19-11-05 03:24:36 INFO (SyncWorker_22) [hassio.docker.interface] Update image homeassistant/qemux86-64-homeassistant:0.100.3 to homeassistant/qemux86-64-homeassistant:0.101.2
19-11-05 03:24:36 INFO (SyncWorker_22) [hassio.docker.interface] Pull image homeassistant/qemux86-64-homeassistant tag 0.101.2.
19-11-05 03:25:43 INFO (SyncWorker_22) [hassio.docker.interface] Stop homeassistant application
19-11-05 03:26:45 INFO (SyncWorker_22) [hassio.docker.interface] Clean homeassistant application
19-11-05 03:26:48 INFO (SyncWorker_33) [hassio.docker.homeassistant] Start homeassistant homeassistant/qemux86-64-homeassistant with version 0.101.2
19-11-05 03:26:58 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
19-11-05 03:27:13 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
19-11-05 03:37:14 WARNING (MainThread) [hassio.homeassistant] Don't wait anymore of Home Assistant startup!
19-11-05 03:37:14 CRITICAL (MainThread) [hassio.homeassistant] HomeAssistant update fails -> rollback

I got that too

Same issue over here

I would like to update System HassOS 3.3
But see error in logs:
19-12-20 14:58:19 WARNING (MainThread) [hassio.hassos] Can’t fetch versions from https://github.com/home-assistant/hassos/releases/download/3.7/hassos_rpi4-3.7.raucb:

How fix it? I would like to update HassOS…

Same error for me. Any ideas?
If from CLI or WebUI, it’s the same error. Thought it’s temporarily, but Dimitrys post Hassos will not update indicates it’s not.
I am using standard hass.IO Installation on Rpi4

BTW: Is it recommended to do this update?

arch armv7l
dev false
docker true
hassio true
os_name Linux
python_version 3.7.5
timezone Europe/Berlin
version 0.103.3
virtualenv false