Hassos will not update


#1

I’ve raised an issue for this on the hassos github, but am also seeing if anyone has had a similar problem here.

Screen shot:

There is no further detail after the yellow message (but do also note the red text 502 bad gateway). A single time, it said:

Cannot connect to host github-production-release-asset-2e65be.s3.amazonaws.com:443 ssl:None [Try again]

but I have tried several times (at least 15) and normally there is no follow up message.

Anyone else having any similar issues or know a solution?

Hass.os issue: https://github.com/home-assistant/hassos/issues/346


#2

Yep. Exactly the same issue.

19-02-10 23:53:58 WARNING (MainThread) [hassio.hassos] Can't fetch versions from https://github.com/home-assistant/hassos/releases/download/2.8/hassos_rpi3-2.8.raucb: Cannot connect to host github.com:443 ssl:None [Try again]

#3

Had similar problems updating, but it worked as I started the update from the command line (ssh). Maybe it’s worth a try?


#4

Hi, I did the update from 1.13 to 2.8 yesterday without issue.

I’m using wired ethernet on a RPi 3

I would check your internet connectivity, are you able to manually download the hassOS images from github?


#5

I am; on my phone or laptop connected to the same network. (but my pi is wired ethernet).


#6

How do you do this? Is this the Hassio SSH or the Host SSH?


#7

Ok, which Pi are you using?

On your laptop, are you able to download any of the files form the hassOS releases page here:


#8

I have downloaded them successfully over the last couple of days, but I’m not currently home to be able to try again.

I have a Raspberry Pi 3B running my home assistant.


#9

I think there’s a way to do some sort of offline update to hassos.

You may be able to copy hassos_rpi3-2.8.raucb to a usb stick and then do an offline update

EDIT: One more thing to try is disabling any HASSIO addons, a firewall or DNS addon could be causing network issues


#10

Thanks,

Yeah, I’ve read about that offline method. But I’d prefer to try and fix this issue first. This method has always proven reliable to me; I’m concerned I’ll get something wrong doing a more manual update!


#11

Well, I did it with hass.io SSH, see here for all commands:
https://www.home-assistant.io/hassio/commandline/

Good luck!


#12

Thanks - but looks like “hassio host update” is no longer available; I can only do

hassio host info/options/reboot/reload/shutdown


#13

Upps, NoNoNo, just use hassio homeassistant update
Your Host-System should not be touched!


#14

But doesn’t that just update Home Assistant? I’m looking to update Hass.Os.


#15

You’re right, thats another topic :wink:

In this case I strongly recommend

  1. backup the configuration (YAML and all other custom files…)
  2. “Bare Metal” installation of hass.io
  3. reinstall add-ons
  4. restore your configuration

Definitely the cleanest solution, and by the way, the ideal opportunity to replace your used SD card with a new quality SD card. Just to be on the safe side…