Home Assistant installation sur une Freebox Delta (VM)

Bonjour,

Si cela peut servir, voici comment installer Home Assitant sur une Freebox Delta.
Il faut tout d’abord installer une machine virtuelle Debian 10.

Une fois installée, démarrez la machine virtuelle, puis allez sur la console.

Dans la console, identifiez-vous (login: freebox, le mot de passe que vous avez indiqué à l’installation).

Ensuite il faut faire les étapes suivantes (attention certaines sont un peu longues, il faut patienter):

sudo -i

apt-get install -y software-properties-common apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq socat network-manager

apt-get update

apt-get upgrade

curl -fsSL get.docker.com | sh

systemctl start docker && systemctl enable docker

curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s – -m raspberrypi4-64 -d /home/hassio/hassiocfg

L’installation (ou lors d’un redémarrage) va s’arrêter sur: « udevd[8]: starting eudev-3.2.8 »

Il faut alors ouvrir dans un navigateur: 192.168.0.xx:8123
L’adresse a indiquer étant celle de votre machine virtuelle.

2 Likes

Anglais s’íl vous plait.

Check with the guy from this topic

He may be able to help you.

Here’s the jist of it in English.
Un grand merci a Kriss30 pour ce post (Big thanks to Kriss30)
How to install Home Assistant on the french Freebox Delta VM.

  1. Install Debian 10 in a VM (I tried using Ubuntu 19.10 but that doesn’t work. It has no docker image. It might work with Ubuntu 19.03, but I haven’t tried).
  2. Connect to the terminal on the VM and execute the following commands:
    sudo -i
    apt-get install software-properties-common
    apt-get update
    apt-get install -y apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat
    curl -fsSL [get.docker.com](http://get.docker.com) | sh
    systemctl start docker && systemctl enable docker
    curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s -- -m raspberrypi4
    All this will take a while - it took around an hour on my connection. It will download and install loads of software. You may need to restart some of the commands. I had to run the last command twice because it timed out the first time
  3. Now use your computer’s webbrowser to connect to the ip 192.168.0.xxx:8123 where 192.168.0.xxx is the IP of your VM.
  4. Configure Home Assistant

This worked flawlessly for me.

bonjour ou bonsoir,
j’ai essayé cette methode mais arrivé à curl -sL https://raw.githubusercontent.com/home-assistant/hassio-
j’obtiens ceci,
[email protected]:~# curl -sL https://raw.githubusercontent.com/home-assistant/hassio-
400: Invalid request

The second line also belongs to this command, you should type the below command in one line:

curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s -- -m raspberrypi4

En réponse à DjWils74, c’est une seule et même ligne de commande:

curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s – -m raspberrypi4-64 -d /home/hassio/hassiocfg

Sorry for french in this tread, but this step by step is specific for french user of “Freebox Delta”, a box of french web operator. With the step by step write in french, the users who don’t speek english could find how to install HASS into the Freebox Delta.

je pense que j’ai dû me planter quelque part avant. j’ai supprimer la VM et refait toute l’installation en suivant vos instruction et du coup tout fonctionne parfaitement.
merci beaucoup.

Glad that it works now. Just for you information, the forum language is english, please don’t post in a foreign language, otherwise most of the people will just ignore your post.

ok, sorry if it disturbs. this post is about a box of a french operator, I thought only French could answer it.

It’s not disturbing for me as I understand french more or less. It’s just the forum language, so everyone should use it. And even though it is a french box, it was me a non-french person, who doesn’t own this box, who was able to help the person in the above linked topic to setup home assistant on the Freebox. With this I want to say, that more people will be able to help you, even if they don’t own the box, to solve your problem if you formulate it in English :slightly_smiling_face:

I think in this case I think French is ok. It is not a request for help, it is a howto specific to French people only.

Hello everybody,
I’ve installed HassIO the way as described above.

Everyything goes well and the install finishes with “Run HASSIO” without any issue.
I’m running everything on Ubuntu 19.04 (Mosquitto, Node-Red and Hassio).
Now when I go to 192-168-1-253:8123 I’ll get the "preparing HASSIO screen) which will not go away even after waiting a couple of hours.
I rebooted a couple of times but no change.
I’ve removed hassio from docker and installed it with different machine-types ( qemuarm-64`, raspberrypi3, raspberrypi4, raspberrypi3-64 and qemuarm).
Happily hassio installs very quickly. All of these types have no issue, but the webpage keeps saying: “preparing hassio”.
Does anybody know what could be wrong?

Thanks for the help!!

Hi french guys, if anyone of you have some custom component / python skills and some DeltaDore devices at home : Delta Dore / Tydom Custom Component - Need help++

Sorry for little off topic, but those devices are french :slight_smile: