Home assistant on Synology: Docker vs VM

Hi all,

As you know the docker solution for synology is not (anymore) supported.
I did update docker and DSM…and this resulted on zigbee2mqtt not working anymore (400 Client Error no such file or directory).

So I decided to install Home assistant on a VM (Install Home-Assistant in a Virtual Machine (VMM) | GH2home)

It looks to work BUT: with the docker solution I was at 3-10% CPU usage.
With VMM, I’m at 80-100%CPU (and I haven’t configured anything on home assistant).

Do-you think It’s still a good solution to use a Synology to run home assistant? If so, what’s your solution?

For info, I have a DS218+

Home Assistant Container is still very much supported on Docker and Synology. That’s what I run and have no issues.

I think you mean the Home Assistant Supervised in a package which then itself manages all of the add-ons which are just Docker containers. My recommendation is to just run the docker containers yourself without the supervisor. It works the same way, just you are the supervisor.

1 Like

Nothing wrong with Docker on Synology here, first I’ve heard of it being unsupported.

What do you mean Docker is no longer supported on Synology? It is working fine for me…

You’re right, that’s the HA supervised that warns and blocks because of unsupported docker version…

For what I see, the container installation does’nt support add-ons (Installation - Home Assistant). So how do you install the add-ons?

You either find a similar docker container yourself or you don’t use the add-on.

PiHole is an add-on, but it’s also a docker container. Same with Portainer and many other HA add-ons.

1 Like

Yep, what @Razgriz said. The add-on is just a docker container. You find the docker compose or docker run command that the add-on uses and you run it yourself. Then you use the integration in HA to connect to the container. You become the supervisor and you manage running the container, configuring it, updating it, etc.

The biggest difference is your HA install will not have a supervisor tab or an add-on store. You’ll just have to search for the add-on in GitHub or these forums or elsewhere.

1 Like

OK Thanks, I understand…but I also understand It’s gonna takes me ages to replicate what I’ve done with the preconfigured solution.

It was easy because of the addons: zigbee2mqtt, nodered, zwave,…
I’ll try to find some tutorials

Good news is you can rip the settings out of the working add-on and insert them into the docker container.

Shouldn’t take too long to get up and running again. As long as you don’t delete the original setup, you can just keep on trying until it just works.

1 Like

Thanks for the tip, I’ll recreate step by step.
For now, my zwave devices are still working

Well…I give up. I tried during 2hours to run zigbee2mqtt docker.

I installed Home assistant to have a easy system to maintain…I don’t have the time and knowledge to manually do all those steps.

I understand It’s synology fault, It’s a pitty they don’t update their docker :confused:

I guess I’ll buy a RPI4 or try another system that is fully supported on my synology.

@Francois -
Something else is going on with your VM setup, if I have to guess.

DS218+, with Intel Celeron J3355 (Dual Core - 2.0 GHz/2.5 GHz Turbo), should have enough horsepower to handle HAOS. Searching around the forum here, for example, I can see a couple of data points hovering at 5-15% on CPU also.

I guess you have tried to increase RAM so that to run VM? DS218+ only has got 2GB to start with, and then HAOS VM is recommend to allocate 2GB per install guide.

What part of “unsupported method” do you not understand? The official installation methods of HA are OS, Supervised, Container, and Core. The method you were/are using is a community driven work around to get HA Supervised installed in an unconventional way. The two officially supported methods of installation on a Synology are Container and (to a degree) Core.

I’ve got a DS220+ with 8Gb of extra RAM, and experimented with both HAOS on VMM and HA in Docker. With VMM the Syno goes nuts, especially on CPU. On average CPU with VMM is 10x CPU with Docker. Even with multiple Dockers (for MQTT, Grafana etc.) CPU is constantly between 1 and 3%, and with VMM it never gets below 30% …

So, deleted the VMM and my whole system now based on containers

Yes I understand Container is the only supported method on Synology.
But I think that most of the people were not aware of that when they installed this supervised version. Lot of people now have a problem with their setup.

Same here DS218+ and 10Gb of RAM.

Just installing VMM is using 15-20% of CPU, without running any image…
Running the home assistant VM is working, not too slow (without any plugin) I gave It 4Gb of RAM.
But I don’t want my NAS to run at 80-100% non stop

Wow OK I didn’t expect this. Is this considered typical?

I have a 2-disk entry-level NAS (but non-Synology) with the same CPU, also a 2018 model. That box could/would run single HAOS VM image at 2-3% of CPU. So I thought things cannot be too drastically different. I was wrong, it seems.

Hi everyone!
As I am was thinking about switching my NAS to a DS220+ because it can run my HA + Grafana + Zigbee2MQTT etc. without the daily fear of the SD-Card dying, let me sum this up, that i understood right:

  1. I can install HA quiet easy in a docker container but just without the supervisor. Performance/Recources is good but if I want to install Add-ons it needs lots of tweaking and knowledge and much TIME - so nothing for me…
  2. I can install HA in a VM, everything should work there including easy maintainance for noobs with the supervisor but the CPU-usage is (strangely) exorbitant, so not recommended…
  3. HA in docker on the NAS supervised doesnt’t exist.

… so I best leave my NAS as it is an go for a dedicated OS on a e.g. Odroid N2+? Whats your opinion? Thanks.

Ture statements on all 3 accounts.

But… before you go buy something new, why not give the VM a try? Download the image, fire up VMM, give the HAOS VM some quick test drive, and monitor the CPU% along the way…?

Maybe yours being a DS220+, which is presumably 2 years apart from the DS218+ iteration, would run just fine. Maybe Synology has improved its VMM implementation somehow…?

There’s a thread recently on VM install also. Report your observations over there if you want to.

1 Like

Thank you k8gg. I can’t give VM on a synology NAS a try myself, because my NAS ist not a “+”, so not capable of running a vm.

Meanwhile I’m at the point that I wont go for a Synology to host my HA - sharing my thoughts:
As I want to change my HA-Hardware-setup away from my older Raspberry running from SD-Card, I thought it to be a nice and clean solution for runing my HA, because 1) it’s a quiet powerful hardware 2) running anyway and 3) with optimal reliability and backup features. I have to take into my consideration the money I want to spend, the performance and reliability I get for this and the time I need to spend for setup and maintainance. As I was investigating about the topic HA on Synology during the last days I got away from the idea of ​​running my HA on a NAS and tend to a solution runnig it on its dedicated hardware because the time I need to spend seems to be way bigger, than I thougt. For exampe new problems ahead with the update to Synology DSM 7 (Anyone installed Hass.io on Synology DSM 7? - #6 by Volker_Steiger) as well as the issue with the high CPU-Loads.
If I go e.g. with a RPi 4 8GB + SDD I will have a good enogh performane for the next few years, a little less reliability but I can be sure that the software will stay supported very well and user-friendly for this platform, as it is the main used one.