Home Assistant OS 6: Release Candidate 1/2/3 (testing welcome!)

Tags: #<Tag:0x00007fc3fee04ec0>

Hi all,

With OS 6 we are changing the testing phase of the OS a bit: In the past pre-releases received a regular version number. From now on pre-releases will use the upcoming major/minor version, plus a release candidate designation, e.g. this first pre-release has the version number 6.0.rc1.

The 6.0.rc1 build is complete and available to download on the Operating System’s Github release page.

This new release comes with the latest Linux kernel 5.10 LTS on all platforms, the latest U-Boot release 2021.04, an updated build system Buildroot 2021.02. The integrated Docker Engine version is now 20.10.6.

Also new in this release is a component called “OS Agent”. It will improve the communication between the Supervisor and the Operating System. It will enable new features, such as enabling the data disk from the user interface. This is still work in progress, so stay tuned for updates in the future.

The user facing naming (e.g. file names) has been changed from hassos to haos. We also renamed the intel-nuc board to generic-x86-64 since the image is meant to support more than Intel NUC systems. Existing intel-nuc installations will get migrated to generic-x86-64.

The full list of changes is available on the Github release page.

Pascal and me have tested development releases as well as this release candidate on various platforms like ODROID-N2+ (Blue), Raspberry Pi 4 64-Bit, Intel NUC and Linux Virtual Machine Manager (KVM). My production instance runs OS 6 development releases since quite a while, so it is generally stable. But, before releasing OS 6 some testing by a larger audience is welcome!

You should feel somewhat comfortable around Home Assistant OS and in the terminal, just in case…

New installations as well as updates can be tested.

Important: If you decide to upgrade your active installation to 6.0.rc1, please take a snapshot and download it, just in case :slight_smile: !

~ $ ha os info
<make sure you are on 5.13>
~ $ ha supervisor options --channel=beta
~ $ ha supervisor reload
~ $ ha os update
<this will update and reboot your system>
~ $ ha supervisor options --channel=stable
~ $ ha os info
<verify version has been updated>

You should now be running the latest OS 6.0.rc1 version.

It is safe to keep running your installation on 6.0.rc1. You will be able to update to the final release. In case you want to downgrade anyway, you can use this commands (make sure to switch to the stable channel first):

~ $ ha supervisor options --channel=stable
~ $ ha supervisor reload
~ $ ha os update --version=5.13

Note: OS 6 can only be downgraded to the lastest OS 5 release 5.13. However, from OS 5.13 it is should still be possible to downgrade to older releases.

Note 2: A downgrade of ageneric-x86-64 (OS 6) board to OS 5.13 using the console is not possible. This is due to the renaming of the board: OS release 5.13 uses intel-nuc. You can downgrade by using a USB flash drive: Store the hassos_intel-nuc-5.13.raucb on a USB flash drive with the file system name CONFIG. Use the “Import from USB” from the user interface, this should trigger the downgrade and a reboot. You can also re-install and restore the snapshot.

I am aware that several people have stability problems with later OS 5 releases on various setups. Unfortunately, so far I haven’t been able to reproduce or pinpoint this stability issues. Please test if you experience this problems also with release 6.0.rc1. If the problem is also reproducible with OS 6.0.rc1, please report in the respective issues (or create a new issue). I plan to invest more time trying to find the root cause of this issues.

Report bugs/regressions on the operating system issue tracker.

Update May 28th 2021:
Meanwhile we arrived at 6.0.rc3! With the latest Supvisor supervisor-2021.05.3 updating to it should work also on Intel NUC (the board type will automatically migrated to generic-x86-64, which is the new board supporting Intel NUC and other x86-64 machines).

Thanks & cheers,
Stefan

10 Likes

Outstanding work Devs! I upgraded from 5.13 about 5 hours ago. Running rock solid on my Raspberry Pi 4 64-Bit.

1 Like

Hmmm tempting! Have kept my production on 5.2 just in case since that was stable for me (Rpi4 on SSD) and didn’t see any great advantage on later releases.

Then again [email protected] running beta on everything else so I might as well dip my toe all the way :smile:

1 Like

very very much appreciated !
i have an intel nuc 11 and it was a nightmare getting anything to work on it since its a new hardware.
id like to ask though, i usually stick to stable releases but would like to try this RC
my question is once a stable release will come out(any idea when will that be?) will i be able to just upgrade to it through the HA interface ? or do i need to go through the process again from scratch - i usually pull out the ssd from the nuc, flash the image with balena directly on it and put back in

@Ron_Azulay when the stable release will come out will depend on how the testing phase fairs. I expect it fairly soon though (this month).

Yes, upgrade to the final OS 6.0 release from OS 5 or OS 6.0.rc1 will be possible through the HA interface.

1 Like

awesome, thank you very much , i just installed the RC, it went super smooth
never seen my NUC booting up/restoring snapshot so quick !

I am trying to apply the update to my intel-NUC but getting an error:

ha os update
processing ... Done

Error: Error raise from OTA webserver: 404
1 Like

i am using a laptop with NUC img. getting same error too. :frowning:

Just upgraded my NUC7i3BNK from a 6.0dev release that I installed fresh a month ago (struggling, it won’t boot correctly when using balenaetcher to write the img to the disk, had to use Ubuntu live and write the img through its tools. I hope one day we’ll have a debian-like installer, so we can boot from a usb key and install on the internal drive).

This upgrade was smooth and fast, hope it will be stable too. :slight_smile:

Thank you for your work.

1 Like

@madrose you can both check on Supervisor that you are actually on Beta channel now. And if you are, try:

ha os update --version=6.0.rc1

404 errors are also showing if there is not enough free space for the image to be dowloaded so check you also have enough space

I had one of the dev6.0 running on some off brand chinese NUC.

5.13 image wouldn’t boot at all. Was getting stuck at Network Manager I believe. And the moment I booted the dev6.0 it was up and running in less than 2 minutes. Now updating to 6.0.rc1 the biggest difference I’ve seen is the RAM utilisation. It’s magntitudes better!

image

Hm, with channel beta and reload the URL should be correct for the new images.

Can you check the logs using ha supervisor logs after ha os update?

@drthanwho I tried that command and it is the same error. and I checked the space and I have 30% utilization only with more than 80GB free.

I am using Terminal & SSH addon, and I did notice that through putty I always get

bash-5.1# ha supervisor options --channel=beta
ERRO[0000] Unexpected server response. Status code: 401
Unexpected server response. Status code: 401

This error does not show through the web, but still I am not able to run the update.

log shows:

21-05-09 12:33:07 INFO (MainThread) [supervisor.hassos] Fetch OTA update from https://github.com/home-assistant/operating-system/releases/download/6.0.rc1/haos_intel-nuc-6.0.rc1.raucb
21-05-09 12:33:07 ERROR (MainThread) [supervisor.hassos] Error raise form OTA Webserver: 404
21-05-09 12:33:14 INFO (MainThread) [supervisor.api.security] /os/update access from core_ssh
21-05-09 12:33:14 INFO (MainThread) [supervisor.hassos] Fetch OTA update from https://github.com/home-assistant/operating-system/releases/download/6.0.rc1/haos_intel-nuc-6.0.rc1.raucb
21-05-09 12:33:14 ERROR (MainThread) [supervisor.hassos] Error raise form OTA Webserver: 404

plenty of space n other resources as seen here:

went back to terminal in gui to run this command:

ha supervisor options --channel=stable

now i see this option available

BUT when i click on update, i get this error
image

There is no such image present, no NUC image for rc1…

oh that’s a shame, i thought this would be similar: haos_generic-x86-64-6.0.rc1.img.xz

The image got renamed to generic-x86-64. So generic-x86-64 is the successor of intel-nuc.

Hm, I see, updating from 5.13 on Intel NUC tries to download the 6.0.rc1 image :see_no_evil: . I uploaded a renamed version for the update file so that the Supervisor is able to download the update file. Can you try again?

thank you! in terminal it worked. strangely, in Dashoard I see this and when i press update, i get error:

i know for sure i have it working as 6 though. Coral TPU in PCI slot now recognized whereas before, Frigate would stop immediately because it cant see Coral in the PCI slot