Home Assistant setup with Synology NAS

Total newbie here.

I’m testing HA on my Synology NAS DS218+ with integration with Alexa. So far, I’ve managed to install HA via Docker on the NAS, and the Alexa skill. With limited hardware, the only tests I can do is with a Samsung TV and a Logitech speaker. Both were automatically recognised and ‘installed’ by HA and are working as advertised. So, so far so good.

I am having a few issues beyond this first step:

  1. I cannot find the configuration.yalm file on my NAS. I find one under “Docker > Configuration.yalm” but this appears to be only a template (no customization inside). Where would this typically be located?

  2. One reason to access the configuration file is to test the Samsung TV as it does not turn on (“off” and vol control is fine). Reading up about this, I need to add a dedicated port and the TV MAC address as this might solve it.

  3. Another reason to access config is to add a z-wave USB and a USB dongle capable of driving my somfy RTS blinds. As I understand HA, these dongles won’t automatically be recognised by HA?

  4. Does anyone have any experience with RTS dongles? I have seen two advertised (RFXCom and RFPlayer) but I cannot find any evidence that these are supported by HA.

  5. Does anyone have experience adding two USB dongles to a Synology NAS? In my case this would be for Z-wave and RTS.

Apologies for the mixed bag of questions. All help is greatly appreciated!

Because you need to add the configuration yourself.

Here are the docs:

Yes, you should ignore it in discovery and add it yourself to the configuration.yaml.

Correct, you need to configure zwave in configuration.yaml:

Can’t help you here.

Follow the zwave installation. That will single out the usb port that is being used. As for the RTS, not sure what it is, so I don’t know if it’s supported.

1 Like


RTS is Somfy’s proprietary radio technology (an encryption type, I believe. It’s 433Ghz) allowing you to control Somfy products like the 6 sun blinds I have. RFXCom and RFPlayer are two USB dongles a local store suggests for this.

The rest of the advice here assumes I can access and edit the Configuration.yalm file, and I haven’t found it! Is there a (very basic?) instruction somewhere that tells me where to look?

what home assistant did you install? Hassbian or Hassio?

The Home Assistant container via Docker on the NAS, using the method described here:

If there is a better way, I am all ears!

Not sure, never dealt with docker. My synology doesn’t allow docker containers. You need to setup samba share for that docker container.

I used these instructions - works a treat:

The nice thing is that you don’t need to set up any samba shares or something else for access to the config as long as I use this:


1 Like

For z wave on docker there are a few video tutorials as well as the z wave and synology install docs. Also, see here: https://community.home-assistant.io/t/install-home-assistant-on-synology-docker-or-package/42048

Thanks for this, chairstacker.

The page you linked to is the one I used for my installation. I went through it again and used the same config path as you (docker/config). I see the same files now that I had previously on the NAS expect that they are now under the “docker>config” path and no longer under “docker”. I can access the HA UI and make changes there that are implemented (e.g. adding my smart TV).

As before, I have a file called configuration.yalm but this appears to be a template (the timestamp is unchanged since I loaded the new container). I’d upload the config file here but the forum doesn’t allow this as a new user… Mine doesn’t seem to contain any of the customization that happen ‘automatically’ via normal use (e.g. timezone entry, recognition of smart TV, etc).

It could be that I’ve totally misunderstood what I should be looking for here, that this file location and content is normal. On your installation - and assuming you have edited the confguration.yalm file - where is this file located?

You are correct, my comfiguration.yaml file is under the network path \\synology\docker\config

When you say ‘upload’ what exactly did you do?

I just connect to the folder through the samba functionality of my Synology (i.e. I mapped it to drive Z: on my Windos PC) and edit the yaml-file directly on the NAS wiith Notepad++.

You keep calling the configuration a yalm-file, not a yaml-fle - hope that’s a continuous typo.

« Upload » could have read „copy“. I wanted to paste my config file on this thread so you or others could read it.

The content doesn’t show any modifications over time, something the fixed file time stamp confirms. I’d expect to see some changes happening as HA does it thing eg finding new smart devices. This makes me think it’s not the „right“ config file. Or I’ve totally misunderstood what to expect in this file.

I’m accessing mine via file station on the NAS.

Yalm was a typo!

if you have linked the configuration folder from the shared folder to the docker container and restarted your docker container, then the changes will be reflected in the folder. Since you are saying the configuration is not changing you have either 1) not linked the correct folder, or linked to it correctly, 2) haven’t restarted the container for the changes to take affect, or 3) you have some permissions issues and the folder cannot be written to.

You do not link the configuration.yaml file to the docker container. you link the folder that contains the configuration file to the docker container.

I’d say that you are looking at the right folder if you can see that the two files called ‘home-assistant_v2.db’ and ‘home-assistant.log’ change in size and ‘Last Modified Date’ - if that’s not the case then your setup pulls the config from another place.

Thanks for this.

For your 3 points, squirtbrnr:

  1. I believe that this is confirmed (see below - the DB and LOG files are updating)?
  2. I hadn’t done this, so I tried restarting, it didn’t change anything. I assume here that the steps are, open Docker, click the tab “container”, select Home Assistant then click "Action > Restart " or “Action > Stop” followed by “Action > Start”. I tried both, neither worked.
  3. This is a possibility. I have two accounts: “admin” and “Gavin”. I’ve tried restarting the container as per point 2 under both accounts, neither worked: The timestamp for configuration.yaml is unchanged.

I can confirm that the BD and LOG files are updating, so does this mean that point 1 above is OK, that the files are all properly linked?

If so, any other ideas?

Yes if you see the log and DB files, you have linked the correct folder. I’m not sure what’s going on then. Are there other files such as entity registry and a uuid and HA_version file? I can’t remember but I didn’t think the configuration file is a two way file. What I mean is I didn’t think HA could modify it while running, it will only read the modifications you make after a restart of the container.

Yes, there are other files and folders. The folders are .cloud, .storage, deps, TTS. Most are empty.

There are 11 files at the root level (ie docker > config) including those you mention. 8 have a time stamp from my installation last week, the other 3 are the DB, Log, and Plex.yalm. These are updating as the time stamp is today.

I’m also playing with the HA UI and there I’m seeing some weird behaviour too. If I make changes via the UI, these work at first but eventually disappear. For example, I changed the « yr Symbol » friendly name to “weather symbol”. How long it is retained before changing back seems to be random - sometimes it’s nearly immediate, sometimes it’ll stick for several hours. But it always reverts back to the defaults.

Ideas? Delete all and start again?

You can log in to your Synology web UI then use “File Station” to navigate to your configs directory. Then you can download to local workstation, edit away, and upload (overwrite) the config all through file station. Don’t forget to reload the config when you make changes this way. I too use Synology NAS with HA in Docker container (working great!).

Also, I had to reset the timezone in configuration.yaml and properly set your location (lat/long/alt) in order to get sunrise and weather to work correctly. You will have to reboot the app when you make these changes to take effect.

By coincidence, xcntrk, this is what I have spend the last 30 mins doing! So, I have any easy way of editing any of the files on the NAS.

I was also playing with the HA UI and, by playing with the Customization tab, noticed that the customization.yalm file timestamp updated for the first time. So, although Configuration.yalm still hasn’t updated, maybe I have not done any action that would update it yet?

I also noticed this text in the middle of the Configuration.yalm file:

"# Enables configuration UI
"# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
"# http:
"# base_url: example.duckdns.org:8123

As I am running in Docker, is there something I should edit here? Or maybe there is a setup step involving duckdns.org that I have missed?

I can now attach my config file in case this helps.
configuration.yaml (1.6 KB)

I had assumed this would update with lots of detail, for example about my Smart TV and other devices, but I guess this information (which is available in the HA UI) is updated elsewhere (the database, maybe?). Although there is no detail in this config file about my location or timezone, the weather and sunrise/sunset data I see in the UI does appear to be correct.

First, let’s go one step back:
You wrote above that you access your config file via file station on the NAS. This seems very inefficient because every time you need to change something you have to download the file, change it, and upload it again, correct?
Why not edit it directly, i.e. by accessing it as a network drive?

I have not worked with the UI/frontend tools to e.g. change my automations or customizations, but I assume that if you do, they will write the changes directly into your automations.yaml and customize.yaml, not into the configuration.yaml. You would’t seen any changes there.

If you don’t enter the details for latitude, longitude, elevation and timezone manually, they will be and stay incorrect forever - unless you live South of Accra, that is :wink: