Home Assistant Supervised (previously known as Hass.io) on Synology DSM as native package (not supported or working atm)

Same situation here : Synology 415+ , Docker V18 nos compatible, supervisor health issue etc.
Happy to say that BeardedConti method workaround worked perfectly (thanks) and another big thank to Fredrike and to this community.
My aim is to use my 5 Squeezebox Touch trough HA and my tube amps :slight_smile:
Let’s see when Synology will upgrade to Docker 19.

Thanks all


Works with 2020.12.6
I have been using this package for almost a year now, much to my satisfaction. Many people have been asking me about this and it’s a great way for people, already owning a Synology to enter HA relatively easy, without having to purchase new hardware or get into the official installation procedures. As much as I appreciate working within protocols and do feel ‘hacking core’ is a sin, in any piece of software, it does get ‘the spare tire on’ for now.

Kudos to @fredrike.
+1 on the same boat.


@balloob just posted this on the PR:

a lot of people will start to complain that they cannot run hassio anymore, which is the opposite of what we al want isn’t it?

In a perfect world where we have all the time in the world and unlimited resources, sure we would want people to run Home Asssistant Supervisor on every system in the world. However, we don’t have all the time. If you know what you’re doing, fine that’s great. But don’t steer people with less experience down a road that with challenges they are not capable of solving on their own.

When (not if) they encounter a problem that they can’t solve, they think Home Assistant is broken. Doesn’t matter if we tell them they run an unsupported system. We get the complaints.

We all want Home Assistant to evolve, get better, support more things. That also takes time. With our limited time we need to choose how we can have the biggest impact and serve the most people. Trying to make things work with outdated and unsupported Linux kernels does not fit.

I’m not sure how to do this best but perhaps we should create a petition that we want to keep this option.

1 Like

Hi all!
I’ve just installed this package and when I try to a install any addon from Add-on Store recieve next error message:

Failed to install addon

Unknown error, see supervisor

System log:

Supervisor Version 2020.12.dev0503

How could be solved this error?

Thank you in advance!


EVERYONE, first, go here and vote thumbs-up for this post:

To check how many of the people who are using this have interest to keep it working.

My video for hassio on Synology has 22.000 views. We will probably not get more then 20 votes there.

I started writing something there, but decided to not do it.
At the end, anyone who is using hass.io package you created, can very easily make this hack and get system back working.

If this is fixed now, there will probably be next issue in a week, months or half a year.
I really understand what they say in regard to people asking for support for unsupported version.

The issue here is not HA, or this package. Problem is Docker version for HA and Synology is really doing nothing to upgrade it to version 19.x They are the ones who should do something about it. But with DSM 7.0 approaching, not sure that they will invest time into this (if they didn’t do anything until now).

I’m not prepared to do hack upgrade of Docker as I risk much more problems and I’m also not prepared to recommend it to anyone even if they are aware of the consequences.

What HA devs did, by enabling us this ignore flag, is really a lot already.
Stopping Pull request is not cool, but I do get it why they want to do it - offload any unnecessary issues by people NOT reading or understanding what they are doing.
I would upvote Pull request to pass myself, especially after you’ve added disclaimer.

My current machine can’t run VM and even if it could, I wouldn’t do it. Other option is SynoCommunity package - currently 0.114 version with some integrations not working - again - would and will not use.

Core, that’s OK, it works very well, but having addons out of box is better.

I will keep it running for as long as I can. After that… Who knows…


One thing to note, running a VM based on the HassOS OVA does result in a working system. HOWEVER, there is some issue with the Synology hypervisor implementation which does not allow the system to detect the virtualization correctly and thus does not load the QEMU guest tools. This limits the usability of accessing the system, and taking proper snapshots. (You can run the QEMU guest tools perfectly fine, it pauses the system for snapshots correctly, but does not survive a reboot)

So, right now the VM support is not 100% either on the Synology devices that do support running VMs.

EDIT: By default it does not work right. However you can turn off the Hyper-v Enlightenments and it works right and loads the guest tools. From Synology:

I did some testing and found that this issue is due to the option “Enable Hyper-V Enlightenments” found under DSM > Virtual Machine Manager > Virtual Machine > edit the VM in question > General > click the Gear button next to “CPU(s).”
NOTE: This option cannot be altered while the virtual machine is powered on. Please shut down the VM before editing it or the checkbox will be greyed out.


Same exact issue.
I tried the jobs.job patch and no luck :frowning:

It should be a file named jobs.json with the contence:

{"ignore_conditions": ["healthy"]}

I’ve updated the #2:nd post with your fix (https://community.home-assistant.io/t/hass-io-on-synology-dsm-native-package/125559/2#unhealthy).


And don’t forget to restart Supervisor - not Home Assistant.

Thank you, but I’m not the one who made this - I think at least two other persons posted it here before me - I think it was @proxy64 and @fufar after it was implemented in latest Supervisor (2020.12.2 I think)

It is too bad that Synology does not jump on the home automation bandwagon and drive this together with HA.
Most people are moving away from NAS to cloud based services…but HA is driving this in the other direction where you should have hardware at home. It is a really nice combo to have raid NAS toghether with your home automation system.

1 Like

Thank you! It’s working again, new version installed :slight_smile:

1 Like

Got the same error again and again. I have install HAS on Synology, Win10, Linux Fedora31:
same problem everywhere. I followed all recipes and spend abt 11 hours. I am planning to stop, unless someone is helping out or Synology upgrades to DOCKER 19.03… Don’t have a good feeling, alas.

Sorry, edgar

…will attend the HA virtual conference , sure. But provide feedback abt DOMTICZ next.

I can’t get supervisor tab back despite multiple restarts.
I’d like to debug that issue more deeply.

First short description of my (partially) stupid steps.
I didn’t see that there is workaround for unhealthy setup so I tried to update docker using https://github.com/markdumay/synology-docker
It went fine but it also broke most of the stuff by changing log-driver ant other stuff.

So I reverted that update and tried to move back to working scenario.
But after rollback I’m not able to get supervisor working again.
I restarted hass.io several times. Also whole Synology. Nothing works.
No Supervisor,

Can someone that have working solution can share docker inspect output for running containers? I even reinstalled both docker and hass.io packages on my DS216+ but it didn’t help.
I’d like to debug that issue but I need some comparison with working system.

Did you delete remaining containers?

For those who have a working system and want to play: DSM 7.0 public beta has been released

Still includes the older Docker version 18.09.x

But also, there is no going back from beta 7 to DSM 6.x if I’m not mistaken. And SynoCommunity packages still don’t work?