Home Panel - A web frontend for controlling the home

Tags: #<Tag:0x00007f73b4860018> #<Tag:0x00007f73b94ebdb0>

Good day Timmo001 any news about the graphic for the sensor? When I did the update to 1.8.1 of the add-on the graphic desappered. I’m on hassio with Hassos on my raspberry pi 4. Thanks a lot for your work

@thundergreen I’ve seen that you have done a vacuum control, how have you done? I’ve tried but when I select the vacuum entity nothing appear in the card. Only the name is in but i don’t have status and icon

Trying to get a RSS feed card working. Anyone have a link that works?

I would really like to have a link that shows current stock market data.

I don’t use this panel anymore but let me see if I find the config on my PC somewhere

Thanks a lot. Just for information, which panel do you use now?

I am using Dwain’s Theme now. Seems nice and dev is working hard to get it running on multiple devices.

Unfortunately I can’t upload my config … Let me setup a small fileserver at home and I’ll let you know

Hi everyone! I messed up and skipped the right IP-adress when configuring the home panel for the first time. Now, whenever I want to configure the panel, it get rerouted to an error page with “the server ip adress of homeassistant.local was not found”.

I tried stopping, uninstalling, rebooting,… reinstalling in various ways, but I can not access the configuration screen again and I can’t find a config file to set it up in any other way. Does anybody have an idea?

Hi,

I reached the same state as you and @arripeo. I found out from the debug console that after some configuration changes it looses the information for the general.

It goes from this:

{
    "config": {
        "general": {
            "autohide_toolbar": false,
            "dense_toolbar": false
        },
"...."
}

to something like this:

{
    "config": {
        "general": true,
"...."
}

I have now the issue that the Nav Bar does not hide.
Even if I change the configuration offline with a text editor and reload it, it still does not hide the “Nav Bar”.

Something broke for sure in the way the configuration data gets stored and handled.

How do I manually change the HomeAssistant address in my case 192.168.0.xxx, within this application? The default that is set up on my system returns an error " homeassistant.local ’s server IP address could not be found.". Any assistance would be appreciated.

If you log out (left drawer -> log out) and then you log in again it will ask again to log in into Home Assistant. There it should ask again for the address of the HA installation.
At least it is doing so on my side but I do have some problems with the configuration saving and updating anyway.

My Home Panel is as an add-on on HA installed.

I am having the same issue. I am sure I clicked right past the setup. I also want to clear out the database but I can not find it.

Host system

Hostname homeassistant
System HassOS 4.12
Deployment production

on pi 4

1 Like

Did you ever get an answer or otherwise solve your problem? I get the same error in the log " Got unexpected response from the API: Service home_panel not found for dictionary value @ data[‘service’]. Got ‘home_panel’" and it results in an inability to open the web UI - error " homeassistant.192.168.0.23 ’s server IP address could not be found". I know this is because I input the wrong info initially, but it won’t let me change it. Supposedly there is a “home-panel.db” either in Config directory (NOT) or in usr/src/… and I don’t have a src directory under usr so also NOT

I am in the same boat. Supposedly there is a home-panel.db file - somewhere. In my case, I have checked in the config directory with file editor (and in all subdirectories of config) and for a usr/src/app/files tree with terminal & ssh add-on - I have /usr but no /src subdirectory. Under usr I have bin - include - lib - libexec - local - sbin - share. I did a find command from the root with .db and home.* - NO home-panel.db.
Is this the wrong way to do a search for that .db file?
find / -iname home*.* returns home-assistant files in 4 different directories; should return home-panel (somewhere) too, correct?

How did you fix this? I know my logon is incorrect but it won’t let me change it. It tries to take me to “homeassistant.192.168.0.23 (my HA URL)” and I know that the homeassistant part needs to come out (it WAS homeassistant.local which won’t work on my machine), but I typed too fast and now it seems to be permanent. I have tried new I’ve read where there is a “home-panel.db” file somewhere, but it seems to not exist locally

Is this addon still being maintained? I tried to add a url for background, which didn’t work, and now the primary and secondary palette’s have gone to Pink and i’m unable to change any colors or background.

Hi @jb901, I have the same issue here. The workaround is to backup your conf everytime you change a theme. When the look n feel UI settings start to stop working, do a restore of the configuration. So for each change, do a backup, and when it crash, do a restore.
The mess seems to start when we try to update the secondary color.

Hi, which panel do you use now ?
Thanks

Hello,

I am using an Iframe card to show a weather widget. Do you know how to ask the iframe to be refreshed ? Indeed, it’s the morning in France and the data displayed in the iframe are dated from yesderday. When you open the iframe URL, I can see the data up to date.

Thanks

Please clear your browser cookies and try again.

You should never have to touch the database, this is internal to the application and does not control your connection to home assistant.

The connection is browser based and stored on the individual device

To clarify, the home assistant URL should be the base URL of your connection to home assistant from your device. For example, a local network IP based URL would be:

http://192.168.1.123:8123

If you make a mistake, the easiest way to recover from an unintended loop is to clear the cookies and cache and try again