How do I change the "node name"?

Hi there.
A long time ago i used to use Domoticz for Home-Automation, and there I changed the node_names (maybe in OZWCP) to “zwave_”. I have now for a year ago or something migrated to Home-Assistant, but have not added any new z-wave devices.

So, I added the first one rignt now, but I can’t see any option to change node name (no, not entity id or friendly name). How can I do this? And make home-assistant re-generate the entities based on the ned node-name.

Controller: UZB1
Latest running on Ubuntu 16.04.5 LTS

you can’t. that functionality was removed somewhere around v76. :roll_eyes:

You have to rename each entity individually as per the pictures above.

Well technically speaking, if you:

  1. Rename node with cog.
  2. Shutdown HA.
  3. Delete all ‘auto generated entities’ from the entity registry. See here how to delete registry entries from core.registry.
  4. Restart HA.

All new entities should be created based on the node name.

EDIT: To clarify. You’ll end up with only the zwave node on startup and HA will auto create all the entities associated with it (because you deleted them).

that is my exact routine each and every time I add devices to my Hue and Tradfri setups. HA is too fast to be able to change the name into something useful, and will have already created the entity in the HA registry before I can rename light.hue_ambiance_spot_12 into light.sofa :wink: don’t even want to think about a few of these: switch.aeotec_dsc26103_micro_switch_2nd_edition

ive made it a habit to calmly rename the lights or switches or whatever to what I would like them to be called, go to /config/.storage/core.entity_registry and core.device_registry, delete the relevant entries with the original names auto-created by the system, and restart.

once you see how these registries are built, it is very easy to manually edit. Never fails, and no more ridiculous entity_ids in Ha

btw, I never shut down, this can be done hot-plugged. Or at least never ran into trouble doing so.

Yes, all of that is, like you said “technically” true.

But officially and intentionally the desired functionality is to edit each entity individually.

I’ve tried to fight the good fight to get the people in charge to understand what the problem is with the current system but it’s all fallen on deaf ears.

I’ve got no problem with workarounds trying to make things work where there is no alternatives but to intentionally remove a working system and then be reduced to jumping thru hoops and editing “system” files as THE alternative is just ridiculous.

Yah, I ment “HA off”, the system can be on.

You may not know the history behind this, but overall it’s still much better than it used to be. Managing dead nodes and renaming things in the past was sometimes just not possible or a never ending battle. The entity registry, while annoying, is much better than it used to be.

I must have missed the time before when it sucked and only experienced the time when it worked well before it was intentionally forced to suck again.

When I first started with HA and save a year and a half ago before the entity registry was introduced it seemed to work pretty well from what i remember.

How time flies. Can’t believe I ditched zwave that long ago. I definitely could rename the node with the gear icon when I was using it.

Apologies for the misinformation.

I think @finity was refering to it “auto naming all attached devices”. You certainly can change the name of a zwave node, it just doesn’t propagate to attached devices.

@finity I think you just missed it. I’m remembering when I first started back in early-mid 2016 when I had 2 zwave devices and HA. I think it was the only 2 things I had in my configuration, just so I could turn on a light and have the other light turn on. Anyways back then, you couldn’t rename, the name came from ozwave. This was also before the zwave domain existed. So all you got was switch.20393248932895234_switch or light.298284382_dimmer. It was hard times.

Thanks, but what is, and where do I find “cog”?

This did not work. added “_testnavn” at the end of the name and it did not change the “node name”. Also done soft reset of controller and reboot of Home-Assistant Server


That is what I did, but the “node name” are still the sameUten%20navn

did you restart? Or even might require a refresh.

EDIT: Now that i’m looking at my config, it appears as the node name is pulled from your ozwave config file. Why do you want to rename the node anyways? It serves no purpose at this point.

well, I might as well follow the standard I have started. Maybe if I change the name in the config file?

Yeah that could work. But again I don’t understand why. You can change the name and the entity_id. The node name doesn’t even show in the UI outside the states page. So I’m not sure why you are spending so much time changing this.

It did work. :slight_smile:
Anyway, I see you are referring to the files core.device_registry and core.entity_registry
where are these files located?

EDIT: Found it, it was hidden.


trying now

EDIT2: It works, thanks for the help