Installing HAOS on a dedicated x86-64 PC

Excellent! I had written a response but you were able to solve the issue.

Good luck and enjoy HA!

When I tried this some time ago I had the same issues starting Balena. I just gave up at that point and took the drive out the PC and plugged it into a USB port on my windows machine and used Balena there instead. Even Balenas website had no clues how to run the Linux download.

It would be good if someone who understands this could write a step by step guide that works and explains how to run Balena.

1 Like

Couldn’t have done it without you. I was only able to run it with balenaEtcher-1.7.9-x64.appimage, latest stable only gave a white screen. Trying to install HAOS through an Ubuntu USB

I was able to flash a system using a Ubuntu 20.04.2 LTS Live distro from USB.

After booting from the live distro of Ubuntu open up a terminal.

sudo su


add-apt-repository universe
apt update
apt install libfuse2 -y

After that installs, we’re going to use steps provided by Balena to install a deb package for Etcher.

curl -1sLf \
'' \
 | sudo -E bash

Now we can install it.

apt update
apt install balena-etcher-electron -y

Once it finished installing I was able to launch it from the application list in Ubuntu.
With Balena Etcher Open:

  1. Select “Flash from URL”
  2. Enter the web URL:
  3. Click on “Select Target”
  4. Choose the desired drive
    4a. I had to go to “Show 1 Hidden”
    4b. Then I selected the drive /dev/sda
  5. Click “Flash!”
  6. Wait for it to complete, unplug USB drives and restart.

I hope this helps others get Home Assistant x86 up and running on a system drive faster.


I’ve been fighting with this for almost 7 hours. Your post saved my bacon! Thank you!!

A very easy, pure GUI, way to install the x86 OS is by:

  1. Boot your x86 system with a live Ubuntu USB3 (3 for speed) stick
  2. Download the x86 OS image to e.g. Downloads folder
  3. Start the “Disks” program (WIndows key, find the “Disks” program).
  4. Select your target PC harddisk (not the USB disk), press the “three dots” menu buttom on the right (not the “three lines” menu on the left), and select “Restore disk image…”.
  5. Now you can simply select the downloaded image and it will be written onto your selected target disk. Dont mind the warning about size difference (unless you installed too small a disk :slight_smile:).
  6. Reboot and follow the onboarding procedure described elsewhere

After battling with installing Balena and trying to find other ways to make this work, this (using Disks on Ubuntu/Debian) was an absolute breeze - thanks for sharing!

This method does no longer work (installing Balena Etcher)
I created a complete guide with the updated instructions

Absolutely agree.
Spent a lot of time experimenting over the past month & did manage success with Balena, but it’s very Version specific.

“Restore disk image…” is an absolute breeze.

I’ve taken a slight tangent with that now…

I have now burnt the Ubuntu USB using Rufus, which allows you to create it with persistent storage.

That means all my settings & more relevant, downloads & bookmarks are still present each time I boot off the USB.

So boot, got to the Disks & Restore the already present download & the jobs done in under 10 minutes.

Admittedly not of benefit to everyone, but an IT Guy here & have dozens of abandoned machines on the shelves.

Aside from my main Pi waiting migration, I currently have 3 other installs on spare x86’s each doing nothing more than providing a test platform for a specific case on a clean environment.


Amazing… I fought with Etcher errors for multiple hours. Your Disks / Restore Image solution is so much simpler and should be the standard guidance.


Trying to install on a new device, I’ve been tearing my hair out for 5 hours with Balena Etcher and got nowhere (just a whole raft of errors about dependencies, none apparently resolvable by installing anything). When I try to use your method in the Disks program, I don’t see Restore Disk Image, only New Disk Image and Attach Disk Image. Will one of these work and, if so, which one?


You need to select the “three doots” menu on the right, not the “three lines” menu on the left. HTH.
PS: remeber to select your target disk first (where the HA OS will be installed)

Thanks Michael. I spotted this late in the day and finally managed to install HAOS. I’m kicking myself for not realising earlier, but had got stressed trying everything under the sun to get Balena Etcher to install: it should come with a health warning!


In dire need of some help. I created a bootable usb with Ubuntu Live on it. On a separate usb drive was Balena Etcher and I ran it and used the app to write home assistant to the SSD that is in the dedicated computer. On reboot I keep receiving messages. I am at such a lost. I also tried taking the SSD out and burning HA to it on my Windows 10 computer. Also tried Raspberry Pi imager. Striking out royally. BIOS has UEFI enabled and secure boot disabled. BIOS fairly up to date (September of 2022)

I hope the below guide can assist you.

No need to use Balena Etcher - which seems to cause issues now and then.
This works: Installing HAOS on a dedicated x86-64 PC - #11 by MichaelSidenius

I am not sure if I got the correct file. I am using one that was zipped and had to extract with get command. The file name is haos_rpi3-64-9.5.img. I can see multiple partitions and the restore appears to go through, but I keep getting no boot device found. I have searched GitHub but cannot find a link to manually download it from.

This topic is for a x86-64 system and you are using the image for a RPi…

I been having a hard time finding the image for x86-x64. A link would be very appreciated. My system broke with the last update that came out Thursday of last week.

Here are the latest releases: Releases · home-assistant/operating-system · GitHub
For a x86-64 system:

1 Like