How to "open" a Snapshot archive, tar.gz

Hi to everybody,
is there a way to open homeassistant.tar.gz ? It’s around 1Gb and i was using a password.
I’m trying with 7z but it gives me an error: impossible to open it as an archive.
Is there a way to solve this?
I’m no more able to rebuild this snapshot, even with a fresh home assistant installation.
I’ve a lot of work lost inside there

thanks for helping me

My snapshots aren’t password protected and I can open them with 7z. Maybe your snapshot is corrupted?

Are you using Windows?

Have you tried Winrar?

Hi Tom. Yes maybe are corrupted. I think so…even if i have 3 snapshot and all these are giving me same error. Will try with winrar now and yes…i’m using windows

winrar reply
! C:\Users…\Desktop\0165a3cc\homeassistant.tar.gz: The archive is either in unknown format or damaged

I just created a full snapshot with password protection. I can’t open the contained tar.gz file with winrar or 7zip.

This is good news I think. Your archive is probably not corrupt. We just have to work out how to unencrypt it.

Relevant info but no solution:

Are you sure you have the correct password?

This should be possible:

Thank you again Tom for your time. This could really be the problem, even if not so easy to solve

Yes i’m sure to have the correct password, cause i’m using it in other home assistant instances and just copy and paste snapshot automations and dropbox addon config
Actually is not true that the snapshot is not rebuilding because something happen. Home assistant start back again giving me different errors.
The proof that something is back is about the old privateKey i need to use for ssh connection.
Anyway, and seem so strange, no configuration files are back. Inside the config/ folder i’ve only default files of the fresh hassio installation

Sounds like it is restoring addons but not the home assistant config.

How old is the snapshot?

Could the failure be due to a recent update’s breaking change?

If it is an old snapshot you could try restoring it to an older version of homeassistant.

To do this, use the command line on a new install to ‘upgrade’ to an older version (from about the time of the snapshot):

hassio homeassistant update --version=x.y.z

Where x.y.z is the version you want.

Release dates and versions can be found here:

Ok thanks, so let me try this

Ok so i’ve tryed it. Installed last hassio image and then trought console installed:
hassio homeassistant update --version=0.91.2
91.2 (the home assistant version of the snapshot)
But the webserver reply with a 404 error
404: Not Found
And in the log i can see this

2019-07-26 17:11:09 WARNING (MainThread) [homeassistant.config] Incomplete core configuration. Auto detected latitude: 45.408, longitude: 11.8859, name: Padova, time_zone: Europe/Rome, elevation: 0
2019-07-26 17:11:11 ERROR (MainThread) [homeassistant.setup] Error during setup of component onboarding
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/homeassistant/", line 151, in _async_setup_component
    hass, processed_config)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/onboarding/", line 24, in async_setup
    data = await store.async_load()
  File "/usr/local/lib/python3.7/site-packages/homeassistant/helpers/", line 81, in async_load
    return await self._load_task
  File "/usr/local/lib/python3.7/site-packages/homeassistant/helpers/", line 104, in _async_load
    data['version'], data['data'])
  File "/usr/local/lib/python3.7/site-packages/homeassistant/helpers/", line 197, in _async_migrate_func
    raise NotImplementedError
2019-07-26 17:11:11 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of frontend. Setup failed for dependencies: onboarding
2019-07-26 17:11:11 ERROR (MainThread) [homeassistant.setup] Setup failed for frontend: Could not set up all dependencies.
2019-07-26 17:11:12 ERROR (MainThread) [homeassistant.loader] Unable to find platform google_translate.
2019-07-26 17:11:12 ERROR (MainThread) [homeassistant.setup] Error during setup of component met
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/homeassistant/", line 154, in _async_setup_component
    component.setup, hass, processed_config)  # type: ignore
AttributeError: module 'homeassistant.components.met' has no attribute 'setup'
2019-07-26 17:11:13 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of logbook. Setup failed for dependencies: frontend
2019-07-26 17:11:13 ERROR (MainThread) [homeassistant.setup] Setup failed for logbook: Could not set up all dependencies.
2019-07-26 17:11:14 ERROR (MainThread) [homeassistant.components.device_tracker] Unable to load /config/known_devices.yaml: Config file not found: /config/known_devices.yaml
2019-07-26 17:11:14 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of default_config. Setup failed for dependencies: frontend, logbook
2019-07-26 17:11:14 ERROR (MainThread) [homeassistant.setup] Setup failed for default_config: Could not set up all dependencies.
2019-07-26 17:11:17 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.1885959248] Received invalid command: get_panels
2019-07-26 17:11:17 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.1885959248] Received invalid command: frontend/get_themes
2019-07-26 17:11:17 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.1885959248] Received invalid command: frontend/get_translations

Seem to be something like this
i’ve tryed the suggested solution with no luck. Now the webserver is starting and the onboarding page is in a continuous refresh loop

deleted .storage folder and now 91.2 is working
i’ve tryed wipe and restore snapshot and i’ve got addons back but files in the config folder are still the ones from the fresh hassio installation.
so what’s the problem? nothing is showed in the log
it’s so frustrating.
i’ve tryed with all 3 snapshot i ve without luck

Hi I am having the same problem was there a fix?
None of my backups restore the yaml files.

Kind Regards and keep well


No fix for me. Everything was lost. So, 1 year of work lost too.
Now my snapshot are only without password.

I cannot open on mac os X or Linux. I would be great if the devs would chime in on this.

I was surprised about this too. Password protected (encrypted) snapshots can not be opened. The type of encryption seems to be proprietary, which gives me a very bad feeling because not being able to access snapshot contents from outside HA is a no go for me. People don´t want and really should not end like

As a quick workaround I´m going to disable password protection for all automatically generated snapshots.

Update: found evidende for my assumption - snapshot protection is proprietary, see Unpack encrypted snapshot files. Very interesting topic.

1 Like