Unpack encrypted snapshot files

I took a snapshot of my hass.io. I can unpack this without problems under Windows / macOS and remove individual files.
If I encrypt the snapshot with a password during creation, then I can not unpack the packed file (I will not ask for the password anywhere). How can I unpack individual files from the encrypted archive or which program is required for this?

1 Like

Thank you for your explanation. I understood that halfway. Therefore, there is no possibility outside Linux to unpack the archive under Win / macOS?

Not easily.

Sorry, I’m quite unfamiliar with this. But this means that it will be able to retrieve information from an encrypted snapshot file? :roll_eyes:


Oh that would be great!
I’m somehow not able annymore to reload previous made snapshots. Seems something got corrupted or broken, since I can not acces Home Assistant annymore after reloading the latest snapshots.
So I would like to retrieve the data manualy from the files.

Sorry, but I’m new in this. Could you perhaps give me directions tosomething of a guide or so on how to do this. Tried to use google or the search engine here. But this brought me to topics like this :slight_smile:
Thanks in advance!

To retrieve the data you would have to restore the snapshot in home assistant. There is no other way to enter the password.

1 Like

Thanks for your reply, but that’s the whole problem. I’m not able somehow to reach or login into Home Assistant after restoring. Seems somehow the link with DuckDNS or Haaska, which is part of the snapshot config, got broken or so :frowning:

I’m trying to get Home Assisstant back to an older version now. But this also doesn’t seem to work :frowning:

I’ve managed to restore my latest snapshot, and reach the files using SAMBA in combination with the static IP adress of the RPI. This opened the file folder with the backup folder and the config folder etc. of the Home Assisstant configuration.

I was able to back up the yaml files here, just in case. And to comment out the Haaska settings in the configuration.yaml file and save it. I was then able to reach the Home Assisstant configuration with the static IP again after restart. So guess something got broken with the Haaska or DuckDNS configuration.

I will save my snapshots without password protection from now on!

1 Like

Yeah this is the take-away learning from this topic.


Somehow this is weird.

It is my data.

HA cannot hold it hostage within their own ecosystem. Goes against basically the whole no lock in / no cloud principle.

This is not the way.


Somehow it must be possible to add your own ‘salt to the mix’ if you catch my drift. If you fuck that that up? That is your own problem.


Or am i talking nonsense? Not well educated in encryption in this matter.

1 Like

It has nothing to do with that.

It’s like two factor authentication. It’s great when it works but if for some reason you need access without it, sorry, you are shit out of luck. The extra protection ends up working against you, but hey at least your data is secure.

1 Like

Then where are my backup codes? so not really 2FA

Any fresh install of HA can unlock those files, why can’t I? What is the secret sauce?

I really would like to know.


It was a metaphor.

There’s a python script on the forum somewhere that can decrypt the backup for you.

1 Like

Copy that. Current handling of password protected (encrypted) snapshots is a no-go.

1 Like

It was easier then I think. Downloaded back up on my second RPI with RasbpiOS, and just unpacked them

Yes that was the oriiginally suggested solution:

Since I got here from google… There is an answer.

Worked like a charm.