Home Assistant Community

I am stuck on the first boot - can't connect via browser

#1

Hello!

After flashing the SD card with the hass.io image and starting raspberry pi for the first time a black screen with white letters appeared. There was some loading and things happening, but at the end it stuck on the following line:

HASSOS>

My screen looks like this:

I am not able to connect to http://hassio.local:8123/

Raspberry pi is connected to my router via cable, while my mac via wifi.

During the time, in which raspberry pi is working and loading things I can see it connected in the router interface. But once the last line is reached, I don’t see it anymore.

I have assigned it a static IP address in the DCHP settings but the setting disappeared for some reason.

I am not sure if my router even supports mdns.

Basically I have no idea what’s going on. Where should I go from here? My next step is to try and connect to the hassio local url right? Or does the screenshot tell you, that the OS installation is not complete?

0 Likes

#2

Your installation is not loading. It keeps resetting. I’m no expert on this but it looks like it can’t download the initial update. You appear to have a network / router / firewall problem.

1 Like

#3

For some reason, after reaching the last line, I don’t see it connected to the router anymore. I tried the last IP I remembered, but it didn’t work. When I restart the device, all the loading starts again. But I will try it again and see if I can connect.

0 Likes

#4

The raspberry Ip seems always to be 192.168.0.80/24, but I can still not connect to it. Do I need to forward ports or anything like that?

0 Likes

#5

I think you need to use SD Formatter on your card and flash it again, perhaps with a new download. It looks like it is trying to PXE boot from a tftp server.

1 Like

#6

I reformatted the SD card, mounted a freshly downloaded image.

I also created a usb with wifi settings (although I am not sure if I put all the settings in correctly)

Then I disabled the router firewall and my macs firewall.

Still, the same problem though.

And at the very beginning I always get the msg “Net no Ethernet” or something like that, even though the Ethernet port is flashing and I can see the device in the router interface.

0 Likes

#7

God no. Forwarding ports is for externally accessing a service running on your network. When you’re on the same network you don’t need to forward a port to access a LOCAL IP address.

0 Likes

#8

It seems that there is a TFTP/PXE server on our LAN (192.168.0.1 = your router?) and HassOS find it and expect to get some files from it.
You may have to disable this feature on our router or try from another internet access.

0 Likes

#9

What model of Pi? Some people pxe booted older ones by adjusting settings in the Pi itself.
Older ones are anything older than the 3 B+.
There should be a way to reverse that setting but I didn’t find it with an online search.

0 Likes

#10

@makai

192.168.0.1 is my router indeed. But why would my router be / have a tftp/pxe server? I can’t find anything about that in the settings.

0 Likes

#11

@bosborne
Its a new 3b+.

0 Likes

#12

I agree you must have a pxe server dooting other network devices that is interfering. I have a new Pi too but no issues (knock on wood).

It looks like pxe boot might be wired only on the Pi. Is it possible to use Wi-Fi with your Pi, at least as a test?

0 Likes

#13

@bosborne
Sure, I tried that but I am not sure how to fill out the settings file.

I am using this, on a FAT usb in network/system-connections:

[connection]
id=hassos-network
uuid=e0638ca6-cd7a-4e82-9812-2984b9f01a4c
type=802-11-wireless

[802-11-wireless]
mode=infrastructure
ssid=UPC1451719

[802-11-wireless-security]
auth-alg=open
key-mgmt=wpa-psk
psk=PQ56pxuyjvh2

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

The problem is, I am not sure what some of those values are, like addr-gen-mode,method,auth-alg and mode.

I have both 2.4ghz and 5ghz on my router which looks like this:

But how do I format that in the settings file?

Same for key-mgmt, I know I have WPA/WPA2 Personal, but I don’t know, how to write that down in the file.

0 Likes

#14

I honestly have not done that, but let me try & search. Sometimes half the battle is searching for the correct terms.

That looks correct assuming the ssid= is there you placed your wireless network name and psk= is where you placed your Wi-Fi password.

0 Likes

#15

I just installed raspbian stretch from an image from the manufacturer of my zigbee gateway and it works well, no problem with ethernet at least.

0 Likes

#16

Guess I will have to go the other route and try to install HA on here without hass io.

0 Likes

#17

Or you could install hassio on raspbian, like the documentation states…

0 Likes

#18

Isn’t hass.io the OS itself?

0 Likes

#19

No. HassOS is the os. Hassio is a way of running home assistant.

Hassio is a pair of docker containers. You can run hassio on Linux.

0 Likes

#20

Hassio on Raspbian Lite is what I am now running. Do you need any guidance for this?

0 Likes