IKEA On/Off Switch Zigbee Issues and Troubleshooting Zigbee

Hi all. The crux of this issue is that I have an Ikea Tradfri On/Off Button that worked and now stopped. TLDR jump to the numbers below.

I am very new to Home Assistant and this is my first post. About 60 days ago I discovered HA when my Insteon hub stopped working. So I stood up a virtual server on an Unraid server, and since then I have spent a ton of time learning it. I still have a long way to go. But at the moment I have all my Insteon, a bunch of Wifi, and now Zigbee devices. In all of this though I kind of started from the top down. Because I installed HA and then boom, it discovered my original Insteon devices, I have kind of been in “Install->discover->build automations” mode, without having to worry about how to really fix issues.

So this week when I to added some Zigbee stuff to my setup, Some of it worked fine, some of it didn’t, and some of it worked at first and broke. Now I am really struggling a little to troubleshoot effectively and know the next steps, and I can’t seem to find what I am looking for. Here is what I have:

  1. I installed a Sonoff Zigbee 3.0 USB Plus Gateway. HA recognized it right away and setup ZHA
  2. Paired an Aqara leak sensor and everything went great.
  3. Paired a motion sensor, plug, and On/Off switch I got at my local Ikea. The motion sensor and plug paired but I cannot read the battery information on the motion sensor. The switch paired but cannot read the battery and the switch doesn’t activate like a normal switch.
  4. Looked up information saying that OTA update can be performed now on IKEA products so I put this in the configuration.yaml and restarted. I am not sure to tell if the firmware is or has been updated though.
zha:
  zigpy_config:
    ota:
      ikea_provider: true                        # Auto update Trådfri devices
  1. Found a post saying I should update my Zigbee coordinator. Unfortunately, the only thing I can find is saying do it for Zigbee2MQTT, which I am not using. And everything I am finding says for Windows or Linux. I am on a Mac, which technically I could try the Linux upgrade. But I am not sure if I need to update.
  2. Installed this blueprint and was able to control a light with the switch for about 2 hours. I say for about 2 hours because it just magically stopped working. I changed the entity it controlled and still no luck. I put in a fresh battery thinking maybe the battery is dead (since I can’t read the status) but that did nothing. Factory reset it, and it still doesn’t work.

So I guess here are my questions:

  1. How the heck do I troubleshoot the devices more effectively. When I press the button, I do not see anything in the logbook, logs, or any type of state change. Yet, when it was working, I didn’t see that either. I have been reading the support documentation, but being fairly new I am not sure how to troubleshoot what these devices are sending out.
  2. Do I need to update the coordinator since I am using ZHA, and should I? I am not looking to use MQTT (which I really know nothing about yet, it may be the best method).
  3. For the OTA updates for the IKEA Zigbee products, how can I tell if they updated? And how do I force an update?
  4. I see some postings about IKEA products and battery level. All the IKEA stuff I bought will not register battery level. That is why I was trying the OTA update. Does anyone know what that is?

I think that’s a good place to start. Everyone in the community looks extremely helpful and I imagine I will have many more questions.

You’ve likely seen the battery drain thread, with my summary of experience.

  1. Don’t bother looking for a network analyser toolset. Basically, the Tradfri is dead and needs adding back to the Zigbee network again. Replace the battery, use the button on the back to reset it, and add it back to Zigbee.

    • Settings → Devices & Services → Zigbee → IKEA of Sweden TRADFRI remote control → `RECONFIGURE DEVICE’
  2. I’ve not updated the firmware in my Sonoff USB coordinator and similar problems to those you are seeing went away after taking the steps im my summary post.

  3. The updates happen magically over about 24h.
    Check the firmware version to see if it changes. The latest Tradfri seems to be 0x23080631 / 2.3.080.

  4. Attributes like battery level appear and disappear due to firmware bugs, and although Reconfigure Device* may help, my experience is it will fail again until the remote gets a firmware update.

Thank you. I will check this out. One note, I turned off the IKEA OTA updates and added another button. That button works fine. Looking at the firmware, I believe the OTA updates pulled from HA bricked the IKEA button. I tried what you said above with the new battery and repair, and it would never do anything other than register with ZHA in HA.

1 Like

Hi Jason,
did you ever manage to revive you IKEA switches?
I have the exact same scenario. Sonoff ZBDongle-E working great.
All devices worked for weeks, added OTA update for IKEA… Boom -
within ~18 hours, all 6 “TRADFRI on/off switch” quit working.
They can be paired, and then almost immediately become unknown.
All other switches, motion, bulbs, etc work great (over 40).

Any advice would be welcome.

Best

Looking across many forum posts, the individual IKEA remote control devices seem to have different issues.

  • The 5-button remote is largely fixed with the latest firmware - battery life OK, uses routers, just needs to be re-paired when the CR2032 eventually drains (months now).
  • The one button and ON/OFF seen to still have issues - there’s hope, as they might receive a similar firmware update to the 5-button.

My one button never got as far as pairing on my Sonoff dongle (likely not the E variant), and went in the bin before an upgrade to the Yellow SilLabs coordinator + ZHA.

All I can suggest is again, add mains switches as routers, replace the battery, factory reset, re-pair.

Thank you for your reply James,
I tried all the mentioned. I understand what you are trying to say with the on/off switches needing an update.

My question is, why did they work reliably for quite a while, but once I enabled OTA, they started behaving like that.
Cheers

Hi Carsten,

The behaviour of the IKEA buttons is quite frustrating. I share my experience with those below, although I haven’t still found a way to resolve the reliability and pairing issues I am constantly experiencing. In any case, the different posts from James @FloatingBoater on this topic have been really helpful to me.

My Network setup and HW:
I am using a recently purchased Zigbee usb gongle (E-variant) as zigbee coordinator (I haven’t been able to verify the FW version of my usb dongle, though) The dongle is running in a Rasberry Pi 4, 8 GB, Home Assistant operative system. The dongle is connected to one of the USB 2.0 Raspberry Pi ports with a 2 meter shielded usb extension cable.

Regarding the zigbee network, I have 9 zigbee mains plugs used as repeaters from different manufacturers around the house. 4 of them are IKEA Tradfri smart plugs. I have also 1 IKEA smart bulb.
I am only using ZHA integration and it is working stable to control the zigbee plugs, read measured values, etc.

I have bought also recently 4x IKEA Shortcut buttons and 3x IKEA on/off switches. I would like to use them as a multipurpose controls to trigger different automations.

My experience with the IKEA buttons so far has been as follows:

  • All buttons are discovered by the zigbee network after pressing quickly the small pair button near the battery 4 times. However, after initial pairing, none of them was triggering any ZHA event.
  • Launching a reconfiguration multiple times (under ZHA integration → device → reconfigure) only worked for one of them.
  • Replacing batteries didn’t work on most of the cases.
  • After really multiple attempts, forcing re-pairing via mains zigbee plugs, replacing batteries before, during and after the paring process, etc, I managed to have all them sending events through the bus. It took me 2-3 days to reach this point. However, the devices became eventually unreactive and had to re-pair again (multiple times).
  • I enabled OTA FW updates and let it do its job. In some cases I had to force manually the FW update. Sometimes the FW update process suddenly stopped and had to start over again.
  • After another 2-3 days the FW of all buttons was up-to-date. Unfortunately, the reliability of the buttons is still very poor and they still became randomly unresponsive. Sometimes they become responsive again but I haven’t found any pattern why or under which conditions this happens.
  • Re-pairing the buttons is still very painful with the new FW. I have tried also a long press (>30-40 seconds) of the small pair button near the battery (making sure that only this small button is pressed and not the actual main button!) while placing the button 2-3 cm near a zigbee repeater or the zigbee coordinator, but this didn’t work for me either (long press near a IKEA repeater or bulb links it directly to the device without issue, but the intent is that the buttons are actually part of the zigbee network and not just a single dedicated bulb/plug controller)
  • Triggering multiple reconfigurations didn’t help much, although in some shortcut buttons eventually worked.

TL;NR: I haven’t found any robust procedure yet to pair them with the network and effectively trigger ZHA events straight away. Even with the new FW, the buttons become unreachable/unreactive randomly, in some rare occasions become alive again on their own.

Obviously my desperation feeling is skyrocketing, and I am thinking that maybe purchasing the IKEA gateway and adding it to the zigbee network would be the solution to the unreliability problem of the buttons? @FloatingBoater: James maybe you have any positive experience with that?

All the best.

1 Like

I’ve only used ZHA with the Sonoff v3.0 and now SilLabs (Yellow) co-ordinator, but some folk reported Z2MQTT worked better for them.

I’m not sure how the IKEA gateway integration works - if it uses a control API to ask an IKEA Zigbee software stack to control items, it might cope better with IKEA wierdness than ZHA or Z2M, but it could also just be a ‘radio on a stick’. (note: There was a new IKEA hub released, and don’t remember seeing updates on the progress to integrate it.)

Annoyingly, I’ve just seen a Sonoff Zigbee door sensor fail a ZHA reconfigure after a dead battery and now doesn’t report voltage level. This suggests some issues are independent of manufacturer, and might be ZHA / Zigbee itself.

If you’re really fed up I’d try:

  1. the “turn HASS and Zigbee coordinator OFF for over an hour to force a mesh rediscover” trick
  2. a move from ZHA to Z2MQTT
  3. a new coordinator, like an IKEA hub (after checking if the new hardware works)

Some X10 kit was flakey, and some pricey Z-Wave kit didn’t work for two years and needed a Fibaro Hub + new firmware - sadly, even with “rigorous certification testing” the complexity of modern network devices means they can be flakey like a badly maintained steam engine!

Personally, I’ve literally destroyed some troublesome devices with a hammer (Sonoff ZBridge, IKEA 1-button remote being one) to prevent my engineering brain wasting time attempting protocol debug on a £5 block of e-waste (properly seperated and recycled, natch :wink:).

My longer term hope is to replace Zigbee with Thread kit and control via Matter, but the flood of cheap devices using a better designed 802.15.4 radio protocol (e.g. allows multiple resilient border routers) is likely a year or so away.

If you’re interested, I wrote a comparison of different automation standards, and their relative costs - basically, CHEAP FAST GOOD Pick any TWO!

Thanks for your response, James.
I will give a try to option 1 within the next days and see what happens. I will keep my hammer away just in case.

While zigbee has its challenges, the IKEA on/off button has been an extra level of annoyance in my experience. It randomly disappears from the network, then works again after multiple forced re-discoveries then suddenly runs out of battery, etc. I’ve had better luck with the IKEA full controller (the one with dim buttons).

However, other than IKEA Tradfri smart plugs and bulbs I don’t think IKEA products are prime time ready. It looks like their firmware / battery algos cannot deal with batteries properly. On battery operated buttons, I had much better success with the MOES scene switch button lately (but they are more expensive and it’s only been a few days for me).

Did anyone find other battery operated zigbee buttons that were reliable?

  • IKEA 5-button TRÅDFRI remote (with the latest firmware) - good, even battery level sensing OK
  • IKEA TRÅDFRI UK 13A socket switch - good
  • Sonoff PIR - good
  • Sonoff door sensor - was fine about 2023.02, now appears less reliable on 2023.04.
  • Sonoff temperature - good

Might try the Sonoff SNZB-01 button, but at £11 for one input, it’s not price/ performance (would prefer several buttons per radio, but that’s back to IKEA kit…).

1 Like

Excellent thread, thanks guys. I will also play around a bit.

I have, or seem to have a different issue.
In my network, I have about 9 of these TRÅDFRI on/off switches. they ALL worked without issue for an extended period of time. Until I added the OTA to my config… 2 of the switches where out of battery, and 1 (I suppose) was left untouched by whatever happened - they are still working flawless. Now, I have 6 switches that become unavailable, right after discovery (when tried rediscover).
I have an old deConz installation, I’ll reactivate - maybe it is a goobered OTA that killed them.

The 2023-02 update for the 5-button remote made significant changes to how the buttons are mapped, which needed a new quirks file which was added to 2023.03 for ZHA users (or manually via GitHub issue instructions which you might find familiar).

Your on/off remotes stopped after an update sounds similar - Do you need to manually update deConz for the latest quirks file?

I’m also suspecting of OTA breaking stuff but either way there is something wrong with the on/off switches. My current state of mind is:

"don’t be a perfectionist, if it’s working fine I don’t need the latest firmware :rofl: "

MOES scene switch button still working reliably after 1 week of use so fingers crossed.

Dear gentle-people…
I had a mini breakthrough.
While fiddling with the TRÅDFRI on/off switches, I usually get this, on the ones that do not work.
image

But, if you toggle the ON/OFF switch, right after initiating the pairing request, they all started working.
(all but one).
Worst on this situation, I can not explain, what that would be any different.

@FloatingBoater - deConz updates frequently. Don’t know anything about quirks, but would be glad to dive into it, if I can help you with that.

Just an FYI

I moved from Deconz to ZHA and everything is working except for the IKEA switches. When I was using Deconz, they worked 100%.

So this is not a firmware issue in the switches, its really something to do with ZHA.

I’d suggest is it to do with the way IKEA firmware interacts with ZHA, and not give IKEA a free pass. Complex systems seldom fail in simple one-sided ways, IMHO.

Deconz might have a different set of assumptions, or different ‘quirks files’ to workaround non-standard IKEA behaviour that work better than the ZHA equivalents or particular co-ordinators.The IKEA firmware could still be very non-standard.

The devices still don’t work, so it doesn’t help you sadly!

As an example, I once consulted on an issue with three networked devices where only two worked. One had different endian hardware, and two were the same - both not TCP/IP network order. The non-working host was the only one that met the spec…

In the mean time I did some tinkering around with ZHA and the switches and got all 3 switches working. What I did was:

  1. Remove the switches from HA.
  2. Restarted HA
  3. Add the switch back to HA: Zigbee Home Automation > Configure > Add device (after this click the small connect button 4 times on the IKEA switch)
  4. When de device is detected click the on and off buttons (you should see it being clicked in the logs, you can enable the logs in the detection screen)
  5. Give the device a new name (one that you never used before for this switch)
  6. Now it works

I did have one switch coming up as “the device is disabled by config entry.” but after changing that in core.device_registry it also worked.

Not sure if they keep working, will keep you updated.