IKEA TRÅDFRI 5-button Zigbee remotes missing event triggers (latest v24.4.5 firmware + Yellow SilLabs coordinator + ZHA)


I’ve been tracking a laundry list of issues operating IKEA TRÅDFRI 5-button remotes, however a firmware update seems to have resulted in some Zigbee devices working fine, but others missing all event triggers in ZHA except the remote Identify button which rather makes them rather useless as remotes!

Any ideas / thoughts / experiences would be appreciated, however I suspect this is going to need a GitHub issue and lots of debug logging.

UPDATE 1: Created Github issue 87495, non-working devices are missing zhaquirks.ikea.fivebtnremotezha.IkeaTradfriRemote1

UPDATE 2: Fix confirmed as working is to install a local “quirks file” until an updated version is included in a mainline HASS release. Instructions are linked in the GitHub issue report, with a command-line summary by me.


  • Yellow + inbuilt SilLabs Zigbee coordinator, all on latest HASSOS 2023.2.2
  • IKEA TRÅDFRI 5-button remotes, auto-firmware updating enabled giving all on 0x24040005 (v24.4.5 ?) which is very recent (in 2023-02)
  • Several automations triggered by remote events
  • (*nix sysadmin with too many years of complex diagnostic experience)

Latest Issue - all but 3x event triggers missing

  • 4x IKEA TRÅDFRI 5-button remotes automagically updated to 0x24040005

  • One remote works fine, and shows the expected 13x event triggers.
    e.g. Device → Automations (+) → Do something when… → Show 13 more…

  • Several other remotes show 3x triggers
    e.g. Device → Automations (+) → Do something when… → Show 3 more…

    So that’s 10x triggers missing (looks like 5x button On + 5x button Off)


  • All of the expected triggers caused by button presses (scene changes?) are missing.
  • Pressing a remote button does fire something, but I can’t see a way of using the event:

  • Note the difference in event naming between devices:
    • GOOD Bedroom 4 IKEA Remote Remote Button Short Press - Turn On event was fired
      Triggers an automation as expected

    • BAD Study IKEA remote Toggle event was fired
      Doesn’t trigger a pre-existing automation, and none can be created

Workarounds tried

  • Bench power supply connected to the remote to prove voltae - 3V3 gives 130%!
  • Factory reset / + Add Device - see below
  • RECONFIGURE scans fail every time, even removing attributes available after the original inclusion - see below

Historic Issues

IKEA TRÅDFRI 5-button remotes seem to work badly with ZHA even with the ‘quirks’ file automatically applied.

Recent issues include:

  1. The well documented short battery life, ranging from:

    • 2x months (next to the coordinator) to
    • 2x days (next to two mains IKEA Zigbee switches acting as Zigbee routers)
  2. Battery dies, replacement CR2032 doesn’t bring it on-line.
    Workaround: press reset 4x times quickly for a factory reset, LED flashes 4x times, fiddle with the buttons and reset until the red LED ‘pulses’ and after several tries (+) Add Device works BUT only next to the coordinator which means it ignores local routers, runs the battery down quickly leading to…
    Workaround: Pair a device next to the coordinator, then turn HASS off completely for 60 minutes.
    My understanding is this forces the restarted coordinator to recalculate the Zigbee mesh so remotes use nearby routers, which may workaround the pairing and bad battery drain issue.

  3. Devices also seem to work, then refuse to connect, with others failing a RECONFIGURE scan failing 100% of the time. The only fix I can see is a factory reset and 2.

  4. Battery level very erratic (looks like a known issue).
    IKEA only seems to report 100% / 66% / 33% / dead, although applying 3.3V from a bench power supply as a test reported 130%!

Thanks again,


1 Like

Thanks for this. Exact same issue and the workaround suggested in your GitHub issue fixed it for me.

I’m pleased to confirm adding a local “quirks file” with a pre-release version has fixed my issues as well.

Credit goes to the ZHA dev team, so read the GitHub issue report, for links to fix instructions.
All the best,