Install directly to USB flash drive = boot errors

I have a Pi3B+.
Wrote appropriate hassio image 32bit to USB flash drive (tried 3 different drives/brands) via Etcher.
Inserted drive to Pi, ethernet cable, etc… When I try to boot the Pi I just get boot errors. It looks like it is trying to do something. But no cigar.
If I leave the sd card inside it just boots to it instead. I thought the 3B+ was supposed to support USB booting.

Is there some trick to putting the hassio image on the USB directly using Etcher or Win32DiskImager? What am I missing? Any ideas?

Or, is there a particular reason we have to install to a SD card first and then burn an image of the SD to USB? That seems very antiquated, wasteful, and superfluous these days.

jpg pic of hassio install error

Did you set up USB boot on the Pi first?

I have a Pi3B+ , I didn’t think there was anything to set up on that for USB boot. I think setup is needed just on the Pi3.

Try this on your USB flast drive or SSD i am working with SSD no other options worked but this work Click the Link to see the Instructions :

1 Like

Coool - but then it is not hassOS - I might need to go that way as HassOS does not support USB boot (so SD-card crashes will be quite common for HassOS users)

I have just Read that hassOS is more application stable and easy to maintain than hassIO

Hi, Did you ever figure this issue out?
I have done everything that you mentioned and tried to look at the other suggestions on here but everything was far to technical for me… I am a Noob…
I have a brand new RPi3B+ I managed to load the Noobs software and it work fine.
When I try to load the Hassio image I get the exact same as your screen shot above!
Regards Adrian

You can install Raspbian (stretch) lite on SSD or HDD you want and then use the below Commands with SUDO SU:

Run this as root user (sudo su):

curl -sL | bash -s

sudo docker run -d --name=“homeassistant” -v /home/homeassistant/.homeassistant:/config -v /etc/localtime:/etc/localtime:ro --net=host homeassistant/home-assistant

curl -sL | bash -s – -m raspberrypi3

Then Reboot the RPi3 you hassio is started! enjoy