Install Home Assistant as a VM on Unraid

The video version of this tutorial can be found here: install Home Assistant as a VM on Unraid.

Step 1: Get qcow2 image
Go to and get the latest ova qcow2 image and unpack the compressed file.

Step 2: Prepare Unraid

  • Go to the settings tab of your Unraid server and ensure that VM’s are enabled in the VM Manager settings.

  • Go to your shares tab and ensure you have a “domains” share and that the SMB is set to export

Step 3: Copy the qcow2 image
On your computer, access the domains share and copy the qcow2 image to the share

Step 4: Setup New VM

  • Go to the VM tab of Unraid and select “Add VM” and choose Linux as the type

  • Give the VM a name

  • Select the cores to assign to the VM

  • Set the amount of RAM

  • Under “Primary vDisk Location” select “manual” and then select the image file we copied into the domains share. This will be located under “user” in the first drop down

  • Under “Primary vDisk Bua” select “SATA”

  • Pass through any necessary USB devices such as Zigbee hubs

  • Click “Create”

  • A new VNC window should open and run through setup. When you get to the login propt you can close the window

Step 5: Test Access

  • Open a browser and go to homeassistant.local:8123 to access your new Home Assistant instance

This isn’t a guide. It’s a link to a video that will soon be out of date. Post the written instructions in the first post in the topic so they may be edited in future.


Thanks for the feedback. I went in and added the written steps.


Perfect. Thanks.

Well they helped me out as my systems automation took out my hassio instance… as designed but not intended, so I just figured I’d throw hassio on unraid

hi! Is there any way to passthrough a share to HA?

I have been trying for days to get this to work. I can get as far as the Home Assistant is Preparing window. When I run ‘supervisor log’ I get a ton of errors about ‘supervisor has no internet connection’. I’ve fiddled around with DNS, Nameservers, gateways and have no idea why the supervisor can’t connect. I can Ping to external sites from the VM with no issue. At a complete loss and close to giving up. I just wanna free up a Raspberry Pi for another project.

Tested this today, looks like I can’t boot the image.

I think you’ve got the wrong image. I had this issue yesterday, there are a couple of versions of the qcow2 file, I tried the generic and got this message. I downloaded the next one down the list (can’t remember the name, but I think it was the next qcow2) and once I changed the drive it fired right up.

That’s true, I found out but forgot to update here.

Hi all, Has anyone encountered issues with HA VM install on Unraid over the last few days? I followed the instructions as per above and the system is running. However after a while with the two pinned CPU cores the unraid host locks into a 100% CPU usage. When i quit the HA VM it sheds processes and the other apps including docker containers and host returns to functioning. I have posted the above issue on the unraid forum as well as there is another HA user there that installed around the same time as me and has the same issue. Any assistance would be amazing.

Yeah, don’t take the upper one saying “aarch64”! We need amd64 and not ARM builds here :sweat_smile: