Installation of Hassio on Synology NAS

Yes it looks like the same error i have with my zigbee2mqtt usb stick plugged in. Did you try to start without it?

NB : before moving to hassio, I used classic docker containers for add-ons such as nodered, and it started ok even with the stick plugged in

I don’t have a zigbee nor z-wave stick so I can’t debug this but it seems like there is an issue with the addons if you have an USB stick. Please check in the hassio-addons channel on discord, perhaps someone there can help you with this kind of issues (I don’t think it is Synology related).

Registered to say thanks and to note that I managed to get Google Assistant Webserver ( addon version) working too. Required (A) the addition of a cheap usb sound card (possibly could have spoofed a sound device but I don’t have the know-how for that) and (B) changing the default ports used so as not to conflict with the ports used by DSM.

Have not been able to get node-red going.

1 Like

(as a reply on my github of @fredrike)(

Thanks, after upgrading to the lastest spk it seems to be working. At first it didn’t seem to work, but stopping and restarting the package from Synology Package Center apparantly did the trick. I can now find and add repositories.

Now I’ll play around with hassio to see if I can get the addons I had installed from HACS to work on Hassio (or install HACS inside Hassio)

1 Like

Same error for me. Received mine today and tried starting the addon runs into following error in system log:

19-07-31 15:11:18 ERROR (SyncWorker_5) [hassio.docker] Can’t start addon_7ad98f9c_zigbee2mqtt: 404 Client Error: Not Found (“linux runtime spec devices: error gathering device information while adding custom device “/dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B00193B13F2-if00”: lstat /dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B00193B13F2-if00: no such file or directory”)

config is:

  "data_path": "/share/zigbee2mqtt",
  "devices": "devices.yaml",
  "groups": "groups.yaml",
  "homeassistant": true,
  "permit_join": false,
  "mqtt": {
    "base_topic": "zigbee2mqtt",
    "server": "mqtt://",
    "user": "mosquitto",
    "password": "XXXXXXXX"
  "serial": {
    "port": "/dev/ttyACM0"
  "advanced": {
    "pan_id": 6754,
    "channel": 11,
    "network_key": [
    "availability_blacklist": []
  "ban": [],
  "whitelist": [],
  "queue": {}

hardware as below:


Look at this solution:

Hey @fredrike I’ve commented on your work in spksrc; I do have an avoton-6.1, I did a clean build of spk-hassio-avoton-6.1 and installed.

  1. good news: using a specified USB device for ZWave Integration works – I’ve just used the /dev/ttyACM0 that my Gen5 USB hotplugs as, and it’s less work than doing a rules file to softlink it to a known device.

  2. bad news: I hit the entrypoint.js issue with your PR in spksrc (d1b19970)

I’ll re-build and re-try tonight with your 7b9dbcc

How did it go? I’ve made a bunch of updates so it would be interesting to see how it goes for you.

Doesn’t the amd64 package work for your arch?

So far that build has been working well for me – I recompiled the SPK for my HW due to habit, if I didn’t need to, cool/sorry. I believe it downloads the and images for actual run anyways.

I can check later if it’s critical.

I had to restart to get the add-on list to populate, but this time it worked. Had some hiccups in wave, need to repopulate aliases, and maybe a few issues related to running a 0.85.0 config on 0.96.5. I’m happy to test a new version if you prefer. Lemme direct-message you some contact info if you need a quick re-check of a build.

1 Like

Hi All,

I’m having some trouble getting the plex media server addon working. I have the image installed via docker and home assistant itself is working flawlessly so far but I cant get the plex addon container started. Im faced with the following error message from the docker logs:

Start container addon_a0d7b954_plex failed: {"message":"driver failed programming external connectivity on endpoint addon_a0d7b954_plex (021534d1d12e67ee0bcc6cb69cd1582b659e00b4490a8e90294e59cb22f22bdd): Error starting userland proxy: listen udp bind: address already in use"}.
  • As described above I have tried installing the image directly to a share (volume1/ but that resulted in the same behaviour.
  • Have also tried manually start the container (this resulted in the error message). Previously trying to start the plex addon via HA would just result in a failed attempt with no log messages in either the addon or HA.
  • Have also tried adding the IP:port of HA to Plexs “Custom server access URLs” but that had no affect.

Plex is installed natively on my Synology DS1817+ (DSM 6.2.2-24922 Update 2)
Plex Version

Any help would be appreciated. Thanks

Simply means that you already have something running on port 32414, do you have another instance of plex running?

Edit: stop the natively running plex, you can’t have two instances running (on the same port).

Thanks for the pointers. Excuse my ignorance, but if I stop plex running natively on the nas, plex wont be running at all… Does that mean that the plex addon for is a new server altogether?

Yes it is a new server (I guess). I’ve not dared to migrate from native Plex to hassio-addon Plex my self yes so please keep us updated on your experience.

The benifit will (probably) be that you are managing all services from within hassio…

Ok Awesome… Thanks so much for your help!! I have the addon working now, but would like to point out one minor detail that isnt explained in the documentation and that is that after the install, the plex addon docker container needs to be updated to include mounting paths for media locations… Minor detail but thought it worth a mention.

Ill keep you posted here. I have turned off my native install (I wont delete it though, at least for the short term) and am slowly building the libraries for

Thanks again for your speedy assistance!

i am getting following error in haasio_supervisor log
can anyone advise what i am doing wrong her. Thanks

Error Log

Starting with the first message suggest that you have some kind of network issue:

Can't fetch versions from Cannot connect to host ssl:None [Try again]

Did anybody experience problems after the last Synology update ( 6.2.2-24922-3)? My Synology updated overnight, and SSH and MQTT promptly stopped to connect to api.

Some more info:
Log file in addon_core_configurator:
/ line 17: HASSIO_TOKEN: unbound variable

Logfile in addon_xxx_ssh:
[11:36:51] ERROR: Unable to authenticate with the API, permission denied stderr
11:36:51 [cont-init.d] exited 0. stdout
11:36:51 [cont-init.d] executing… stdout
11:36:51 [cont-init.d] exited 0. stdout
11:36:51 [cont-init.d] executing… stdout
11:36:51 /var/run/s6/etc/cont-init.d/ line 30: HASSIO_TOKEN: unbound variable stderr
11:36:51 [cont-init.d] exited 1.

I see it was addressed in another post: on Synology DSM (native package)

I have Hassio now running as Virtual Machine in my Synology. (DS918+)
Would this docker method be better? Less overhead maybe?

I have switched to using the native package as the VM kept dropping my USB Z-Wave and Google Coral TPU

What do you meen by Virtual machine on Synology? You have server that is just using Synology as place to hold image or?