Installing Home Assistant OS on a Mini-PC

I’m thinking both sides of this kerfuffle could tone down a bit. We who have been at this a while need to remember that, when you’re starting out, you often don’t even know what question to ask or how specifically to frame it. All you know is that you tried something and it didn’t work.
The new folks could do well to read through the “How to help us help you” article and remember to provide as much detail as possible about exactly what you were doing, at what point it failed, and what, if any messages you received when it did.
Patience, all around is vital. I’ve benefitted in so many ways from people who took the time to answer my questions in detail. I’ve also benefitted from following links and reading up on my own.

3 Likes

No, it doesn’t.

I am addressing this thread, not some other thread. I have no idea what else you posted somewhere else.

Or, try this.

After you have flashed the Home Assistant image to the drive, go to the Windows File Explorer. The drive should now be labeled haos-boot (or similar). Double click on it and then create a new folder named CONFIG. Then, inside that folder, create another folder and name it, network. Using Notepad, create a new file named my-network (no file extension) with the following:

[connection]
id=my-network
uuid=YOUR_UUID_NUMBER 
type=802-11-wireless

[802-11-wireless]
mode=infrastructure
ssid=YOUR_WIFI_NAME
#Uncomment below if your SSID is not broadcasted
#hidden=true

[802-11-wireless-security]
auth-alg=open
key-mgmt=wpa-psk
psk=YOUR_WIFI_PASSWORD

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

You can generate a UUID HERE

I don’t, and haven’t used the instructions listed, so can’t help any further.

I just see only in one last week the fourth topic, where some wise nose is stating against a newcomer, that maybe he is not capable enough to run HA, based on that one single question.

This annoys me realy very much, the sphere on the forums is touched by this behaviour.

So i will say it again, even expecting a rainshower of critics from the best coders on this planet, who knows everything:

Not everyone here is even smart as you. If people ask for help, tha last thing they expect is being told, that their are maybe not capable enough. Well, that way any learning is blocked, no any help is given, it’s just a smash in the face.

Please, realise, that we are all different, have different skills and need different methods to learn and find out, how things sticks together. Be kind to each other.

That part, Paul Hibbert is right. I’ve experienced this here also. And I’m actually a geek my whole life.

Thanks for listenning.
And now I’m seeking cover, because I know, the stones are going to fly against my head… :slight_smile: Well I don’t care. If I only helped one man to change his mind, my mission of this message is accomplished.

2 Likes

Thanks. Will give that a go, appreciate the help

I have just tested these instructions on a Pi4 with HA OS and can confirm they work, so assuming you have a HA/Linux compatible WiFi device in your PC, you shouldn’t have any problems.

All I did was to generate a UUID using the link provided, and enter my network name and password in the relevant places.

I need help with my installation. I have HA running successfully on VMware on windows 10. HA does not start up when I try to boot it after a power outage. startup always gets stuck at a black screen with “autoboot-” on it.

I’ve have struggled all day to install HA x86-64 on an old desktop on which I can happily install Windows 10 or Ubuntu 20.x and perform whatever activities I want. I have HA running on an RPi with an SSD, but I have close to 900 entities and the fan is running really loudly. So I though I’d give the x86-64 a try.

I have two drives, 1TB and 3TB. The 3TB supports UEFI. I created an ubuntu boot image and run ubuntu in trial mode. I then install Balena Etcher on ubuntu and use it to burn the x86-65 image tot he 3TB drive.

But when I come to boot, it keeps on telling me to install a boot drive. I rebooted into the BIOS, and now I cannot see the 3TB UEFI drive, only the 1TB non-UEFI drive. However, if I go into the Boot Loader menu I can see the 3TB drive. Selecting it just takes me back to the message that I need a boot drive.

  1. I don’t know why the drive disappeared from the list of boot drives after I flashed the x86-64 image
  2. I don’t know why the drive is no longer seen as a UEFI drive after I flashed the x86-64 image

Any clues? Any suggestions for the next step?

You can see the x86-64 image written the the one hard drive:

The boot image and other partitions I presume are as expected:

Make it easy on yourself. Install Debian, install supervised.

2 Likes

Exactly, what I’ve done too. Easy install and reliable, fast response on a Intel Celeron J1900 Quad core processor with 4GB RAM.

yeah, I’m not very good at the OS level, so I was hoping for something as simple to install and maintain as the RPi

If you are not using the machine for other things, just for HA, ditch one of the hard drives, keep just one in it.

  1. Install Debian → How To Install Debian 11 (Bullseye) with Screenshots – TecAdmin

  2. Install HA → https://github.com/home-assistant/supervised-installer

Done.

Thanks for the links. Very helpful.

The only issue that I ran into is that I had to create a new user with Admin rights because I couldn’t change the default user rights to sudo.

Will this work on Ubuntu too?

Ubuntu isn’t a supported OS for a Supervised install. Check this guide for a more detailed walk through of the install process.

I’ve started with HA on Ubuntu before, had to change to Debian, because I had some issues. Can’t remember anymore exactly what. I do remember the important part - it did not worked perfectly :slight_smile:

I got mine working now on a Beelink T4 mini. I installed the Generic x86-64 image and here is how i got it working.

  1. Download and flash Ubuntu image on a flash drive or SD card. Any ubuntu will do. I used 20.04

  2. Copy the downloaded haos_generic-x86-64-6.6.img.xz image into another flash drive or SD card

  3. Boot with the ubuntu flash drive but select try ubuntu without installing

  4. When ubuntu is booted, Insert the second flash drive

  5. Open the flash drive and right-click on the HAOS image, open with disk image writer

  6. select the T4 mini disk (or NUC or your laptop) as the destination and restore

  1. When completed, shutdown ubuntu, remove the 2 flash drives and restart
3 Likes

I just bought a Dell OptiPlex 3040 i3-6100T Micro (SFF).
Will Home Assistant run on this as a stand-alone server?

Yes it’ll be great. How much RAM?

It should work. Just remember to Make UEFI Boot mode is enabled and Disable Secure Boot.

You can follow my guide above if you want to use the entire system for HA OS

1 Like

Sorry to everyone that responded to my question, I’ve been having too much fun with this setup.
For RAM I just upgraded the RAM from 8GB (2x4GB sticks) to 16GB (2x8GB sticks).
For now, I am running Home Assistant Core now I am thinking of moving up to Home Assistant Supervisor.
I am so glad that I tried this software again, it was 3 yrs ago when I tried it for the first time. I am so glad that my IT education has paid off…lol