Installing Home Assistant OS using Proxmox 8

no, I just found this thread covering the RC1 release and hoped someone has an idea :wink:

I hope that you have a recent backup that’s not on the Blue, because you may have to re-flash.

I have :slight_smile: but I’m wondering what could be the issue, because even after rebooting 3 times, the system should rollback automatically, but there happens nothing :frowning:

How a Proxmox VM works is entirely different to the Blue.

1 Like

Not sure if this is a HASSOS issue or proxmox, but whenever I try to update HASSOS the system will disconnect (probably because it’s updating), but then will never come back up on its own. I have to force stop the VM and start it back up and then it’s on the latest version of the OS. Going into Console when this is happening doesn’t show anything so not sure what the deal is. Is there some setting I may have missed? I used this script last year, been having this issue ever since. Just leads me to not update as often as I should. Anyone else run into these issues?

1 Like

That’s before this guide started using my scripts (a lot has changed).
I’d suggest making a full backup of HA and download it.
Copy the MAC address of your VM and shut it down.
Create a new HAOS VM with the script above not using the default settings so that you can insert the MAC address from the other VM (this will keep the IP the same as the old VM).
Upload and restore the backup.
If everything is working as it should, remove the old VM (never run both VM’s at the same time)

1 Like

By not using the default settings do I need to change the script or do you just mean shut the VM down, edit the network settings to override the MAC address back to what it is currently?

When you run the script, it will ask you if you want to use the default settings, select NO

got it, thanks!

How did the update to OS 9 go?

thanks for checking! I haven’t done it yet, (didn’t even now it was out). I’ll try tonight and see how it goes and let you know.

1 Like

The HA Team just made a Revert “Bump stable channel Home Assistant OS to 9.0” so you may have to wait for an update.

Edit: They just made a Revert "Revert “Bump stable channel Home Assistant OS to 9.0"”
OS 9 is a go, again

It looked like it worked. I had removed some hardware but hadn’t shutdown/rebooted the VM so it had USB errors after the install and reboot, so I had to shut it down and reboot.

1 Like

So, all’s well now! :+1:

1 Like

Worked fine for me! :+1:


I’m facing same issue and tried just 1 hour ago to update rom 8.5 to 9.0 but I still get stuck.

As I read from your message, it should be all working after

Edit: They just made a Revert “Revert “Bump stable channel Home Assistant OS to 9.0””
OS 9 is a go, again

Should I do anything before or after the update process?


The conversation between patmann03 and I starts here of trying to solve their issue of getting stuck after OS updates. Your issue may be totally different.

:arrow_right: If you installed HAOS using a script from this guide before May 3 2022, I’d suggest doing this.

1 Like

I haven’t used your script, but I used this script to create the HA VM.

I will try to check messages in this thread to see if it’s valid also for my issue


Pretty sure that is the script I used as well about a year or so ago. I do think taking a backup and rebuilding the VM with this script worked. I will know for sure next OS update.



I’m trying to create a new HA VM due to an issue updating my VM from HA OS 8.5 to 9.0

But I’m getting this error

Creating a HAOS VM using the above advanced settings
 ✓ Using local-lvm for Storage Location.
 ✓ Virtual Machine ID is 100.
 ✓ Downloaded haos_ova-9.0.qcow2.xz
 ✓ Extracted KVM Disk Image
 - Creating HAOS VM...400 Parameter verification failed.
name: invalid format - value does not look like a valid DNS name

qm create <vmid> [OPTIONS]
‼ ERROR 255@268 Unknown failure occurred.

It seems something related to DNS

this is my DNS configuration in Proxmox

Schermata 2022-09-17 alle 11.31.52

I haven’t used default settings in the script, to enter the MAC address of the other VM and I choose not to start the new VM automatically.

The script I’m using is
bash -c "$(wget -qLO -"

What else should I check?