Installing Home Assistant Supervised using Debian 12

If it saves time having to configure/set up Debian then why not image it? Network settings, users, permissions, changed repositories, etc. Now, if you load up a Proxmox VE box, the built in backups/snapshots of VMs and containers are a thing of beauty and virtually eliminate the need for images.

1 Like

If you think the time spent doing this regularly enough (weekly/monthly) to have a recent working back up is time better spent than 20-30mins every ~2 years if an SSD fails, then go nuts.

In the time span an SSD should and will last, you will most likely move to another machine making the imaging redundant.

Still having this issue:

Error response from daemon: Get “”: dial tcp: lookup on [::1]:53: read udp [::1]:60704->[::1]:53: read: connection refused
dpkg: error processing package homeassistant-supervised (–install):
installed homeassistant-supervised package post-installation script subprocess returned error exit status 1

Already disabled IPv6, but still no go…
Anyone having any suggestions??

Maybe @RVital’s workaround helps?

Add to /etc/hosts:

Tried it with

But seems to be an issue with dns in relation with IPv6

tcp: lookup on [::1]:53: read udp [::1]:60704->[::1]:53:

And now that i look at it…maybe add ??

At last…

Stared at it for a couple of days, searched for a solution a couple of days, but answer was right in front of me the whole time :smiley:
Thanks for making me see @Tamsy !!

PS: Not sure if this is (still) required, but it can’t hurt to add it :stuck_out_tongue:

Anoyher and probably more viable solution than the above workaround (ip addresses can change at any time) can be found here.

Hi guys,

How can I get docker-compose to work and avoid the “You are running an unsupported installation” ?

Had the system running fine, then tried to do `sudo apt install docker-compose’
Now I have the “You are running an unsupported installation” and afaik I will not be able to do updates when this message are active?

you can’t avoid unsupported if you install compose. But that won’t prevent you getting updates as normal. Even if you get the unhealthy message as well there is a cli command to tell HA to ignore it and you will get updates as normal.

Thanks @DavidFW1960 :slight_smile:

After I did the sudo apt install docker-compose, my NetworkManager got screwed up. Are there any other way to get docker-compose installed to avoid messing with NetworkManager?

btw; do you also have the CLI command you did mention (for my own records) ?

Look at Section 4 paragraph 3 within the OP.


Somewhere around Section 2.1 the guide needs to be updated.

Debian is now shipped with ifupdown. This will interfere with network manager.

If the following message is shown when installing network manager:

The following network interfaces were found in /etc/network/interfaces
which means they are currently configured by ifupdown:
- eno1
If you want to manage those interfaces with NetworkManager instead
remove their configuration from /etc/network/interfaces.

Then the file: /etc/network/interfaces needs to be edited. In my case the lines with eno1 (my ethernet) needs to be commented out, before proceeding. If this is NOT done, the machine will crash and nothing will work.

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eno1 <-- This should be commented out
iface eno1 inet dhcp <-- This should be commented out

Remember to reboot before proceeding.

1 Like

ifupdown has been shipped with Debian since ages (a quick lookup brought me back to Debian 8 Jessie (released April 2015).

I don’t know what went wrong with your installation to show that described message. Just last week I installed a new Mini PC using this excellent guide and all went smooth without any errors.

I followed kanga_who’s guide step-by-step except for:

apt-get install ... avahi-daemon ...

because the requirement for Avahi was superseded in favor of systemd-resolved within the supervised-installer beginning with version 1.1.1.

Having avahi-daemon and systemd-resolved.service active leads to unexpected errors when starting Supervisor. David started a extended thread about the latter here.

Going back to the topic, did you remove the wired eth0 after installing Debian (after Section 1) and continued with Section 2 of the guide by using WLAN? There are indeed reports about ifupdown seemingly freezing the boot process for quite some time if no Ethernet cable is plugged in but this should has already been fixed ages ago according to the bug reports.

The comunity guide suggests to continue remotely only after having completed Section 3.2 which in my understanding should be the earliest to remove the wired connection and continue remotely which can also be through WLAN (which is discouraged all over the forum anyway).

Other than the above the whole installation process is working flawlessly as long as one strictly sticks to Jason’s guide as I just went through the whole process (except for installing avahi-daemon) a couple of days ago.


I’ve used to run Debian on my RPI4 and have never seen ifupdown on that. Could be that the vanilla Debian for RPI don’t ship with ifupdown?

I’ve always been running wired. As soon as the HA install is finished, the connection dies and I get a ton of DNS errors in the log, but if I comment out those two lines, everything is working perfect (except I can’t set a fixed ip in the frontend)

So I should just omit the avahi? or is there anything else to be installed instead?

Thanks for reminding me, need to update the guide. :+1:


Definitely. Probably that will also fix those DNS errors you are describing without having to tamper with “interfaces”:

Since we are using systemd-resolved the reversal conclusion is to disable/remove the avahi-daemon:

Dependencies updated

1 Like

That didn’t help unfortunately :frowning:

Don’t know if this has something to do with it

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 6.426/6.426/6.426/0.000 ms
Device "eno1 <-- THIS
eno1" does not exist. <-- AND THIS
[info] Install supervisor Docker container
[info] Install supervisor startup scripts
[info] Install AppArmor scripts
[info] Start Home Assistant Supervised
[info] Installing the 'ha' cli
[info] Switching to cgroup v1

When I list the nmcli, I can see that’s renamed to Supervisor eno1

Could that be something messing it up? or is that just a label that the system gives the connection?

Maybe my post here helps?

1 Like

Ok, as I’ve got some clearance on how to resolve healthy/unsupported, I still would like to know how I would get the docker-compose installed without breaking my NetworkManager?

@kanga_who are you able to assist me on this? Great tutorial by the way :slight_smile: