Installing Supervised on Pi5

Hello,
I don’t get the Raspberry Pi 5 option when I run
dpkg -i homeassistant-supervised.deb
Should I use the Pi4 option for my Pi5?
Grateful for answers.
Fredrik

The pi5 is not yet supported.

1 Like

Managed to install it supervised w/ rpi5 beta releases?

I have succesfully installed and ran HA Supervised on Pi 5. During installation choose Pi 4 and it works normally.

Do not forget to switch the kernel page size from 16kb (default on Pi 5) to 4 kb, because HA uses jemalloc that crashes with 16kb page size and therefore docker container with HA won’t run.

And enable apparmor by adding this at the end of /boot/cmdline.txt:
apparmor=1 security=apparmor

After this you can use one of the tutorials. First you need to install all dependencies, next - docker, the os-agent (I suggest downloading the newest .deb package for aarch64, now it is 1.6.0 I believe) and finally - the HA Supervised itself. During installation choose RPi 4 x64.

1 Like

Hi,
I’m desperate to do this as i want to install HA sup… Can you tell me how to change the kernel page size from 16kb to 4kb?

I have sent the link to the guide in my previous reply - “Pi5 16K PageSize Kernel Incompatible Software”.

Go to boot/config.txt and change the line “kernel=” to:
kernel=kernel8.img

Here I found a guide for installing:

I have not done point A and B (the unified_cgroup_hierarchy thing) from Step 3 (changing grub file) and everything worked out of the box. Do not forget to enable apparmor, however (just at the end of Step 3).

I think the Pi 5 GPIO mappings are different on the Pi 5 now, so GPIO support may not work correctly if choosing RPI4.

Edit /var/lib/dpkg/info/homeassistant-supervised.templates and add raspberrypi5-64. then run:
sudo systemctl stop hassio-supervisor.service
sudo docker stop homeassistant
sudo docker rm homeassistant
sudo dpkg-reconfigure homeassistant-supervised
sudo systemctl start hassio-supervisor.service
You should then have it running.

2 Likes

hey guys, thx a lot for the instructions.
so i did as [Block3r] said, so
kernel=kernel8.img
apparmor=1 security=apparmor
installed os-agent and HA supervised with RPI4.
had issues with the homeassistant docker, so followed the instructions from [Terry Sanders] in addition.
and voila :slight_smile:

Installed on rpi 5 os or Debian?
Is it stable?

I used Raspberry Pi OS and haven’t had any issues once I actually got it installed.
Observer reports:

Supervisor: Connected
Supported: Supported
Healthy: Healthy

I’ve had it running since December and Core (and some addons) have upgraded several times without any issue. Currently running version 2024.1.5

Supervised? Cause the topic says supervised.

Yep, Supervised. All addons and updates available via the UI.

how did you manage that :smiley:

I am getting OS-Agent bot modul is loaded and OS-Agent installed.

[supervisor.host.sound] Can’t update PulseAudio data: Failed to connect to pulseaudio server

[supervisor.dbus.rauc] Host has no rauc support. OTA updates have been disabled.

[supervisor.dbus.agent] No OS-Agent support on the host. Some Host functions have been disabled.

could you share any insights how to fix it? thank you

I followed this guide using a fresh install of raspbian.
I initially had some problems with memory allocation which I resolved by booting kernel8.img and manually edited the /var/lib/dpkg/info/homeassistant-supervised.templates file to add the pi5 to the options.

‘rauc’ is for updating embedded linux (HA-OS) but you are using raspbian, which you have to update yourself, so you can ignore the supervisor.dbus… messages.

I don’t know about the pulseaudio since I’m not using any audio and don’t get that message.

1 Like

Hey I made a tutorial about the installation process on my Github. It may help you.