Guide: How to install Home Assistant supervised on Rpi4 with RaspiOS (64 bit) - October 2022

Warning

The following installation instructions, for Home Assistant Supervised on Raspberry Pi OS, will produce an unsupported version of Home Assistant.

Why? Because official support is provided exclusively for Home Assistant Supervised on Debian and no other version of Linux (not even any derivative of Debian).

The resulting system will be marked ‘Unsupported’ and if you encounter any problems with it you may seek assistance from the community but not from the development team (who reserve the right to reject any bug reported for an unsupported system).

If you want a supported system, follow the official installation instructions for Home Assistant Supervised on Debian.


Updated: 2022-11-03

Here I leave you a guide for the installation of HA Supervised.
This guide is just intended to be use with experimental purposes, probably the best choice for most of us would be using HA OS.
Hopefully It will be useful to some of you!

Install Home assistant Supervised in RPi 4



Attention!

Everything should be done with LAN connection because wifi is lost during the procedure!!!

Step 0: Upgrade your system

sudo apt update && sudo apt upgrade -y && sudo apt autoremove -y

Step 1: Install the following dependencies with this command:

sudo apt-get install \
apparmor \
jq \
wget \
curl \
udisks2 \
libglib2.0-bin \
network-manager \
dbus \
systemd-journal-remote -y

Then reboot and wait a little bit, the Rpi will reboot a few times.

Step 2: Install docker (important! Do not install portainer, it will make your installation unhealthy and you won´t be able to install add-ons):
curl -fsSL get.docker.com | sh

Then create Docker group and add your user to the Docker group:
sudo groupadd docker
sudo usermod -aG docker $USER

Step 3: HA Supervisor depends on a particular Docker CGroup v1, so we make sure that we install it that way. (CGroup Version - Home Assistant)
To solve this problem we need to add the following lines in two different files:

A- Add “systemd.unified_cgroup_hierarchy=false” to /etc/default/grub:

sudo nano /etc/default/grub
and paste: systemd.unified_cgroup_hierarchy=false

B- Add systemd.unified_cgroup_hierarchy=false to the end of /boot/cmdline.txt.

sudo nano /boot/cmdline.txt
and paste:
systemd.unified_cgroup_hierarchy=false
apparmor=1 security=apparmor

Reboot.

Step 4: Install the OS-Agent (ver. 1.4.1):
a- First: download the correspondig os-agent acording to your CPU architecture, in this case aarch64 (RPi4)

wget https://github.com/home-assistant/os-agent/releases/download/1.4.1/os-agent_1.4.1_linux_aarch64.deb

b- Second: Install the downloades package

dpkg -i os-agent_1.4.1_linux_aarch64.deb

c- Third: To check if it was installed
gdbus introspect --system --dest io.hass.os --object-path /io/hass/os

If it prints something back, everything went OK

Step 5: Get Home assistant supervised

wget https://github.com/home-assistant/supervised-installer/releases/latest/download/homeassistant-supervised.deb

Step 6: Install home assistant supervised
In this step if you are connected through wifi you will loose connection, you need to be using LAN!!!

dpkg -i homeassistant-supervised.deb

Step 7: If you get an error during the instalation:
sudo apt --fix-broken install

That will fix it and a blue screen will appear, choose your model of RPi

Finally wait several minutes until HA is available at http://[your_IP]:8123

If you can access HA you should reboot your Rpi and the wifi connection should be available after rebooting, if not go to the following step.

## If wifi is not working ##

Step 8: Fix the interfaces file
Remove everything but first ‘source-directory’ line in /etc/network/interfaces.

Using nano:

sudo nano /etc/network/interfaces
Use CTRL+K to delete lines, CTRL+O to save, and CTRL+X to exit nano editor.

Step 9: Enable dhcpcd
Enable ‘dhcpcd’ with:

sudo systemctl enable dhcpcd

Step 9: Disable networking
sudo systemctl disable networking

Step 10: Restart Raspberry Pi
Restart the Pi to have the changes take effect.
sudo reboot

Done! WiFi should work now.

Hopefully you will be as happy as I was after figuring everything out.
Kind regards,

Federico, PhD in biology from Argentina and nowadays living in Germany.

8 Likes

I would change the category of your topic to Community Guides. :+1:

1 Like

It should also be noted that doing this will result in issues since the requirements are quite clear - only Debian itself is supported.

Anybody following this guide should do so in the knowledge that their system is likely to break without warning, and getting it working again is likely to require significant effort.

You should instead either:

  1. Use Home Assistant OS
  2. Use a pure Docker (HA Container) install
6 Likes

Thanks for you reply, luckily I have been using this same setup in a Rpi2 for more than 8 months without any issues.

I am just sharing a guide that actually works. All the guides i saw out there were not working… So, I just try to help… But as they say, do it under you own risk.

I like having RaspbianOS and running HA under docker container. Nothing should go wrong if you have everything within containers.

Thanks for the extra advises for everyone out there!

Done! Thanks for your help!!!

Why not run HA Container then?

1 Like

Because if (I am not mistaken) you use it as a container you can´t install add-ons. HA supervised is pretty much the same as HA Os but you can still use the RaspbianOs.

No, you can’t

The requirements are incredibly clear on this, yet people still seem to think otherwise:

Debian Linux Debian 11 aka Bullseye (no derivatives)

The only things the Supervisor gives you are:

  1. Built in backup and restore functionality
  2. Add-ons - which are just software running in a container

Dear Tinkerer,

I am right now using the same Rpi4 where I have HA Supervisor with RaspianOS and Chromium to reply to this message.
So please, don´t confuse people.

As you said, HA Core DOES NOT support add-ons and that is extremely annoying and makes everything extremely difficult, because while I used it I had to install every container inside Docker. With the Ha Supervised, it es MUCH MUCH easier to install add-ons with almost no effort.

This guide is for people that want to try and experience different options, I in my opinion that is one of the biggest advantages of Rpi’s-

Just grab a microsd card and fool around.
For this matter sake I encourage everyone to do their own research.

Best regards!

1 Like

By installing Home Assistant Supervised on anything other than Debian, the installation becomes unsupported.

The “unsupported” designation means the development team will not provide support for any problems the user encounters. The user of an unsupported system is expected to solve their own problems and/or with the community’s help.

Unless a user is willing to accept the consequences and responsibilities of operating an unsupported system, they should use one of the supported installation methods.

Good advice. The information Tinkerer has presented, that wasn’t included in your installation instructions, is important for their research. Some users may decide that they want a supported system and so will choose to install Debian.

1 Like

Along with that, installing anything outside of the HA ecosystem on an HA Supervised installation (apart from the requirements listed in the official instructions) will result in it becoming unsupported.

(I mention this because OP said they’re using Chromium on their HA host to reply to this thread)

2 Likes

You’re the one confusing people - sure, you can ignore the requirements, but advising people to do so is unhelpful. You’re setting people up for failure, and that’s not a nice thing to do.

Dear @Tediore,

In here I provide you with one image that shows how I am using Chromium in the same Rpi4 where I host Home Assistant Supervised.

I wish you a nice day,

Federico

1 Like

Good afternoon dear @Tinkerer;

By any way I advise people to do a supervised installation, I am just providing the results of my experience in this wonderful journey related to HA.
If someone found this post I am pretty certain that has already done some research, but I am glad the everyone is providing its own opinion to make it even clearer.

As I mentioned before, in my own case I just wanted to be able of using RaspianOS and have HA with the possibility of using add-ons because they simplify everything. What I am mentioning here is shown in the following image.

image

1 Like

I didn’t say you’re not using Chromium on the same Pi that you are running HA Supervised on. I said that installing anything outside of the HA ecosystem on an HA Supervised installation (apart from the requirements listed in the official instructions) will result in it becoming unsupported.

2 Likes

For Valkanoise:

Thank you for your affords. This helped me a lot.


For Tinkerer:

I get your point. It is written all around the place and I beleive there is no confusion. I am a noob. I can only do good research and try it out. But still, for years I am using Supervised allthough it is stated that it is for “experts”. Why?

  1. I use the same raspberry for lots of other purposes. In my friend’s office the same Raspberry is used for both Homeassistant and MagicMirror. In my office I use the same Raspberry for octopi and homeassistant. In my home I use Truenas Scale. I have one VM for homeassistant and one VM for Kodi (with dedicated gpu for it). This is by far the best approach I have.

  2. I use several addons on Homeassistant. I know addons can be done with container. But here is the thing: I am a noob. Using every addon from container is hard thing for me.

So I use Homeassistant supervised for years, even if I am a noob. I know it is not recomended but I had very few problems and thaks to people like valkanoise I can solve them.

I would like to use Homeassistant Os and use another raspberry for other needs; but it is not possible for people like me (people who live in Turkey for example) due to prices of an old pc or a raspberry. Even if we take the price of a raspberry as 110 usd (which is not due to chip shortage) it is pretty expensive for us. 60% of the population here lives with 310usd per month.

@valkanoise Hi, nice guideline.
I’ve followed step by step your guidelines on my RPI 4 with SSD, and unfortunatelly it doesn’t work for me.
I still receive the errors. See attached printscreen.
So far I tried a lot of methods based on Raspberry PI OS and I tend to believe that Debian 11 no derivative recommendation is true. Looking forward your oppinion.

The ADR aren’t recommendations, they’re requirements. As has been said many times, if you ignore them you are going to have problems.

Hi Mr Tinkerer,

don’t you think that stating that “you are going to have problems” is a little too much FUD?

I see your point.
Supervised is unsupported, and if any problem arises somebody using such deployment is basically left alone by NabuCasa.
Stating that having an unsupported installation is basically calling for trouble is a bit pessimistic.

Sometimes is the only way to go.
I have my z-wave USB antenna not connected directly to my HA instance, but using usbip it can run smoothly. This is close to impossible on an “official HASS” installation.

But it is definitely true that this installation is not that tested/stable, and sometimes (I repeat, SOMETIMES, not ALWAYS, expecially if you keep it simple) you have to hack it a little.

e.g. After one year of happy running supervised, a recent update of HA container started to blame about having a wrong cgroups version (HA requires the legacy instead of version 2).
“best way to fix is re-run supervised-installer”

Supervised installer script is gone. Now you have a shiny DEB package.
A broken one, where the os-agent package on aarch64 (e.g. raspberry pi 4) is not recognized, and as such the prerequisite is not satisfied, and apt/dpkg spit all kind of errors.

Downloaded the installer source, changed the “os-agent” to “os-agent:arm64” and reinstalled the package. Now it works.

Supervised can help in a couple of scenarios, have a lot of features (IMHO is a lot more flexible than HASSOS), and it is not as difficult as running and maintaining all addons by yourself in docker.
It is definitely not for the faint of heart, but it’s here, and thanks to people like valkanoise this is a bit more “community-supported”.
Until such repo will be removed :frowning: (my guess is that it will sooner or later)

1 Like

HA Supervised is definitely not required for this. This would be possible to do with both HA Container and HA Core installations.