iOS app & themes

It seems like the iOS app does not entirely adopt themes, but leaves the header toolbar & footer with orignal coloring. This looks a bit weird:

Would it be possible for the iOS app to adapt to the home assistant theme, or maybe just provide a config option for 1-2 settings (background color, text color, maybe detail/highlight color), so we can set it up to match our selected themes?

I am planning to get some old ipad and have home assistant running in kiosk mode as wall terminal, and it would look really better if the colors matched :slight_smile:


To get this to work on your iOS device go to Services under dev-tools, choose frontend.set_theme and the add { "name": "your_theme" } to service data.

I understood that the header and footer only change with the build-in themes and not with the custom themes.

For me the colors changed after refreshing several times and/or hard quitting the app and reopen it. But it might be a style setting though, I wouldn’t know as my knowledge is limited on css. Refreshing a lot helped in my case :stuck_out_tongue:

Didnt change anything for me :frowning:

Which theme are you using?
And just to be sure, you have changed your_theme with the name of the theme you are using? :zipper_mouth_face:

I’ve tried your suggestion and it doesn’t work for the built in or custom themes. I believe there’s a variable that needs to be set in the theme itself. There’s a few older threads that talked about this, but every time I’ve tried creating a theme with those variables it either does nothing or complained about an invalid variable option.

Yeah I have read those threads too. The ones which worked for other people weren’t working for me until I used the frontend.set_theme solution, for example with this theme.

1 Like

Yeah sure I replaced the theme name.

I am using this theme:

Maybe there is some definition missing which is responsible for coloring the iOS bars?

This worked for me, but it reverts again at times, so it isn’t a permanent fix. Quite annoying when you have a few devices and you have to manually do this.

(Just a note, to make this work, I had to call it, hard refresh a few times, call it some more, hard refresh, quit the app, call it again, refresh, quit the app, and phew, the setting ‘took’)

The HASS app 2.0 due for public release soon solves this.

Hey there,
I had a quite similar problem. And i think you need to read my own post for your solution :wink: