Issues with zeroconf and Docker container on a pi3

Recently I started to get issues with zeroconf in my docker setup. I am running the official pi3 image. During startup I get the following error message:

Error during setup of component zeroconf
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/homeassistant/", line 145, in _async_setup_component
    component.setup, hass, processed_config)
  File "/usr/lib/python3.6/asyncio/", line 332, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.6/asyncio/", line 250, in _wakeup
  File "/usr/lib/python3.6/asyncio/", line 245, in result
    raise self._exception
  File "/usr/lib/python3.6/concurrent/futures/", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/lib/python3.6/site-packages/homeassistant/components/", line 33, in setup
    zeroconf = Zeroconf()
  File "/usr/lib/python3.6/site-packages/", line 1670, in __init__
    socket.inet_aton(_MDNS_ADDR) + socket.inet_aton(i))
OSError: [Errno 105] No buffer space available

It already started with version 0.64.3 and it is still there with 0.65.5. I think it must be related to my overall setup, since it appeared without upgrading my home assistant version. I changed some other containers on my system, but since they should be isolated, I can`t imagine the root of this issue.

Any ideas where I could start to debug?

That is the docker-compose file I am using:

version: '3'

    image: homeassistant/raspberrypi3-homeassistant:latest
    container_name: homeassistant
    restart: always
    network_mode: host
      - /opt/home_assistant/:/config
      - /etc/localtime:/etc/localtime:ro
      - /opt/ssl:/ssl

    image: oznu/homebridge:raspberry-pi
    container_name: homebridge
    restart: always
    network_mode: host
      - TZ=Europe/Berlin
      - PGID=1001
      - PUID=1001
      - /media/usbstick/container/homebridge:/homebridge
      - homeassistant

I was able to solve it somehow by removing old unused docker networks.

1 Like

@Tribune that worked for me as well. All I had to do was run docker network prune

I am having the same issue, but prune did not work for me. Any other ideas?

Actually, in another case I did work for me - but now none of my cast devices (chromecast, google home mini) are not shown anymore. I tried readding the integration but discovery does not find any of the devices anymore… any idea what I could do?

For future reference, the clearing of networks probably reduced the users of the igmp_max_memberships limit, hence it “worked”.

1 Like

Had this issue since my system updated to 2021.6.2 and this fixed it for me.