Italian users

Ciao a tutti.
Ci sono anch’io
MArco

Ciao, sto cercando una presa elettrica per Hassio (anche da eseguire agg firmware tasmota).
Che modello mi suggerite?

si puo usare un hd con raspberry.
si puo fare sia da soli che con dei kit credo

Ciao a tutti

Buongiorno a tutti,

chiedo il vostro aiuto per cercare di risolvere un problema legato ai comandi di Alexa echo dot.

ho interfacciato Alexa con Home assistant e configurato le tapparelle della mia abitazione.

Le tapparelle però funzionano esclusivamente sul comando vocale “Alexa , ATTIVA tapparelle”. Mentre il comando “Alexa, APRI tapparelle” dice che non è una funzione disponibile sul dispositivo tapparelle.
Vorrei capire se il problema riguarda un limite di Alexa oppure una errata configurazione di Homeassistant. Nel caso quale suggerimento avete?

Grazie a tutti in anticipo

Ciao a tutti, sono un neofita di home assistant ed ho un problemino, ho comprato raspee come gatewey zebeeg , istallato secondo le guide e funzionava tutto.
A seguito di un errore di configurazione ho deciso di reinstallare il haso.io ricarico l’app deconz e magicamente mi trovo 2 gatewey, uno con ID corretto ed uno con ID 000000000000000

Risultato non riesco più a far funzionare l’interfaccia

Avete qualche idea per aiutarmi

Grazie a tutti

Ciao
Vincenzo - Udine

Ciao a tutti, vorrei chiedere all admin di creare un sottogruppo ufficiale .vi va ?
A qualcuno va di fare da mod insieme a me ?

Buona sera a tutti ^^

Ciao a tutti!

Scrivo da Torino. Ho Hassio che gira sul mio xpenology server da qualche anno ormai.

Colgo l’occasione per chiedervi già un supporto (scusa se vi sembro sfrontato ma ce l’ho in testa da un po’ e non riesco a sapere come fare).

Sto usando questo package da un po’ di tempo.

Va alla grande ma purtroppo ho notato che spegne anche i dispositivi che sono si accesi ma che non stanno consumando affatto (nel mio caso forno, microonde ecc).

Ho visto che la macro che “gestisce” lo spegnimento dei carichi ogni minuto è questa

            {%- macro dss_spegni_primo_carico() -%}
            {%- set entity_carico_da_spegnere = states.input_select.lista_carichi.attributes.options|join(',')-%}
            {%- for item in entity_carico_da_spegnere.split(',') if (states(item) != 'off' and (item != ''))-%}
            {{ item }}{% if not loop.last %},{% endif %}
            {%- endfor -%}
            {%- endmacro -%}  
            {{ dss_spegni_primo_carico().split(',') | first }}

Sapete darmi una mano per inserire una “condizione” che guardi anche al consumo del dispositivo oltre che al suo stato?

Mi rendo conto che forse dovrei perdere la comodità del friendly_name ma penso che ne valga la pena!

Ciao e grazie a tutti in anticipo

Ti ho già risposto nel nostro forum, dovresti accoppiare d ogni switch il valore del consumo. Per poterlo fare dovresti crearti uno switch template in grado di comandare lo switch originale e che conntenga anche il valore del consumo, una volta fatto questo va modificata la macro aggiungendo un ‘and’ dove dici che il consumo deve essere maggiore di 0, Purtroppo non è un lavoro da due minuti e non conoscendo le tue entity ed i tuoi sensori nessuno potrà mai aiutarti

Ciao scusa non volevo sembrare maleducato. Avevo bisogno di due imbeccate e finalmente adesso le ho. Certo sembra un bel po’ complesso. Proverò a fare qualche tentativo. Grazie mille dei consigli!

Buongiorno a tutti,
sto cercando di integrare homeassistant nella mia domotica basata su tcp/ip!
Attualmente sto percorrendo la strada di far delle chiamate al server con stringa HTTP:user:[email protected]:porta/ecc e per ora funziona!!
Lo stato e gli ampere vengono salvati nel db della domotica ogni tot secondi, la mia idea è quella di recuperare in qualche modo questi dati per poi renderli disponibili ad homeassistant!
Ho usato questo esempio per la configurazione dei relè/prese/luci

switch:

Ringrazio tutti per il supporto che mi darete…

Un buongiorno a tutti, mi trovo in difficoltà in merito all’aggiornamento di hassio da 102.3 a 103.4 in quanto “check home assistant configuration” ma da un log piuttosto negativo, in particolare in merito ad un sensore DHT22 (che all’atto pratico funziona egregiamente), e ad un modulo octoprint-netdisco che non capisco (anche Octoprint viene gestito egregiamente), ovvero:

[16:09:02] INFO: Checking your configuration against this version…
[16:21:24] ERROR: The configuration check did not pass!
[16:21:24] ERROR: See the output below for more details.
INFO:homeassistant.util.package:Attempting install of colorlog==4.0.2
Testing configuration at /tmp/config
INFO:homeassistant.util.package:Attempting install of aiohttp_cors==0.7.0
INFO:homeassistant.util.package:Attempting install of ha-ffmpeg==2.0
INFO:homeassistant.util.package:Attempting install of hbmqtt==0.9.5
INFO:homeassistant.util.package:Attempting install of paho-mqtt==1.5.0
INFO:homeassistant.util.package:Attempting install of pushbullet.py==0.11.0
INFO:homeassistant.util.package:Attempting install of home-assistant-frontend==20191204.1
INFO:homeassistant.util.package:Attempting install of hass-nabucasa==0.30
INFO:homeassistant.util.package:Attempting install of defusedxml==0.6.0
INFO:homeassistant.util.package:Attempting install of netdisco==2.6.0
INFO:homeassistant.util.package:Attempting install of distro==1.4.0
INFO:homeassistant.util.package:Attempting install of PyNaCl==1.3.0
INFO:homeassistant.util.package:Attempting install of HAP-python==2.6.0
INFO:homeassistant.util.package:Attempting install of sqlalchemy==1.3.11
INFO:homeassistant.util.package:Attempting install of RPi.GPIO==0.7.0
INFO:homeassistant.util.package:Attempting install of xmltodict==0.12.0
INFO:homeassistant.util.package:Attempting install of Adafruit-DHT==1.4.0
ERROR:homeassistant.util.package:Unable to install package Adafruit-DHT==1.4.0: ERROR: Command errored out with exit status 1:
command: /usr/local/bin/python -u -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-8yu7jlmu/Adafruit-DHT/setup.py’"’"’; file=’"’"’/tmp/pip-install-8yu7jlmu/Adafruit-DHT/setup.py’"’"’;f=getattr(tokenize, ‘"’"‘open’"’"’, open)(file);code=f.read().replace(’"’"’
‘"’"’, ‘"’"’
‘"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ bdist_wheel -d /tmp/pip-wheel-pcmyqryb --python-tag cp37
cwd: /tmp/pip-install-8yu7jlmu/Adafruit-DHT/
Complete output (21 lines):
running bdist_wheel
running build
running build_py
creating build
creating build/lib.linux-armv7l-3.7
creating build/lib.linux-armv7l-3.7/Adafruit_DHT
copying Adafruit_DHT/common.py -> build/lib.linux-armv7l-3.7/Adafruit_DHT
copying Adafruit_DHT/platform_detect.py -> build/lib.linux-armv7l-3.7/Adafruit_DHT
copying Adafruit_DHT/Beaglebone_Black.py -> build/lib.linux-armv7l-3.7/Adafruit_DHT
copying Adafruit_DHT/init.py -> build/lib.linux-armv7l-3.7/Adafruit_DHT
copying Adafruit_DHT/Test.py -> build/lib.linux-armv7l-3.7/Adafruit_DHT
copying Adafruit_DHT/Raspberry_Pi_2.py -> build/lib.linux-armv7l-3.7/Adafruit_DHT
copying Adafruit_DHT/Raspberry_Pi.py -> build/lib.linux-armv7l-3.7/Adafruit_DHT
running build_ext
building ‘Adafruit_DHT.Raspberry_Pi_2_Driver’ extension
creating build/temp.linux-armv7l-3.7
creating build/temp.linux-armv7l-3.7/source
creating build/temp.linux-armv7l-3.7/source/Raspberry_Pi_2
gcc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -DTHREAD_STACK_SIZE=0x100000 -fPIC -I/usr/local/include/python3.7m -c source/_Raspberry_Pi_2_Driver.c -o build/temp.linux-armv7l-3.7/source/_Raspberry_Pi_2_Driver.o -std=gnu99
unable to execute ‘gcc’: No such file or directory
error: command ‘gcc’ failed with exit status 1

ERROR: Failed building wheel for Adafruit-DHT
ERROR: Command errored out with exit status 1:
command: /usr/local/bin/python -u -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-8yu7jlmu/Adafruit-DHT/setup.py’"’"’; file=’"’"’/tmp/pip-install-8yu7jlmu/Adafruit-DHT/setup.py’"’"’;f=getattr(tokenize, ‘"’"‘open’"’"’, open)(file);code=f.read().replace(’"’"’
‘"’"’, ‘"’"’
‘"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ install --record /tmp/pip-record-1mco_59o/install-record.txt --single-version-externally-managed --compile
cwd: /tmp/pip-install-8yu7jlmu/Adafruit-DHT/
Complete output (11 lines):
running install
running build
running build_py
running build_ext
building ‘Adafruit_DHT.Raspberry_Pi_2_Driver’ extension
creating build/temp.linux-armv7l-3.7
creating build/temp.linux-armv7l-3.7/source
creating build/temp.linux-armv7l-3.7/source/Raspberry_Pi_2
gcc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -DTHREAD_STACK_SIZE=0x100000 -fPIC -I/usr/local/include/python3.7m -c source/_Raspberry_Pi_2_Driver.c -o build/temp.linux-armv7l-3.7/source/_Raspberry_Pi_2_Driver.o -std=gnu99
unable to execute ‘gcc’: No such file or directory
error: command ‘gcc’ failed with exit status 1
----------------------------------------
ERROR: Command errored out with exit status 1: /usr/local/bin/python -u -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-8yu7jlmu/Adafruit-DHT/setup.py’"’"’; file=’"’"’/tmp/pip-install-8yu7jlmu/Adafruit-DHT/setup.py’"’"’;f=getattr(tokenize, ‘"’"‘open’"’"’, open)(file);code=f.read().replace(’"’"’
‘"’"’, ‘"’"’
‘"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ install --record /tmp/pip-record-1mco_59o/install-record.txt --single-version-externally-managed --compile Check the logs for full command output.
WARNING: You are using pip version 19.2.2, however version 19.3.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.
INFO:homeassistant.util.package:Attempting install of psutil==5.6.7
INFO:homeassistant.util.package:Attempting install of mutagen==1.43.0
INFO:homeassistant.util.package:Attempting install of gTTS-token==1.1.3
Failed config
General Errors:
- Component error: octoprint - No module named ‘netdisco’
- Platform error sensor.dht - Requirements for dht not found: [‘Adafruit-DHT==1.4.0’].

Successful config (partial)

Un aiuto sarebbe ben apprezzato, grazie!

Ciao, giusto per la cronaca:

I miei grandi elettrodomestici sono monitorati da dei sonoff pow r2 che danno anche visione dei consumi.

Ho creato quindi dei template switch mqtt:

  - platform: mqtt
    name: "Asciugatrice"
    state_topic: "stat/SonoffP1/RESULT"  
    value_template: "{{ value_json.POWER }}"
    command_topic: "cmnd/SonoffP1/POWER"
    json_attributes_topic: "tele/SonoffP1/SENSOR"
    json_attributes_template: "{{ value_json['ENERGY'] | tojson }}"
    payload_on: "ON"
    payload_off: "OFF"
    availability_topic: "tele/SonoffP1/LWT"
    payload_available: "Online"
    payload_not_available: "Offline"
    qos: 1
    retain: false

così da avere uno switch con le info di consumo.

image

Ora devo solo modificare la macro!

Buongiorno a tutti e buon Natale.
Condivido con voi il nostro ultimo progetto.

Nuovo articolo!!:
Centro notifiche (AppDaemon notifier)

Dopo il package centro Notifiche realizzato dal nostro Admin Caio Sweet lo staff di Hassio Help ha deciso di realizzarne uno più completo e funzionale, che permettesse di tenere i messaggi audio da inviare in coda e che non presentasse i limiti del precedente. Grazie alle possibilità offerte dal linguaggio di programmazione Python, all’addon Appdaemon ed agli sforzi congiunti di Caio Sweet e di Gianpi, siamo lieti di presentarvi il nuovo centro notifiche.

2 Likes

Che bella notizia!

Mi metto subito all’opera per sostituire il vecchio centro notifiche

Ciao nico, il tuo sembra l’unico post in grado di risolvermi l’accesso ad Hassio. Ho un IP pubblico di Fastweb e non riesco ad accedere con https.
Ho già fatto tutta la procedura con DuckDNS e Letsencrypt ma nulla. Ho provato allora con solo Letsencrypt ma mi da errore nella configurazione dell’ Addon: “not a valid value for dictionary value @ data[‘options’]…”
Vedo che ci sei riuscito: puoi condividere la tua configurazione? in particolare, nel campo domain inserisci il numero dell’indirizzo IP?
grazie

Ciao Morris,
prova a seguire la procedure di installazione per il tuo hardware da qui: https://www.duckdns.org/install.jsp

La mia configurazione dell’addon di duckdns con supporto lets encrypt è questa:

{
  "lets_encrypt": {
    "accept_terms": true,
    "certfile": "fullchain.pem",
    "keyfile": "privkey.pem"
  },
  "token": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
  "domains": [
    "xxxxxxxxxxxxxx.duckdns.org"
  ],
  "seconds": 300
}

invece nel file di configurazione yaml ho questo:

`
http:
  base_url: https://xxxxxxxxxxxxxxx.duckdns.org:8123
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

controlla le virgolette
ciao

Ciao a tutti, sono nuovo di Home Assistant. Consigli su quale installazione effettuare?