Just Installed Mosquitto Broker, but can't start it

I’m looking to start working with MQTT so I installed the Mosquitto broker add-on. After clicking start the screen flashes (it tries to show the graphs for resource usage and the “start on boot” option turns off). I have not been able to get this stared even after multiple restarts and re installs. If I check the configuration tab it shows “This add-on does not expose configuration for you to mess with…” and if I check Log I have the following:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] mosquitto.sh: executing... 
[19:22:09] INFO: Certificates found: SSL is available
[cont-init.d] mosquitto.sh: exited 0.
[cont-init.d] nginx.sh: executing... 
[cont-init.d] nginx.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[19:22:09] INFO: Starting NGINX for authentication handling...
[19:22:10] INFO: Starting mosquitto MQTT broker...
1657844530: Warning: Mosquitto should not be run as root/administrator.
[19:22:11] INFO: Successfully send discovery information to Home Assistant.
[19:22:11] INFO: Successfully send service information to the Supervisor.

Current Setup:
Home Assistant 2022.7.4
Supervisor 2022.07.0
Operating System 8.2
Frontend 20220706.0

What options did you set in the configuration of the broker? What is in the acl.conf and accesscontrollist files?

Immediately after installing I can go into the configuration and see the default config. I don’t change anything and just click start. After that I’m not able see anything within the configuration tab anymore. except the message posted above.

As far as the acl.conf and accesscontrollist files, I’m not sure where these are located.

Have you read the docs? Its no wonder the broker wont start if you have not configured it

Hello David,

When following tutorials online the settings are not changed when starting the mqtt broker.
Hope you can help out, like what did you configure before starting ?

Create mqtt user and password in ha.
For mqtt config use mqtt for username and password you created for user mqtt.
I think everything else could stay as default.

I came across this thread having just updated an old thread of mine. My Mosquitto implementation has just failed after a Ubuntu upgrade due to a config change. I had to explicitly add the listener port into the config file.

After doing some research on this item I discoverd my issue could be something different.
: Add ons not working properly after snapshot restore - #13 by Protechtedd
because just before starting my working I used a backup file. so tried a few other add-ons and it seems all the addons would not start.

Same problem here. Install Mosquitto broker bit it does noet start.
Here is my log :

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
cont-init: info: running /etc/cont-init.d/mosquitto.sh
[10:31:45] INFO: SSL is not enabled
cont-init: info: /etc/cont-init.d/mosquitto.sh exited 0
cont-init: info: running /etc/cont-init.d/nginx.sh
cont-init: info: /etc/cont-init.d/nginx.sh exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun mosquitto (no readiness notification)
services-up: info: copying legacy longrun nginx (no readiness notification)
s6-rc: info: service legacy-services successfully started
[10:31:48] INFO: Starting NGINX for authentication handling...
[10:31:48] INFO: Starting mosquitto MQTT broker...
2023-01-25 10:31:48: Warning: Mosquitto should not be run as root/administrator.
[10:31:53] INFO: Successfully send discovery information to Home Assistant.
[10:31:54] INFO: Successfully send service information to the Supervisor.

Search the internet, looked at youtube examples but de broker does not want to start.

Please help.