KNX cover without position state address

Dear community

Short question about knx covers in HA.
A few of my covers only support the following knx features:

  • move_long_address
  • move_short_address
  • position_state_address (only 1bit open or closed)

The knx implementation in HA want’s a state address in 8bit (0-100% open/closed).

Is there a way to configure a cover that can only be opened / closed and stopped?

Thanks for help.

have you tried using the cover without position_state_address and setting “travelling_time_down” and _up ?

Any progress on this?

My installation has old covers which do not report any position. Actually, I don’t want HA to store any position information at all since any cached value gets incorrect as soon as somebody opens or closes covers using a KNX wall switch.

Try this (example):

cover:
  - platform: knx
    name: Kitchen.Shutter
    move_long_address: '3/0/0'
    move_short_address: '3/0/1'

Thanks for everyone’s suggestion.

I tried Joca‘s configuration, but was not successful (because there is no position state address, home assistant can‘t read the current state / position of the cover).

Right now, I‘m using following configuration:

- platform: knx
    name: "Terasse OG Storen kleine Terasse"
    move_long_address: '10/5/224'
    move_short_address: '10/5/223'
    position_state_address: '2/4/37'
    travelling_time_down: 15
    travelling_time_up: 15
    invert_position: true

But the state address still doesn’t really work, because home assistant expects an 8bit value, but my cover only supports 1bit state (up or down).

It would be really great if in a future release the knx integration allows using either a position_state_address or a state_address.

Hello,

same issue here. My cover as no position_state_address. My KNX cover is definded like this:

cover:
  - platform: knx
    name: "Arbeiten"
    move_short_address: '1/3/1'
    move_long_address: '1/3/2' 
    travelling_time_down: 12
    travelling_time_up: 12

The status after reboot is

current_position: 0

After reboot I try to send tho cover down. Directly from the service test page with cover.close_cover. But nothing happens.

If I manually move the cover up (down I cant press in the UI) I hear the actor clicking. Only after that move I can use the service successful.

Seems like a bug to me. Can anyone test this on his installation. Comment the position_state_addressout and try to send the cover down directly after reboot from the service web console. I would like to understand if this is a general issue or if I can do anything about it.

Current result is that covers dont work until once manually and only in the UI of HA are moved. Moving them on KNX is not helping. This makes automation for the blinds rathe useless atm.

Regards
Ralf

Same situation here - I would rather prefer that the down/up arrows gray option would be enabled if it’s too hard to change the KNX <-> HA mapping with 1-bit / 8-bit.

Actually the covers are unusable in this situation.

Hello there!

I’ve created a feature request, please vote it, so we can try to get something :slight_smile:

Where do I find the feature request to upvote?

Tnx. Voted.

Hello,

is there any update on this issue? WAF is significantly down bc blinds not working properly.

Regards
Ralf

I think that recently (less than 10 years) all knx shutter actuators has 1byte status position object.
Are your knx actuators old?

Yes. I started my journey 13 years ago. Not one device failed since then. I don’t want to replace them when this can be done with a few lines of code. I solved it for now. I only have now 0/100% states for position. Better than nothing. I also worked on an appdaemon class which takes care of monitoring position. Works like a charm. Still one piece missing. I continue to work on this topic.

Same for modern actuators running electronical controlled motors with soft-start/stop. Absolute Position is unreliable in this case.