KNX RGBW Problem

Dear Communitiy,

I have a stupid problem with the KNX integration. I’ve been trying to link my DALI RGBW controller for a few days now, but somehow it doesn’t work.

I have connected Dali rgbw controller to KNX via MDT Dali gateway. Everything works as expected directly via ETS. But something doesn’t seem to work with home assistant. If I change the color when the dimming value is less than 20%, the EVG somehow gets the signal to dim down to 1%. If I then try to dim it to 100%, it only comes up to a maximum of 20%. Only when I change the color again is the output back to 100% dimming value.

Hi!
Can you please add an ETS group monitor log and mark the rows so we know when you did your HA actions?

And add the yaml configuration of the light.

Hi Matthias,

yes no problem.

Light Config

    - name: "LED Labor"
      # switched light
      address: "7/0/1"
      state_address: "7/0/2"
      brightness_address: "7/0/3"
      brightness_state_address: "7/0/5"
      rgbw_address: "7/0/6"
      rgbw_state_address: "7/0/7"
      
    - name: "LED Labor CCT"
      # switched light
      address: "7/1/1"
      state_address: "7/1/2"
      brightness_address: "7/1/3"
      brightness_state_address: "7/1/5"
      individual_colors:
        red: 
            brightness_address: "7/1/10"
            brightness_state_address: "7/1/14"
        green: 
            brightness_address: "7/1/11"
            brightness_state_address: "7/1/15"
        blue: 
            brightness_address: "7/1/12"
            brightness_state_address: "7/1/16"
        white: 
            brightness_address: "7/1/13"
            brightness_state_address: "7/1/17"
            
            
      ```
  <Telegram Timestamp="2021-04-26T05:20:14.9978989Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01109380607008000003000000F" />
  <Telegram Timestamp="2021-04-26T05:20:16.4026143Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01102380707008000003000000F" />
  <Telegram Timestamp="2021-04-26T05:20:26.6060524Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01109380607008030000000000F" />
  <Telegram Timestamp="2021-04-26T05:20:27.7069106Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01102380707008030000000000F" />
  <Telegram Timestamp="2021-04-26T05:20:30.3282667Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01109380607008018300000000F" />
  <Telegram Timestamp="2021-04-26T05:20:31.5067326Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01102380707008018300000000F" />
  <Telegram Timestamp="2021-04-26T05:20:32.0677368Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01109380607008000301800000F" />
  <Telegram Timestamp="2021-04-26T05:20:33.1028312Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01102380707008000301800000F" />
  <Telegram Timestamp="2021-04-26T05:20:34.4678929Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE011093803020080FF" />
  <Telegram Timestamp="2021-04-26T05:20:34.7420652Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE011023805020080FF" />
  <Telegram Timestamp="2021-04-26T05:20:39.0966974Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE0110E3703010081" />
  <Telegram Timestamp="2021-04-26T05:20:39.8037524Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE011093806070080BF00FF00000F" />
  <Telegram Timestamp="2021-04-26T05:20:40.907964Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE011023807070080BF00FF00000F" />
  <Telegram Timestamp="2021-04-26T05:21:39.093779Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE0110E3703010081" />
  <Telegram Timestamp="2021-04-26T05:21:53.067631Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE0110938030200803B" />
  <Telegram Timestamp="2021-04-26T05:21:53.3417266Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE0110238050200803B" />
  <Telegram Timestamp="2021-04-26T05:21:56.0327533Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE0110938060700803A000000000F" />
  <Telegram Timestamp="2021-04-26T05:21:57.1037725Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE0110238070700803A000000000F" />
  <Telegram Timestamp="2021-04-26T05:22:00.3368448Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01109380607008000003A00000F" />
  <Telegram Timestamp="2021-04-26T05:22:01.50675Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE01102380707008000003A00000F" />
  <Telegram Timestamp="2021-04-26T05:22:03.2770001Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE011093803020080FF" />
  <Telegram Timestamp="2021-04-26T05:22:03.5418593Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE011023805020080FF" />
  <Telegram Timestamp="2021-04-26T05:22:09.187134Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE011093806070080FF000000000F" />
  <Telegram Timestamp="2021-04-26T05:22:10.2081954Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE011023807070080FF000000000F" />
  <Telegram Timestamp="2021-04-26T05:22:39.0901362Z" Service="L_Data.ind" FrameFormat="CommonEmi" RawData="2900BCE0110E3703010081" />

Ähm maybe screenshot your ETS. Raw CEMI frames are Hard to read ^^

Also no problem.

I can’t see any brightness < 20% in your telegrams.
Are there any differences between the telegrams that work (from ETS) and the telegrams from HA? Is a changed state sent correctly to HA?

Have you tried to omit brightness in your config (it is encoded in rgbw).

I hadn’t set the dimming value to exactly 20 or less. But the problem also exists with 23%.

I’m not exactly sure how I can compare that to.

I have now taken out the brightness value in the config.
But this only works with the config with individual_color
not with rgbw config. Did I make a mistake there?

    - name: "LED Labor"
      # switched light
      address: "7/0/1"
      state_address: "7/0/2"
     # brightness_address: "7/0/3"
     # brightness_state_address: "7/0/5"
      rgbw_address: "7/0/6"
      rgbw_state_address: "7/0/7"
      
    - name: "LED Labor CCT"
      # switched light
      address: "7/1/1"
      state_address: "7/1/2"
     # brightness_address: "7/1/3"
     # brightness_state_address: "7/1/5"
      individual_colors:
        red: 
            brightness_address: "7/1/10"
            brightness_state_address: "7/1/14"
        green: 
            brightness_address: "7/1/11"
            brightness_state_address: "7/1/15"
        blue: 
            brightness_address: "7/1/12"
            brightness_state_address: "7/1/16"
        white: 
            brightness_address: "7/1/13"
            brightness_state_address: "7/1/17"
          

I have never tried it myself (I don’t have any color lights). Does it fix the <20% problem?

I can’t see this for example. You dimmed to 100% and the Status was replied with 100%. Seems ok to me!?

yes the problem is solved with it. So with this config I could work if necessary.

But that’s not nice because all other KNX devices would also have to work with the config buttons or motion detectors. RGBW setting would be the best solution. Do you know why HSVW is not supported as setting

As you can see in the logs, I dimmed to 100% in HA. That fit so far too. HA 100% ETS 100% but the real output on the controller was only 20%

On HA side or KNX side (is there a DPT for that?)?

Then I guess it’s a problem in the controller or its configuration. When it doesn’t react properly to knx telegrams there is nothing we can do about it.
It reports its status 100% but is actually outputting 20% ?! I’d get in touch with the manufacturer.

No, no configuration for HSV or HSVW control is listed on the HA KNX page. Only RGBW as combined object DPT 251.600 or individual colors. My KNX Dali gateway from MDT supports the following variants:

  • XY color DPT 242.600

  • RGBW combined object 251.600

  • RGBW separate objects

  • HSVW separate objects

I think there could be a problem with the translated entries in the front to the KNX Hex value for RGBW DPT 251.600.

Can I somehow see what HA generates as HEX and sends to the KNX bus?

I think you are right after all. I have now been able to reproduce the problem in ETS. Now I just have to find out whether it is the controller or the gateway

Has it to be one of them or are multiple possible. If multiple are possible side by side I see no real reason to add support for HSV or XY (especially when it’s not a separate DPT but proprietary) - RGBW should cover all needs, doesn’t it?
But if you like, PRs are always welcome. GitHub - XKNX/xknx: XKNX - A KNX library written in Python

Sure, just look at ETS group monitor or xknx log in HA.

There are some functionalities missing in the HA knx integration for RGBW that are there for RGB. I can add these, but can not test. Could you help?

Unfortunately you can only have one variant running in the gateway, either RGBW or HSVW. Both do not work at the same time. Unfortunately, the problem here is that my glass pushbuttons only support HSV to control RGBW. As it is now, I would have to decide whether I want to control the stripes via HA (RGBW) or via glass buttons (HSVW).

Yes, I can support you with testing.

Give it a try! Add color modes to KNX light by farmio · Pull Request #49883 · home-assistant/core · GitHub

1 Like

Can you help me with that. How do I get the new code in HA

Hi there,

I am following this discussion with great interest, since I run into similar issues with the MDT DALI gateways and addressing my Kiteo Spot 12-F. In fact, these lights are natively operating by XY coordinates, so being able to get HA and xknx library to speak DPT242.600 would be absolutely amazing.

I can support with testing.

Best regards.

I’ve created an issue Light: Color modes · Issue #698 · XKNX/xknx · GitHub for it.

Just out of interest: Can someone explain to me the benefits of these different ways to select a color?
I still think it would be the Controllers job to accept all of them and convert appropriately, but this is nothing we can change :confused: Maybe it’s just to generate vendor lock-in inside an open system (knx).

It’s not that easy to explain.
The problem is that we use DALI here and there are many different devices from different vendors. In the DALI DT8 standard, there are mainly 3 ways to control RGB color. XY coordinates, RGB (W) and HSV (W). But you can’t use all of them at the same time, you have to choose one mode. In my case, I have 3 devices in the chain. 1. KNX button 2. DALI gateway 3. DALI driver and all must run in the same mode, so either RGBW, XY, or HSVW.
The problem is, however, that every vendors has a different philosophy and has a different opinion about which mode is the better. Although they support all modes, they recommend a special mode. It is reasonable to assume that the development of the firmware only focuses on one mode and that other modes are only by-products and are not perfectly programmed.

In my case. KNX buttons and KNX gateway are from MDT and they recommend HSV. LED DALI driver is from MiBoxer and they recommend XY coordinates.

Long talk makes no sense

If you provide us with HSV and XY as modes in HA, we have the opportunity to find out which mode works best in a device chain.

1 Like