KNX Secure Connection

Hi all,
I have a problem with KNX connection that I cannot configure with IP Secure. I have this version of HA 2022.3.7, by chance is there someone that is using this type of connection? If so, how did you configure it?
Thanks a lot in advance for your feedback!

Hi :wave:!
Knx IP Secure Support was added in 2022.4. update to the latest version.

I’ve just updated it, so now I have the last version. But how can I set the user and password for manual configuration?
Thanks a lot!

See KNX - Home Assistant

You’ll have to delete the KNX integration and add it again from the integrations page.

Perfect, now I can set the user and password! But I need to check ETS configuration, about user and password, probably I need to set something with ETS… so I’ll update you asap.
Just another question: when I create the configuration I cannot set the fisical IP address, and when I click “configure” I see this this IP “15.15.250” that is wrong, can I update it or is it not necessary?

KNX individual address is not needed for Tunnelling connections.

Thanks a lot!
So I’ll work to change/check ETS configuration and I’ll let you know.
Thanks again!

Sure, please let me know, you may be the first user of Knx Secure in production :partying_face:

Hi Matthias,
this weekend I worked to configure ETS, and I confirm that it works correctly! So thanks a lot for your support! :slight_smile: It’s a very good solution, thanks who implemented it!

1 Like

:+1: Glad to hear! You’re welcome :wink:

@curgio Hey :wave:! We just discovered a bug where 1 byte payloads (eg. percent) were handled incorrectly when using secure - thus rendered these unusable.
You might want to update to 2022.5 when it is available (tonight) where this is fixed.

Hi everyone,

can you give a hint, why the TCP with secure option may not be available in the tunneling settings?
Here is a screenshot from my fresh setup on a raspberry pi:
I am using Home Assistant Core 2022.6.6.

Is there any way to configure the connection settings manually in the configuration file?

Hi :wave:!
Secure currently has to be configured initially on integration setup - it can’t be configured afterwards in the options.
Just delete the KNX integration from the menu and add it again - the flow will allow you to configure secure then.

Thanks for your fast reply!
Unfortunately, going this way I have even less options:

Then your KNX interface doesn’t support KNXnet Core V2 and thus no TCP connections (and no secure connections). (In the options menu this is just not checked.)

What device is it?

I am using a MDT SCN-IP000.03 IP interface.

Oh dear… unfortunately MTD doesn’t seem to take the specifications too seriously.
Try updating its firmware.
There is also a bug with the newest firmware (at least for the router) with exporting the key file. Id recommend configuring the user and password manually.

Thanks for the hint. I will try to update the firmware and come back to you afterwards.

1 Like

I have now updated the IP interface to version 3.0.6.
The image is still the same, only UDP and UDP with NAT are suggested.

Do you have any suggestions, how I could debug this any further?
If it won’t work, I can always switch over to non-secure tunnels.

Configure debug logging for xknx and send me the logs from when you (re-)add the KNX integration.

What HA installation method do you use? Are the HA device and the KNX interface in the same network?

Next step to debug would then be to do a packet capture (eg. Wireshark) while adding the KNX integration.

You may contact me on Discord at HAs or xknx Server: farmio#5918