Kwikset 910 Hassio

I have a house with 2 kwikset 910 door locks. They were previously paired to a vivint system, but I was able to exclude them from that system, and I have been able to pair and control them with a SmartThings hub as proof that the locks work and are not still tied to the Vivint system.

I can pair them to HA using my USB z-wave controller: amazon.com/dp/B01GJ826F8
However, when I have them paired to HA, they do not respond to any command - lock, unlock do nothing. When I press lock or unlock in HA, I do get a flashing light next to the “button A” which is used to pair and exclude the lock, but no motion on the actual lock.

The locks also do not properly report the current state - they just always say unlocked.

Any help is appreciated as I’ve been trying to get these to work for nearly 2 days and am about to give up and just go back to SmartThings.

Log snippet when I send a command:

2019-07-11 17:57:54.261 Info, Node013, Sending (Send) message (Callback ID=0x2b, Expected Reply=0x04) - DoorLockCmd_Get (Node=13): 0x01, 0x09, 0x00, 0x13, 0x0d, 0x02, 0x62, 0x02, 0x25, 0x2b, 0x84
2019-07-11 17:57:54.267 Detail, Node013,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2019-07-11 17:57:54.267 Detail, Node013,   ZW_SEND_DATA delivered to Z-Wave stack
2019-07-11 17:57:55.539 Detail, Node013,   Received: 0x01, 0x05, 0x00, 0x13, 0x2b, 0x00, 0xc2
2019-07-11 17:57:55.539 Detail, Node013,   ZW_SEND_DATA Request with callback ID 0x2b received (expected 0x2b)
2019-07-11 17:57:55.539 Info, Node013, Request RTT 1277 Average Request RTT 1854
2019-07-11 17:57:55.539 Detail,   Expected callbackId was received
2019-07-11 17:58:04.262 Error, Node013, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-07-11 17:58:04.263 Detail, Node013, Removing current message
2019-07-11 17:58:04.263 Detail, Node013, Notification: Notification - TimeOut

Edit:
I did pair the locks using “ADD NODE SECURE”
And here is my config with the network_key:

zwave:
  usb_path: /dev/ttyUSB0
  network_key: "0x01, ...0x10"

Unpair them and pair them using Add Secure Node.

1 Like

Have same lock.
Works without issue, just add secure.

I forgot to mention, but I did pair them using add node secure. And I do have a network key in the config. Also edited the original post to reflect this.

I also did move them within 12 inches of the controller during the pairing process. They were much closer to the HA controller than they were to the (working) SmartThings controller.

Someone in the discord responded:

it’s possible the network key isn’t actually being read from the configuration if you just had a usb_path defined in configuration.yaml and added the network_key later
try going to configuration -> integrations -> z-wave and click the trashcan icon in the top right corner
then restart HA
may need to unpair/repair the lock after that

I did that and afterwards the first lock worked. Working on the second lock now, but wanted to post this here in case anyone else comes across the same problem.

Thanks for writing your solution, i am having identical symptoms, will try this when I get home.

Hope it works for you! I had assumed that when I push the trash icon it would remove all of my Z-wave integrations, but they all reappeared after restarting ha, so it’s not a destructive process.

It worked for me as well. However there is a side affect from trashing the zwave integration. I lost all of my custom names for my zwave devices, so all of my node red automations stopped working until i rename them all the same as before. Always 2 steps forward 1 step back with this stuff…

New HA user here. I have three of these locks and am running into the same problem. I’ve been able to include all my non-secure devices, but not these. I’ve tried the solutions mentioned here, plus the solutions mentioned on other threads. These include deleting the node and re-pairing, deleting the Z-Wave integration and re-installing, performing a factory reset on the lock per its instructions, then trying to include it; I’ve even tried reformatting the SD card, reinstalling Hassio, and starting everything from scratch. No matter what, my logs give the same error mentioned above. I’ve used the add secure function each time.
The locks were paired with a Vivint controller. I cancelled the contract, but since Vivint doesn’t allow users to include or exclude devices without a phone call to support, I didn’t exclude them before Vivint went away. I’m using an Aeotec Z-Stick, and I used the exclude function on it before I tried to include the locks to HA.
Could this be the locks’ anti-theft feature? I would really appreciate any help.

It’s possible the lock’s anti-theft could have been active on your locks, though mine were also from a Vivint install, and did not have the anti-theft system activated. I would give it another try. Make sure you have the lock within 12 inches of the Aeotec Z-Stick when you’re doing this. I tried a few times with the lock on the door, but it did not work. I had to remove it and move it closer to the stick.

Make sure you have the network key in your configuration for the secure pairing. Should look something like

zwave:
  usb_path: /dev/ttyUSB0
  network_key: "0x01, ...0x10"

When you have the lock close (something less than 12 inches) to your z-wave stick, activate the exclude method on HA and press the button on the lock.
After you confirm it is unpaired, try pairing secure again.

If all else fails, I did temporarily activate a Vivint subscription just so I could call them and unpair the locks. It turned out this was totally unnecessary in my case, since I had already successfully unpaired them - I just didn’t know it yet. But it is possible in your case the anti-theft thing was activated, in which case you may need to actually pair them back to the Vivint controller and then unpair them properly to get around the anti-theft bit.

Hi, total noob here. Running brand new HA install on Ubuntu 20.04 64bit server, 8GB RP4. Z-wave hardware is the Aeotech Z-Stick Gen5, attached through an unpowered USB2 hub. Hopefully that’s not a red flag right away. AFAIK from OZW_Log.txt, the stick is powering up fine.

I’ve already troubleshot several other problems leading up to pairing, like running OpenZWave while trying to pair (giving me problems with accessing /dev/ttyACM0), and the system / stick is sitting on a stool right next to my Kwickset 909 (installed in the door). The former Vivint system is powered down (the head unit - I assumed that’s where its Z-wave controller lives?). The 909 has been factory reset (battery out; hold Program while inserting battery, hold for 30 sec, release, press again). It could not be unpaired from the former Vivint system due to issues noted above already (I hate Vivint). My config in configuration.yaml is as has been shown above, with my own (self-generated) network key.

OK. So, Configuration->Z-Wave Network Management->Add Node Secure.
The controller replies ADD_NODE_STATUS_LEARN_READY in the logfile.
I hit the LEFT upper button on the Kwikset (OMG I hope this is not the problem… I’ve read different ways to get this baby to want to pair and tried both)…
And nothing happens. The controller just waits.

I bet I just have no clue how to set the lock into pairing mode. Hopefully not. Maybe the lock is just crap. Anyway, thanks for any tips…

I got it to work. I’m continuing my journey here. Thanks for the advice on this page, it helped.

Just went through this, so I’m posting in case anyone else comes along. I just bought a house with Vivint pre-existing. Two kwikset locks. Same experience as OP, I could add them to Home Assistant, but the locks would not respond to commands. Tried to uninstall from the Vivint panel, but the 2203 code wouldn’t work. Vivint had me locked out. Just yesterday, I called to see if they would unlock the panel, and of course, they wouldn’t. So, I started a two-week free trial. They unlocked the panel. I had to un-pair the lock with the vivint panel and then re-pair the lock. The re-pair failed at first, but worked the second time. It also asked me if I wanted to enable anti-theft on the device. I selected not to. I then unpaired the lock from the vivint panel again, and did the add node secure from Home Assistant. The lock now responds properly with HA.

I had the same issue when trying to add my kwikset 916 dead bolt; it would let me add it however would not let me control it. As many did, I added my z-wave network key to the config file after my initial z-wave set up. However, I found a much better option then manually entering.

If you have already set up your z-wave network and have added zwave: code to the configuration file follow these steps to fix your secure devices:

Step 1: Remove your secure devices from the z-wave network by selecting the node and clicking “remove node” (Follow each devices remove from network instructions).

Step 2: After you have removed the devices from your network. Remove the z-wave code you manually added to any configuration/option file.

Step 3: Go to Configuration>Integrations> Delete the Z-Wave Integration
(Note: This will not remove your existing devices since they are stored on your Z-Wave Stick. However, if you have created custom names for devices you may have to rename them again after.)

Step 4: Go to Supervisor>System>Reboot

Step 5: Create a network key
(There are many ways to generate one however I just changed some of the characters of this example one I found)
0x67, 0x8b, 0x93, 0x5d, 0x84, 0x8b, 0x58, 0x31, 0x06, 0x08, 0xe9, 0xf7, 0xaa, 0x60, 0x9d, 0x5e
(Note: There should not be a z-wave integration after reboot, also your configuration files should be z-wave free at this point)

Step 6: Go to Configuration>Integration>Click “Add Integration”>Add Z-Wave>A dialog box will pop up with 2 text boxes, Path & Network Key

Step 7: For Path Enter: /dev/ttyACM0 For Network Key Enter your network key without parentheses
Example: 0x67, 0x8b, 0x93, 0x5d, 0x84, 0x8b, 0x58, 0x31, 0x06, 0x08, 0xe9, 0xf7, 0xaa, 0x60, 0x9d, 0x5e

Step 8: Start the Z-Wave network and add your secure devices that you removed using Add Node Secure.

Hope this Helps!

Any suggestions on how to do this on z-wave JS

I have the same Kwikset 910 lock and its doing the same as above.
(only giving me two Entites and they don’t seem to work)

when I added the device I selected Advanced and Secure if possible

Thanks
noob

Add the lock via Home Assistant, it’ll auto handle adding it securely.

I am adding via z-wave JS (configure)

im just not sure where to go from here, nothing seems to work once connected (seems to be doing like everyone else when its not being added securely)

mains
Kwikset Smart Code with Home Connect Technology 910 None Yes 3.37 No Alive
Complete
11/1/2021, 8:36:14 PM

2021-11-01 21:37:01.824 INFO ZWAVE: Node 26: added with security LOW SECURITY
2021-11-01 21:37:01.885 INFO ZWAVE: Node 26: interview stage PROTOCOLINFO completed
2021-11-01 21:37:02.051 INFO ZWAVE: Node 26: interview stage NODEINFO completed
2021-11-01 21:37:02.224 INFO ZWAVE: Node 26: value added: 114-0-manufacturerId => 144
2021-11-01 21:37:02.233 INFO ZWAVE: Node 26: value added: 114-0-productType => 1
2021-11-01 21:37:02.235 INFO ZWAVE: Node 26: value added: 114-0-productId => 1
2021-11-01 21:37:02.565 INFO ZWAVE: Node 26: value added: 134-0-libraryType => 6
2021-11-01 21:37:02.570 INFO ZWAVE: Node 26: value added: 134-0-protocolVersion => 3.67
2021-11-01 21:37:02.572 INFO ZWAVE: Node 26: value added: 134-0-firmwareVersions => 3.37

Double check the addon’s config to make sure all the security keys populated.

Thanks, firstof9,
i believe you are on to something (none of my devices connected securely)
no even my S2 Zooz ZST10 USB stick.

keys look good to my limited knowledge,
i believe it generated these keys when I installed it
(I truncated the keys for security sake)

device: >-
/dev/serial/by-id/usb-Silicon_Labs_CP2102N_USB_to_UART_Bridge_Controller_c077019b87bcea118f0096e368aed703-if00-port0
s0_legacy_key: 3C612FDD297FDED22FA680263F*
s2_access_control_key: 85A1FA44A497A2BE66B64057*
s2_authenticated_key: 8272A3A3C3CC783383166CA9C*
s2_unauthenticated_key: 50134D45EAF7C2CCCF8319*
log_level: info
network_key: 3C612FDD297FDED22FA68026*

The sticks never show security, don’t worry about that one.

Looks like you have keys setup that’s good, likely you’ll need to bring the brains part of the lock close to the stick to pair it securely, once that’s completed it should show secure, then you can mount it back onto the door.