Kwikset 910 Hassio

Tags: #<Tag:0x00007f7c5cecfa10> #<Tag:0x00007f7c5cecf948>

I have a house with 2 kwikset 910 door locks. They were previously paired to a vivint system, but I was able to exclude them from that system, and I have been able to pair and control them with a SmartThings hub as proof that the locks work and are not still tied to the Vivint system.

I can pair them to HA using my USB z-wave controller:
However, when I have them paired to HA, they do not respond to any command - lock, unlock do nothing. When I press lock or unlock in HA, I do get a flashing light next to the “button A” which is used to pair and exclude the lock, but no motion on the actual lock.

The locks also do not properly report the current state - they just always say unlocked.

Any help is appreciated as I’ve been trying to get these to work for nearly 2 days and am about to give up and just go back to SmartThings.

Log snippet when I send a command:

2019-07-11 17:57:54.261 Info, Node013, Sending (Send) message (Callback ID=0x2b, Expected Reply=0x04) - DoorLockCmd_Get (Node=13): 0x01, 0x09, 0x00, 0x13, 0x0d, 0x02, 0x62, 0x02, 0x25, 0x2b, 0x84
2019-07-11 17:57:54.267 Detail, Node013,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2019-07-11 17:57:54.267 Detail, Node013,   ZW_SEND_DATA delivered to Z-Wave stack
2019-07-11 17:57:55.539 Detail, Node013,   Received: 0x01, 0x05, 0x00, 0x13, 0x2b, 0x00, 0xc2
2019-07-11 17:57:55.539 Detail, Node013,   ZW_SEND_DATA Request with callback ID 0x2b received (expected 0x2b)
2019-07-11 17:57:55.539 Info, Node013, Request RTT 1277 Average Request RTT 1854
2019-07-11 17:57:55.539 Detail,   Expected callbackId was received
2019-07-11 17:58:04.262 Error, Node013, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-07-11 17:58:04.263 Detail, Node013, Removing current message
2019-07-11 17:58:04.263 Detail, Node013, Notification: Notification - TimeOut

I did pair the locks using “ADD NODE SECURE”
And here is my config with the network_key:

  usb_path: /dev/ttyUSB0
  network_key: "0x01, ...0x10"

Unpair them and pair them using Add Secure Node.

1 Like

Have same lock.
Works without issue, just add secure.

I forgot to mention, but I did pair them using add node secure. And I do have a network key in the config. Also edited the original post to reflect this.

I also did move them within 12 inches of the controller during the pairing process. They were much closer to the HA controller than they were to the (working) SmartThings controller.

Someone in the discord responded:

it’s possible the network key isn’t actually being read from the configuration if you just had a usb_path defined in configuration.yaml and added the network_key later
try going to configuration -> integrations -> z-wave and click the trashcan icon in the top right corner
then restart HA
may need to unpair/repair the lock after that

I did that and afterwards the first lock worked. Working on the second lock now, but wanted to post this here in case anyone else comes across the same problem.

Thanks for writing your solution, i am having identical symptoms, will try this when I get home.

Hope it works for you! I had assumed that when I push the trash icon it would remove all of my Z-wave integrations, but they all reappeared after restarting ha, so it’s not a destructive process.

It worked for me as well. However there is a side affect from trashing the zwave integration. I lost all of my custom names for my zwave devices, so all of my node red automations stopped working until i rename them all the same as before. Always 2 steps forward 1 step back with this stuff…