Life360 Officially Supported Integration

This custom version of the life360 integration is quite old, and I stopped maintaining it when it was clear that Life360 was actively blocking unauthorized usage of their API.

I just gave it a try, yet again, to see if it would work, but like the last time it was reported that it was working again, it didn’t work for me. In addition to getting errors from the server, there are changes in HA’s core code base that also break this custom integration so that it won’t work with fairly new HA versions.

I’m pretty busy on other stuff right now, but I might spend some time on seeing if it can work again, and if so, I’ll try to bring it up to date. No promises.

Alternatively, anyone is welcome to try to get the built-in integration working again.

1 Like

Just to add. The custom fork recently shared in this thread “works” — data is received initially, but it appears theres an issue with the coordinator, so locations dont seem to update.

Same issue as shared earlier by @obrien.craig

I think its potentially an easy fix, I just dont have the time atm to look into it in any level of detail.

I did try to quickly fix the issues due to the changes in the core code base so I could try and see if it would work, but the changes were not easy to work around while maintaining compatibility with older HA versions, which I always try to do. Still, I was getting “too many requests” errors from the server, so it didn’t look good. Not sure why some don’t see those errors, but again, it’s the nature of the problem. I.e., their attempts to block unauthorized usage aren’t foolproof, but they are effective enough to make working on this again less than promising.

UPDATE: I tried the life360 package by itself, and it does seem to work. I’ll have to try and find some time to update the custom integration. It may “work” with the current HA release, but I’m almost positive it won’t with the next one (2024.4), since it doesn’t work with the dev branch.

But, even if I get those issues resolved, there’s no telling if/when Life360 might lock us out again.

UPDATE: I now have a version of my custom integration that basically works. It’s not complete, and I’m not even ready to release a beta, but this is potentially good news.

8 Likes

If anyone would like to try it, the custom integration is available in this repo:

https://github.com/pnbruckner/ha-life360

Beta version 0.5.0b5 is the latest. Documentation can be found here:

ha-life360/README.md at new-api · pnbruckner/ha-life360 (github.com)

7 Likes

@pnbruckner thanks for picking this up again, just installed 0.5.0b7. So far the installation did go flawless and all four devices in my life360 account are added. So far so good!!! :orange_heart: … will monitor and report in case any issues pop up.

Thanks again!!! :pray:

1 Like

Thanks a lot buddy, this is much needed.

1 Like

Well well. I had lost all hope in Life360 and transitioned to Google Maps Location tracking, but recently had ‘issues’ with this. Couldn’t figure out why. Never could get it working correctly on my account again
So, came back to this thread. What a turnaround!!
@pnbruckner persistence pays off. This integration works perfectly. Thanks so much for your continued support on this.

Glad you were able to use it again.

On the Google Maps front, what kind of issues were you having? Were you using the built-in integration, or my custom version?

I tried both. Your Custom integration works, but I have a strange feeling its a strange hidden Google configuration relating to my account only (I can track my wife, but cant track me for some strange reason). I just didn’t see any entities relating to me
I tried multiple reboots after cleansing all files of configurations, it always ended up with the same results.

Thanks for the work you put in Phil.
I just installed the latest beta 0.5.3b0. When I tried to add the integration I got the following message: Fout: Config-flow kon niet geladen worden: {“message”:“Invalid handler specified”}. This is in dutch but I think/hope it is pretty universal. Do you have an idea of what went wrong for me or what mistake I possibly made?

Hi @pnbruckner,

thank you very much for this new mod extension!

I had disabled the original one because it was not working anymore and I am glad to see such an advancement here. :slight_smile:

I have an issue though: I have successfully installed the version 0.5.2 and configured it using the token, but the circles cannot be downloaded.

I always get the error message:

Could not retrieve full Circles & Members list from server; will retry

followed by the message:

Circles & Members list retrieval cancelled

I tried to restart HA, to reload the extension, to wait for a couple of hours, but the result is always the same: no circles are downloaded. Any idea where the problem could be?
Thanks!

Yes, Life360 and/or Cloudflare have found new ways to break the integration. I have a beta available that might help (0.5.3b2). It seems to work for some, but not for others. I myself run two instances of HA (production & test), both running this beta, and both using the same Life360 account info. The test system works flawlessly, but the production system won’t work. Constant error 403 from the server.

I’m pretty much stumped, again. I found a way to work around the problems the last time it broke (with an almost complete rewrite), but no such luck this time. I think I’m done trying, again.

Thank you for the prompt feedback @pnbruckner!
I will give a try to the beta version. Let’s see if in my system will work.
It’s a pity anyway. Still do not understand why they are so strict on dev. APIs.