Linkind zigbee alarm starter pack

The siren is built into the Hub.

Here is how you can hack the Hub to have access the underlying OpenWRT.

I haven’t figured out how the siren can be triggered from the OpenWRT.

So you could hack the siren and use it in HA ?

@Twinsen68, Someone just asked the same on the github discussion, but unfortunately not. I haven’t had too much time to tinker with it since.

Hi all, did you solved the issues with the keypad? On the Z2M web site is reported that It is supporter. Do you know if it works well?

There is an issue open in Z2M that the keypad disconnects from the network after a while when connected directly to the coordinator, but otherwise it works well.

Have a look here:

1 Like



Thanks for the information :slight_smile:
I’m not sure if I understood well, I got there is an issue open in Z2M but I didn’t understood if the blue print you suggested to me solve this problem

This is the issue:

The Blueprint works.

If the Blueprint would solve it then there wouldn’t be an issue. :laughing:

But seriously, if the keypad is connected to a repeater, but not directly to the coordinator then there seems to be no issues.

1 Like

Got It :grinning_face_with_smiling_eyes:but is there a way to force the keypad to be connected to a repeater and not to a coordinator?

In Z2M there is a way, but I am not sure about ZHA or DeConz.

1 Like

Perfect, I have the conbee2 but I’m using z2m. :grinning_face_with_smiling_eyes: Do you have a link to the documentation to set the use of coordinator and repeater?

All what I know as documentation.

But I am talking about the option what you see when you open the drop down in the UI.

Screenshot_20220531-221330_Home Assistant

Select any of the repeaters in the list and then press Permit to join.

Like this:

The devices paired will join the network through that repeater.

1 Like

Thanks to your suggestions the keypad is perfectly integrated in my alarm system :grinning_face_with_smiling_eyes:
Now I would like to reuse the hub siren, I was thinking to modify the hub in order to activate the siren through an esp32.
I saw the images where you disassemble the hub and I’ve a couple of questions.
Once removed the zigbee module are available contact through which I could activate/command the siren?
If Yes do you have an image to show It to me?
How could I disassemble the siren without destroy the case?

If you have never updated the Hub, I mean you have never connected it to Linkind services, then scroll down to the bottom of the discussion.

Someone managed to get the default password for the stock OpenWRT.

Someone else managed to trigger the siren through one of the built in services.

@Elle, I will be unable to give hands on help with this, because I don’t have the Hub in hand for a while. But if you haven’t updated the firmware of the Hub, then you should be able to log in to the OpenWRT with the password listed in the opening post of that discussion. If you have updated the firmware of the Hub, then you will need to contact one of the guys in the discussion, that how was managed to enable dropbear to access again the OpenWRT.
I am unsure that the uBoot has been locked or not, that could have been some other communication issue.
For triggering the siren, you can try first the command listed in the discussion’s end somewhere, and you can build some automation to run commands on the device from HA, so anything is possible.

1 Like

I never turned on the hub, I bought the kit just for the keypad :sweat_smile:.
I will try to follow the discussion :grinning_face_with_smiling_eyes:
Really thanks for your help.

1 Like

Then you should be good. Plug in the Hub, connect to the Wifi network what it creates. (I use a mobile phone most of the time.) Use Fing (app) to check the devices on the Wifi network. Check what ports the device has open, if 80 is open, then navigate to the IP address of the device and use root as username, and the password mentioned in the discussion. To connect to your own Wifi network, just set it up with the OpenWRT what is on it.

Personally I disabled the Linkind services on the Hub to do not “call to home”.

Good luck! Please report back how you proceed. Especially with the default password, as I never tried that.

1 Like

Hi, I’ve been able to connect to the Siren and command it! but I did not understand how I can deactivate the linkind services and make the siren work with my home wifi. could you help me?
attached the image of what I can see once connected to the siren.

Sorry for the late reply. I cannot really help with the full answer, because I don’t have access at the moment to the Hub to guide you through.

You should find the menu, where it lists the installed and running services. You need to disable the Linkind ones. Unfortunately, as I don’t have access to the Hub, I cannot give a full list.

But these are as I can read from this Github repo:

  • device
  • eagent
  • lagent
  • lds-keyring
  • ota
  • security
  • smart
  • subdevice
  • zipgateway
  • zware

To join your Wifi network, you need to bring up the Wifi settings, turn on the Wifi connection and connect the device to your local Wifi network, save the settings and then disable the Linkind AP.

Here is a generic OpenWRT instruction how to connect to Wifi networks:

Once you connected it to your Wifi network, check connection to other device with ping, etc. Then disable the AP. Save settings and then restart a few times. If you did it correctly all 3 LED lights should be green and you should be able to access the Hub from your network, and the AP will not be active anymore.
If the Wifi fails to work, then just power cycle, if it is still not working after, then reset the Hub and do it again. I struggled a bit until I managed to connect it to the my Wifi.

Thanks for your suggestions :slight_smile:
I’ve been able to find the list of services (going to the web interface, cliccking on system and selecting startup) and disabled the Linkind services (I hope so, but in any case at least the otap one is for sure disabled) then I tried to connect to my home network but I’m unable to do it, in the menu wifi I didn’t find the network and when I click on scan it give me back a blank page.
Do you know what I’m doing wrong in trying to connect the siren to my home wifi?

Edit the Client (Leedarson) add there your WiFi setting.

As I can remember the Hub can connect only to 2.4GHz WiFi networks. So if your Home WiFi is 5GHz one only, then you will have no luck.

1 Like