Lost Z-Wave and have errors about ZWave JS

I have times where I can spend a good amount of time on my home automation setup, then I have months where I can’t do much of anything. So after months of everything working fine, a Z-Wave switch of mine, an Aeotec Wallmote Quad suddenly stopped working and I couldn’t turn a light on. I went to the switch, which is connected to an Insteon dimmer (I think a Micro-Dimmer? Model #2442-222 ). I’ve never had trouble with either device before and I have never had a time when I turned a physical switch on or off and the Insteon switch connected to it didn’t respond, but this time nothing happened. I turned the switch on and off with no response.

And that’s when I check my HA app on my phone and realize I need to do 5 updates - Mosquito, ZWave2JS, Core, Remote, and OS. I’m also seeing a reported error with Z-Wave, but I didn’t look closely, since I figured updates might fix it. I do the updates and restart. The physical switch works. I can use my phone and control the light (the Insteon switch also lets me dim the light) and dim it, too. So the Insteon Micro-Dimmer is working fine. The Aeotec WallMote Quad, which is a Z-Wave device, is apparently not working. I checked and it’s charged. Then I check other Z-Wave switches. I can’t control them from my phone. The control panel doesn’t even let me turn the switch on or off - the control is ghosted.

I went to my desktop computer for troubleshooting.

When I go to Z-Wave, I see this:

So I go to CONFIGURE and get this:

Since it’s citing Z-Wave JS, I go there on the sidebar and find it’s not on, so I try to start it and get “Error starting the add-on.” I clicked Logs and I get an empty log with just a REFRESH link/button to click and when I do, I still don’t get any log entries.

Where can I start troubleshooting this - or does anyone know what’s going on here?

I had a similar problem yesterday, even after updating to the latest version 2.01 of zwave-js ui. Turns out after all the updates were complete, the USB port had changed on my stick and the configuration needed to be updated to point to the new ttyUSB port. Worth a peek.

SInce this problem started before I updated, but the symptoms seem to be the same after the update, I’m not sure it was the update. Of course, if something went bad before the update, and didn’t need much, the update could have made it worse.

As @smithkt suggested, I’m going to check the USB port location, but I won’t have time to do that until late tonight.

Okay, feeling like an idiot here. I have done all this before, but when I’m going through my settings and so on, I cannot remember or find:

  1. How do I find the proper node in /dev for my USB Z-Wave device?
  2. When I go to the Z-Wave JS page (from the side panel), and pick Configuration, there is nothing that lets me set the location of my USB device. Where do I go to change that? Is that under Z-Wave instead of ZWave JS?

Have you powered off the computer, unplugged the stick, wait about 5 minutes and start eveything backup?

It made no difference.

Anyone have a fix for this? Z-wave stops working when I upgrade from Z-Wave JS UI 1.16.01 to 2.0.1. The only option I had was to restore Home Assistant back to BEFORE the upgrade and stay on 1.16.01. \
I have an Aoetec Gen 5 stick. When I had upgraded to 2.0.1 and went into the hardware area, there is no USB device listed for my aeotec stick

OK, may have found a fix. While on v16.0.1, go into: ZWAVE JS UI >> Settings >> ZWave.
And disable “Soft Reset” before you upgrade. All seems normal now!

So that basically seems like you have to do that BEFORE you’ve already run into a problem, right? Since this bug crashes ZWAVE JS UI and makes it impossible to change settings.

No, you can still configure it. If you do encounter the add-on restarting for some reason, then just unplug your USB stick and it will fail on startup. In that case at least you can still configure it afterwards.

Of course, if you do it prior to upgrading it’s easier.

What’s frustrating is that in the past I’ve set this up. I knew how to ID which USB device I was using so I could configure ZWave to use that ZWave device - all that stuff. But that’s been half a year and I’m dealing with having to set up a server and two new systems, including one to control a CNC and other devices, so this is really a bad time for failure. It’s been down about a week now and I’m realizing what a serious inconvenience it is and how much we’ve counted on Home Assistant. (And it’s got me thinking maybe I should find a commercial program. I’m in my 60s and hope to be around for a good while, but if Home Assistant can be this unreliable, what would happen if I were incapacitated or dead and my wife were stuck in this house with all these things no longer working?)

It appears ZWAVE JS isn’t working because ZWave isn’t working - which makes me think @smithkt might be right and the USB port might have changed - but I don’t even remember how to check the USB IDs on HA. (On standard Linux, I’d use lsusb to get the info.) So I don’t remember how to check it out, get the proper ID for the device, or how to specify the device. I can’t get to anything in the web UI that lets me do that.

Yeah, well, it was busted and wouldn’t start before the upgrade. I don’t have anything doing auto-upgrades, so I don’t know why it broke, but just one evening, poof no ZWave. I really was hoping the upgrade would fix it.


Click all hardware.

That will give you a list of everything.

Hmmmm…Okay, found my device as ttyUSB1, but I thought the number given in the error would be the UUID for that device. It’s not. I was thinking maybe my Z-Stick just died, but I think if that were the case, it wouldn’t show up in the hardware. I’m thinking about the “Name has no useable address” part of the error message. It did have one and now it doesn’t. So I’m wondering if something happened with the configuration.

Since I made this thread about the ZWAVE JS UI, and it now looks more like it’s not the UI, but the ZWave setup, I started a 2nd thread with some more direct questions.

The zwave-js ui still loads? If so, go to the settings on the left side. scroll down to zwave. there should be a drop down that lets you select the port.


I’m figuring it’s not the JS end of things, since it looks like it’s ZWave itself. ZWave JS seems like it won’t load without the ZWave integration working properly.

That’s backwards. The integration is dependent on ZUI in this case.

Now I’m remembering that there was something odd - I remember having th change things around somehow in the Z-Wave at one point. Something like that MQTT was included or excluded or something odd like that.

There’s also an option under ZWave->Configure to turn on the ZWave Supervisor. Is that supposed to be on or off?

You’re using Z-Wave JS UI, so that option should be already off.

It is off - but since something’s gone wrong, I’m making sure it should be off - that it didn’t somehow get changed.

From what you’re saying, I take it that it should be off?