Lovecard installation via HACS


I have been searching and reading and following instructions on installing lovelace cards via HACS for several days. and keep hitting a dead end with ‘No card type configured’ in a red box the end result. At the moment it is the result with mini media player and Roku card. I put this on the HACS github page and all I got was contact the devs for those cards. I have read the repos instructions for those cards as well as others and get to get the same result with all.
I have tried reloading HASS and rebooting the system to see if that works.
I’m using HASSio 0.97.2 on a Raspberry 3b+

Thanks in advance

did you read this

Like I said, I have read and re-read everything n case I missed something.

Used the store then go to the next set off of instructions, watched videos, etc to get the answers.

After you installed mini-media-card, what did you add to yout lovelace configuration?

You really need to add some details about what exactly you did and where you did it for us to help you.

I installed the custom card from the HACS store, from there I followed the instructions to add the url in the right place. I then used example code from the repos for each, in the case of the custom media player card I used the basic player card and added it to love lace as is using a manual card

  • type: custom:mini-media-player
    entity: media_player.kitchen_speakers

(copy and paste) I then changed the media player to the one I wanted.

  • type: custom:mini-media-player
    entity: media_player.music_speaker
    . The results as above.

Now this morning I had another go, I look at other things in the ras config for love lace. The custom player card sample code appears to need the two lines swapping around for it to work so that it now looked like this

  • entity: media_player.music_speaker
    type: custom:mini-media-player

I am still having issues with this from the roku remote card,

  • type: custom:roku-card
    entity: media_player.bedroom_tv
    name: Bedroom TV
    theme: darkpurple
    tv: true
    service: switch.turn_on
    entity_id: switch.bedroom_tv_power

Without you showing EXACTLY your code, ie copy and pasting it, he can’t help.

I suggest you read How to help us help you - or How to ask a good question

Sorry didn’t realise he needed the code as well.

What “right place” is that?

That’s not true.

It will work with those two lines in either order.

Are you swaying the mini-media-player card is now working?

Lastly, you need to make sure that when you post any code to the forum that it is formatted correctly. If we can’t see exactly how you have it formatted in your config then we can’t help find syntax/indentation errors.

there are a couple of ways to do it but this animation should give you one way:

By in the right place I meant where it is supposed to go in the lovelace config.

Yes, I am saying I fixed it by switching the lines of code around.

Anyway, I’m going back to fixing stuff with trial and error. I learn !

And where exactly would that be?

Man, you’re making this difficult for people to help you.

I’m not just asking those questions to irritate you. I’m asking because those are the kinds of questions we need to know the answers to in order to help you.

If you ask for help on other things on this forum you will need to provide that same kind of information for almost every problem that you will need help with. So you might as well either get used to providing the detail necessary for others to help you properly or just continue to learn by “trial and error”. I would personally rather choose the former rather than the latter. But that’s just me.

But that’s not what actually fixed it. Lovelace doesn’t care in which order those two lines are entered. There was likely something else that you fixed by rewriting the config. But we can’t know what it might have been because you haven’t given us the detailed info that we need in order for us to help you see that.