Lovelace: Multiple entity row

I’m trying to find a way to use a template-entity-row inside a multiple-entity row as one of the extra entities:

      - type: custom:multiple-entity-row
        entity: sensor.washing_machine_last_run_energy
        name: Kosten
        icon: mdi:currency-eur
        show_state: false
          - type: custom:template-entity-row
            entity: sensor.washing_machine_daily_energy
            name: Vandaag
            state: |
              {{ ((states('sensor.washing_machine_daily_energy') | float(0)) *
                  (states('sensor.energy_rate_tarif_2') | float(0))) | round(2) | replace('.',',') }} €
          - type: custom:template-entity-row
            entity: sensor.washing_machine_last_run_energy
            name: Laatste
            state: |
              {{ ((states('sensor.washing_machine_last_run_energy') | float(0)) *
                  (states('sensor.energy_rate_tarif_2') | float(0))) | round(2) | replace('.',',') }} €

Unfortunately, the values shows are those from the entity and not the templates states.

Can anyone provide some guidance how to get the templates working?

(I know I can create a templated sensor with the values and show that, but want to avoid that.)

You cannot use template-entity-row here.
Place the whole multiple-entity-row inside config-template-card if you need templated states/names/headers/icons.

1 Like

Hi, I know this was 2 years ago but have you found a way to get a actual timer inside multiple entity rows instead of the timers state?

Did you figure out how to do this?

Sorry, no I didn’t

How do I get the value of a nested attribute ( in the seconday info section).?

Nested attribute I want to display: setpoint_mode of attribute setpoint_status

Attributes in development tools::
** setpoint_mode: FollowSchedule **
** target_heat_temperature: 19 **

So far I tried this ( with no result )

  • attribute: setpoint_status.attributes.setpoint_mode
  • attribute: setpoint_mode
  • attribute: setpoint_status.setpoint_mode
type: entities
  - entity: climate.woonkamer
    type: custom:multiple-entity-row
    name: Woonkamer
      attribute: setpoint_status.attributes.setpoint_mode
      - attribute: current_temperature
        name: Huidig
        unit: °C
      - attribute: temperature
        name: Gewenst
        unit: °C

Expected outcome: “FollowSchedule”
Actual outcome: “ündefined”

Find my issue about a support of nested attributes on Github.
Please add required comments.

1 Like

Hello guys. How to change font, size, color,… of marked part? Can’t find it…cc7221b2b9f993821f947f357d9a0486a06404fd

card-mod thread → 1st post → link at the bottom → styles for multiple-entity-row

Thread? Where? This forum? Github…

Community thread


I’m getting this error. I installed with HACS. Any advice?

Custom element doesn’t exist: multiple-entity-row.
entity: sensor.alarme_baixo_humidity
type: custom:multiple-entity-row
name: One entity
secondary_info: last-changed

  • sensor.alarme_baixo_temperature

i got the same, further info from the console

i tried the .js from releases and master (though i suspect they’re the same as there hasn’t been a commit since the last release, but i didn’t diff the files)

Got a quick question for you all, is tap-action broken? I’m trying to add an icon button to the multiple-entity-row card, code:

      type: custom:multiple-entity-row
      entity: input_text.entity1
        - icon: mdi:watering-can
            action: service
            service: script.my_script

When I click on the icon I just get a popup with the info of ‘input_text.entity1’. Am I doing something wrong or is there something wrong with the card? I see that it hasn’t been updated in a year, so was there a breaking change introduced? I’m running OS version 2022.12.8.

Edit: typo in “tap-action”, should be “tap_action”

Start with fixing this typo.

Late night coding claims another one 🤦 … Thanks!

I have multiple toggle buttons and when I switch one it switches all of them on or off and I want to operate them separately. Any idea?

Never mind… saw that the main entity was the same

I can’t get name: false to work either
This card addon had been brilliant if it worked

Tried without space (shouldn’t work I suppose) and then the whole sub-entity dissapeared:

On your 1st picture you specified nothing for the “name” option.
2nd picture: spaces are obligatory.