Mirabella Genio Smart Home

Great Job! I’ve had one of these PIR sensors in the drawer for a couple of months now, having given up on it as a lost cause when it seemed that there was no way of making it work with Tasmota. Anyways, I’ve managed to implement the updated device template, and I guess from what I am seeing that it’s functioning correctly. Yay! Now i’m stuck. I’ve entered the Sensor information as per your post, and I am getting the following feedback when I check the Config file…

Configuration invalid

Invalid config for [sensor.mqtt]: [payload_on] is an invalid option for [sensor.mqtt]. Check: sensor.mqtt->payload_on. (See ?, line ?).

I can’t really tell where I went wrong (did I miss any precursor steps?, etc). I believe that I followed the details of both the template and the config.yaml info to the letter, and as this is my first implementation of this kind of device I’m sorta flying blind… so any and all advice would be appreciated.

Post your config making sure you tag it for formatting. Maybe it’s just a typo.

I’m having issues with the tamper sensor in these causing false triggers, it’s vibration based and the metal wall I have it on must vibrate in the strong winds we are having at the moment, it’s been going off all day.

Thanks for the quick reply!

This is the current config.yaml file. I’ve just rebuilt Hass.IO on a VM, so there isn’t much in there to complicate things…

# Configure a default setup of Home Assistant (frontend, api, etc)

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml


  - platform: synology_srm
    password: !secret dsm_password

  - platform: mqtt
    name: "PIR Sensor"
    state_topic: "pir_sensor_1/tele/RESULT"
    value_template: "{{ value_json.TuyaReceived.CmndData | truncate(9, false, '') }}"
    payload_on: "650100010"
    off_delay: 3
    device_class: motion

It was a clean copy and paste of the content in your previous post, but there is EVERY chance in the world that I’ve buggered something else up! :slightly_smiling_face:

1 Like

Ah - I see the issue. It should be a binary sensor - sensor implies an analogue or other value, binary_sensor is for things like light switches, reed sensors and motion sensors. Anything that’s either on or off.

Should read:

  - platform: mqtt
    name: "PIR Sensor"
    state_topic: "pir_sensor_1/tele/RESULT"
    value_template: "{{ value_json.TuyaReceived.CmndData | truncate(9, false, '') }}"
    payload_on: "650100010"
    off_delay: 3
    device_class: motion

Let me know if you start getting false readings. The original article was a bit vague about the returned values so I might have to capture some logs off the device if mine continues to play up.

Just changed to “binary_sensor” and perfect! No issues with the config file - so it’s fixed!
Will have a look at it again in a sec and see how it implements into the UI.
Great Job, and again thanks for the super fast reply… I love this learning journey and all the folk that are along for the ride! :smiley:
And as for sensor behavior, will do. I have it sitting on my desk at the moment, and this one is likely to be mounted on the wall near the desk, so it’ll have minimal external influence on the sensing operation. But, will test it, and see what happens!

Thanks for the neat template!
Yeah it took us a while to find a solution for the PIR.
The full thread can be found here.

1 Like

That looks like a good bit of detective work, well done.

I’m not too impressed with these sensors though. I have an extensive 433 Mhz installation and I may stick to the Sonoff pet friendly 433 Mhz sensors.

Yeah they aren’t that good for the price, would you recommend the Sonoff sensors?

Hi people, first post here…

Has anyone tried to flash ESPHOME to a Genio RGBW globe they bought from Woolies?

I tried to flash ESPHOME to the Woolies version and had nothing but issues with even turning it on and off. Could not get any colour at all other than half a second flicker of yellowish green.

I bought a kmart version today, flashed fine first go with the same yaml and binary as I used for the woolies version. All up and running first go in home assistant.

The version you buy in boxes at woolies seem to be different to the kmart versions in packets. They have different part numbers and both weigh slightly different amounts… enough for me to notice picking them both up anyway… I decided to weigh them…

Kmart - 1002339 - 69gm
Woolies - 1002608 - 64gm

So either the Woolies one I bought was faulty to start with (I never tried it with the genio app before flashing it) or they may be internally different. I haven’t opened it up to confirm though.

Can anyone confirm this?


I have the sickly green issue with a Genio bulb, so maybe it’s faulty. I think mine is… I have other Genio bulbs that are fine.

@aogorman - if you already have a 433 MHz bridge they are good value at $9 US + delivery. Last for ages on battery, less false positives than the Genio, but that may be because of how I have the Genio configured.

Don’t buy the Sonoff reed switches, they only have open notification not open/closed. I use the GS-WDS07 because you can pull them apart and do cool things:

Only issue with 433 MHz is that building penetration compared to wifi is not as good, mainly due to lower transmit power. This however translates to longer battery life.

1 Like

Hi Johan,

Regarding the Mirabella Window and Door sensor. Did you use Tuya-convert OTA? if so could you explain your method? My attempts to flash it have been unsuccessful. While tailing the smarthack-wifi.log file I can see the sensor connect to the WIFI AP however once it is in ez pairing mode it disconnects.

There were some comments about not converting while on battery power for the PIR sensor - causing the same behaviour. Does the door sensor have an external power option?

Not that I can see. I made sure to activate the reed switch while trying as I have seen people mention that keeps the sensor from sleeping.

I think the crux of the issue is it disconnects from the AP while in EZ pair mode, as soon as the red light stops flashing, I can see it connect to the AP again.

I manage to get the door sensor flashed OTA today and don’t know how it happened but it took a lot of resetting and activating the reed switch now I just need a template for it.

hi can you post the configuration for the kogan cool/warm white LEDs pls?

I’m interested in flashing the door sensor too, pleased to hear OTA is working with it.
Ill have to give it a shot later.

I bricked mine now trying to work out how to make a template for it and not sure if it is soft or hard brick but it doesn’t seem to work with serial reflash but will keep trying.

I’ve had a scan through the last many pages but couldn’t find it.

Do the RGB Led strip from Kmart flash ok?


Can only speak for the 3m strip: yes