Mirabella Genio Smart Home

I bricked mine now trying to work out how to make a template for it and not sure if it is soft or hard brick but it doesn’t seem to work with serial reflash but will keep trying.

I’ve had a scan through the last many pages but couldn’t find it.

Do the RGB Led strip from Kmart flash ok?

https://www.kmart.com.au/product/mirabella-genio-wi-fi-led-strip-light/2754878

Can only speak for the 3m strip: yes

Can I asked what you flashed with ?

I put ESPhome on mine and am disappointed with the 5 to 10 second response time.

I got it flashed with tasmota. Just needed to reinstall tuya-convert. I must have been missing something earlier. Now just trying to tackle the config.

I have created Mirabella Genio Door & Window Sensor I002575 HKWL-DWS02W topic to track the progress of this integration. @jivesinger @a_lunatic @JohanPotgieter

If you could post what you know, that would be great.

Wondering if someone could help me here, this is my first time flashing Tasmoto

I used the tuya-convert method listed here
http://www.thesmarthomehookup.com/tuya-convert-walk-through-february-2019/

using a Rasperry Pi 3 B+

All went well and it flashed quickly and easily.

I then used the ESPhome addon for home assistant to generate the firmware file using the code from


which also succeeded. The device flashed successfully and i can see it is connected to my wifi and can see the ip address that it has. The only thing is i cant access the webserver using it’s ip address to finish configuring the mqtt. Have tried multiple browsers and rebooting it once

By default, esphome doesn’t have a webserver.
You can enable it by including

webserver:

in your devices esphome config.
It’s not used for setup though, thats all through the yaml file.
The webserver is more for checking the status of inputs and outputs.

As for your MQTT problem, personally I’d just add

api:

to your config and let esphome do its auto discovery magic.
If your dead keen on MQTT though, post your config and we’ll see what up :+1:

EDIT:

Actually, if you used that config you linked to, api is already enabled so the light strip should already be showing in Home Assistant ?

1 Like

I may even be asking the wrong questions as i’m stumbling my way along with this

How does HA automatically detect the new item?

I have it flashed, i can tell it’s connected to my wifi, but i can’t see where to go next

HA should detect it through mdns (avahi, bonjour). Check your HA notifications, it should say it found a device. Or look at the integrations list to see any new discovered devices.

1 Like

OMG! So easy!

Thank you

Hi guys,

Picked up one of these today for an outside light.
Flashed with tuya_convert put tasmota on it fine then upgraded to Esphome after that.

This is the Esphome YAML that I needed to use. small change from the standard monochromatic option.
Brightness works as expected in home assistant.

esphome:
  name: mirabella_genio_cw_1
  platform: ESP8266
  board: esp01_1m

wifi:
  ssid: 'WIFI'
  password: 'WIFIPASS'

logger:

api:

ota:

light:
  - platform: monochromatic
    name: "Mirabella Genio Smart Bulb"
    id: light
    output: output_component1

output:
  - platform: esp8266_pwm
    id: output_component1
    pin: GPIO5

Note the change from GPI0 pin 13 to GPIO pin 05.

efleming,
Did you ever get this sorted?

I have the same issue with the RGB lights, the colour control isn’t working as expected.

Hi, I have this Mirrabella Genio globe that is Warm White, Colour changing and dimmable. I have flashed it with Tasmota but Im buggered if I can get it to work using all the published GPIO pinouts. If I use the RGB template on Blakadders site, it initially turns on warm white but goes off if i touch any of the sliders (in Tasmota page) and wont come back on again. I’ve tried this on 2 separate globes and the same happens, so, now I have 2 globes that wont work.
Anyone have a template for this globe by any chance? I’ve tried making a template but cant figure it out. The part number is 1002608 WIFI LED GLS
thanks

I dissembled one of mine to try and get it to work, but I couldn’t figure it out. It has a sm2135e controller inside. A small search says you could try these settings:

{“NAME”:“LSC RGBCW LED”,“GPIO”:[0,0,0,0,0,0,0,0,181,0,180,0,0],“FLAG”:0,“BASE”:18} source

Thanks Freyta, unfortunately it doesn’t work. I put the bulb in a fitting and powered it on and now it acts as a normal light globe for one cycle then nothing, on and off but no colour control and now nothing.

Has anyone had experience with these and ESPHome

I see the light switch version is working

It has a Tasmota template so it’ll be a breeze to get it working with ESPhome.

Not quite there yet , but have got a Woolies genio I002608 bulb to mostly work with this template:

{“NAME”:“MI-BW906-999W”,“GPIO”:[0,0,0,0,37,38,0,0,181,142,180,0,0],“FLAG”:0,“BASE”:18}

is a modification of existing Merkury bulb, which used SM16716 driver. Have modified the clock and data pins to reflect SM2135.
The colour bar seems out of sync (backwards?) but is my most stable configuration so far.
(No real knowledge of the LED driver (SM2135), any help would be appreciated)

addit: Console command: setoption37 30 seems to align the colours
addit2: setoption37 31 is best so far
addit3: The PWM commands don’t appear to be needed. This template seems to work just as well
{“NAME”:“MI-BW906-999W”,“GPIO”:[0,0,0,0,0,0,0,0,181,0,180,0,0],“FLAG”:0,“BASE”:18}

Thats great, at least it will go “on”. Im at work at a mine at the moment and fly home Wednesday so I will try it then.