Mr. Silence Full Inverter Pool Heater?

Has anyone found an integration for the so called “Mr. Silence Full Inverter” pool heater? It’s being sold under various brands: Aqua Forte, AQS, …
https://www.toppy.nl/product/12544/aqs-mr-silence-full-inverter-11kw-zwembad-warmtepomp.html

It does have home automation/integration, but only with the InverGo App https://play.google.com/store/apps/details?id=com.inverpac.smart&hl=nl&gl=US

1 Like

I’m very much interested too. :wink:

I would also be interested in this. I have a Madimack which as you have stated, is just another rebrand.

Also, noticed the Invergo app looks like it is a rebranded Tuya app. On a scale of 0-100, i am about a 10 on dev skills, but am more than happy to work with someone to create an integration for this…

@bluejohn @brix29

I think i may have stumbled across something which may start the process of integrating InverGo devices… Watch this video HOW TO - Setup Local Tuya in Home Assistant - YouTube.
I have managed to get my heatpump showing up in HA as a Binary Sensor using Local Tuya (screenshot shows that there is no switch)

.
I have just worked out that i can add the device as a switch which allows me to control the on/off state of the heat pump, but i just need to work out how to control fan speed, mode and temperature, but for now, if i can turn it on and off, the temp really stays at one setting along with the fan speed and mode, so i am not that worried… If either of you work it out, please post the setting.

thanks

1 Like

UPDATE:

So, here is an update… I have just added the HACS repo GitHub - make-all/tuya-local: Local support for Tuya devices in Home Assistant, which allows for Auto detection of devices. This time, I have some more info appearing… like: Status, Setting, Set Temp and Current Temp

1 Like

Hi Michael, I’m just working on it. Looks very promising, :slight_smile:
Thank you so much for sharing!!!

UPDATE: All working

image

To get it working, follow the steps in the youtube video posted above, BUT instead of adding the Tuya LocalTuya integration, add the Tuya Local integration by adding the custom repo above to HACS. Once that is installed through HACS, add the Tuya Local integration and configure it as either Auto and then just add the device to your Lovelace by clicking ADD TO LOVELACE…

Thank you to @make-all for making the enhancements to the original LocalTuya integration to get this working

Same here. Works like charm. :slight_smile:
Just wanted to post the same picture.
Thank you so much for sharing.

1 Like

Your temperature looks much better than mine. :rofl:

1 Like

Hi everyone. Thanks for this!

A while ago - after some detective work to find them :sunglasses: - I contacted the manufacturer in China and they sent me the MODBUS specs. An integration through MODBUS should be possible as well, but I haven’t gotten around to it yet. (Swimming pool season is only just starting :wink: )
If you guys want to give it a try, I can share the MODBUS specs…

Hi,

Don’t know when I can start looking at it, but feel free to send them through. For now though, I am happy with this working.

I can be your beta tester, but the solution works great.

I’m not sure, if it is relevant for you, too. What I really like about the solution is, that I can now restrict internet access for the heat pump.

1 Like

@brix29 Can i please ask you to test something for me.

Can i please ask you to click the power button on the lovelace card and let me know if that powers on your inverter and then when pressed again, powers it off.
image
I am finding that my config does not power the inverter ON when I click the power button (when the inverter is in an unpowered/not running/off state), but then when it is in an ON/HEATING state, when i press the power button, the device does turn OFF

In order for me to turn the inverter on using Home Assistant (from an off state), i click on the three buttons at the top right of the card,
image
On the new window which appears, I click the dropdown associated with the Operation field and select Heat.

Hi Michael,

it’s not a toogle button. It’s just “off”. The fire is “on” in my case.

BR Axel

Thanks…

This is the case for me too, i actually didn’t try to click the Fire icon previously, but now have and you are correct, it does turn the unit ON.