My steps to success for on Intel NUC

Yep tried to SSH into the ip address that my unifi controller says it is (hardwired)

Have rebooted a few times and no luck. I just tried reset bios to defaults and will try one more time before I give up for today

Good luck.

Some success …I left my old pi3 with hassio running and on the same network, think it was getting confused somehow.

I have now been able to get to it via the url and it says “will take 20 mins” pretty sure its been 30 mins but Ill keep waiting fingers crossed, pi took quite a while here also.

EDIT -finally completed after about 1.5 hours (must be my terrible internet) up and running thanks for the great post, gotta say everything just feels faster, even my zwave lights seem to react quicker.

Well done. Keep hitting CRTL + F5 to force refresh. It should come up shortly.

Did you ever solve the issue with the Bluetooth?
I’ve got 5 Xiaomi sensors that used to work in my Raspberry Pi that I havent been able to use with the NUC

No. I’m either going to use another Pi3 and MQTT Eventstream to connect the two together or hopefully better still, see if @andrewjfreyer can include detection in his awesome presence software I’m now using.

Or just use normal Docker on a normal Linux distro?

I am testing Hass in Docker with bluetooth support using Phil’s excellent instructions. While it works, I like too much and the location of my server rack is not ideally located for BT presence detection.

Hi, I have the same machine Intel NUC and I can’t get my Aeon Labs Z-Stick S2 to work. Do you have the latest version of the Z-stick?

did you manage to make the mi flora work with HASSIO on the NUC?

See above My steps to success for on Intel NUC

Yes, I have Gen5

Thanks for confirming. Wondering if my Aeon Labs Z-Stick S2 is not being detected by image. It works fine on my RPi3, but I find the RPi3 a little slow and wanted to run it on the NUC with SSD.

Just tried to install on my NUC5i3. Followed all the steps and got to the Logo screen (the one without text) and now it just hangs there. I control-F5 to switch the screen to the linux text and I see that the process is stalled at “Started Update UTMP about System Runlevel Changes.”. Not sure what to do from here. Any suggestions? BIOS is latest etc. Thanks!

Having the same issue.

1 Like

Did it not shut down after 3 or 4 minutes?

I bought nuc7i5 and managed to migrate hassio (backup and restore) from pi3. I’ve installed hassio on top of Ubuntu server using provided hassio script and it worked just fine. The main issue I had was with wifi and Bluetooth driver that had to be installed manually. I’m using aoetec gen 5 z stick, zigate and Bluetooth (for mi flora). The only flaw of this particular Nuc is the quality of wifi and Bluetooth connection but this can be supposedly fixed with diy antenna.
So far it works much snappier than pi3. Supprasingly my zwave network got much responsive.

@xbmcnut No, it didn’t shut down on its own. I left it alone on this screen from a good 30 min and it’s just hung there. Rebooted twice and got same hang at exact same part of boot sequence. Very frustrating.

Since my last post I decided to try a different route and just install Ubuntu server and use the install script provided on the HA site. After a bit of tweaking - I guess latest Ubuntu Server doesn’t have a Docker CE install available - I was able to get it installed. I’m not a real Linux nerd and so a little out of my element as I had to learn to do all the required package installs before getting working. BUT…finally got to the admin page and got Configurator installed. That’s where I am as of this moment.

Question: Should I assume that this install is as good or better than using the flash image that uses ResinOS? Before I invest a bunch of time setting things up I want to make sure this isn’t a dead end for compatibility etc. From everything I have read it seems that starting with a NUC will save frustration later due to performance and reliability issues on RPI. I thought about trying the whole DIY using Docker with main HA install as MANY people say that is best for flexibility and control. But I just can’t sign up for the admin maintenance and learning curve of getting and keeping it running if this is going to be my main home automation platform.

Next step is I want to install Homebridge so hoping that Add-ons ‘just work’ in this config. Anything else I should know or look at given how I have chosen to install this?

Thanks for all the community support. Great to jump into this and see where it goes.

One other question: noting the post about issues with WIFI and Bluetooth on an Ubuntu install, are there any suggested steps for achieving this? I don’t need WIFI as my NUC is hardwired into Ethernet, but wondering what benefits adding Bluetooth added to the whole HA workflow and use? And how does one install the required software for Bluetooth on a NUC with Ubuntu and


@misterwiggles I use Bluetooth for Mi Flora. Iirc I had to install a package called wpa-supplicant and then turn on Bluetooth using a command I found on the internet. Be ware that at least in case of nuc7i5 the range of the connection is very poor and I’m going to install external antenna on my own. I went through similar mental excercise as you re. Hassio vs plain docker ha. In particular I’ve started with docker ha and configured nginx and duckdns manually to get started but then I’ve realized that extra maintenance burden is not worth the effort and switched to hassio. All add-ons that I had are working except configuration add-on. I was worried that I’m going to have issues with external devices (zwave and zigbee stick and internal bt) but they’ve worked out of the box.