myVAILLANT integration

Hi all,
Since a few days it is not possible anymore to set/change the heating circuit from “Auto” to “Off” (or any other change of mode).
Instead I get the below error code list:
I tried to revert to an older backup from the time it was still working, I tried to reinstall the myVaillant integration and I tried with both V0.7.x and V0.8.x releases but the problem remains.
Anyone else has seen this?

Same problem here when using Saunier Duval boiler with the wifi bridge. The original MiGo Link was failing too, but it started working back as soon as I installed the latest update v2.16.0

If I interpret your comment correctly, I have exactly the same.
The MyVaillant app was also playing up on Thursday, but is now in version v2.16.0 and working fine now.
Changing heating mode by the MyVaillant integration on HA is still not working.

Hi Folks,

I am new to this integration. I am using it with an “ArpTherm Heat Pump”.
Real time power consumption is activated in configuration of the integration


But I do not find any entity dealing with real time values.

Can anybody help.


Hi Philipp,
any chance for you to check if you see the same behavior when switching any of the heating circuits to a different mode? Or do you have another suggestion on how to resolve?
As it coincided with the app update and probably (couldn’t check this) a firmware update of the Vaillant internet gateway, I suspect that they made changes to the API.

Appreciate suggestions or comments.


Hello, did anyone manage to change the waterheater-mode in relation to excess energy from the PV-system and might share the automation?
I´m thinking like:
if battery state > 60%, water temp < 50°C and energy usage < solar generated energy, activate hot water boost mode and increase target temperature to 60°C.
After that switch back to time controlled and set target temp. to 53°C.

Did I miss something or do you have other suggestions?

Hi all,
Quick background:
I’m a longish term user of Home Assistant and have a lot of home brewed integrations as I prefer local control over cloud based.
I’m about to have a Vaillant Arotherm Plus 7kW heat pump with the newer R290 gas. I’m pairing it with a Sunamp Thermino e thermal heat battery instead of a water tank.

Question - to use this integration (myvaillant) it mentions I need a VR290 or VR291 gateway. My fitter has been told that the VR291 is being discontinued and is being replaced by the VRA 42 ( myVAILLANT connect | For Installers - Vaillant )

I’ve been told that I can either go with this gateway or they may be able to get hold of a VR291

Will this integration work with the VR42 either now or in the future?
Seeing as the future is the VR42 then I’m more than happy to go with this model as part of my install and work with developers to try and get it to work, I don’t have the skills to be able to actually code :frowning: but will offer my install up as a tester to help get it to work?

Let me know - VR291 or the newer VR42?



Well, my Arotherm Plus was installed, I installed this integration and it all seems to be working with values in the various sensors. Thank you for a great integration. However, I have a couple of questions to check what I’m seeing in case I’ve done anything wrong.

The sensor xxx_device_0_arotherm_plus_consumed_electrical_energy_heating seems to have an increasing value during the day then zeroises at midnight. Is that what I should be seeing. I’d hoped to graph it as an hourly number. If the increasing number is correct could somebody please help with how I can convert it to hourly (or another period).

The efficiency sensor seems to be hours (as much as 7hrs) old whereas all the others seem to update much more regularly.

I didnt want to risk using more than my quota so set seconds between updates to 300 seconds rather than the default. Could that be part of my problem?

Sorry, it’s not related to your question but do you know if they’ve fitted the older VR291 gateway or the newer VR42?

Hi, not a problem. These are the ‘bits’ that were installed, based on the pile of manuals I got left.

VR940f myVAILLANT connect
VRC 720/f sensoCOMFORT
VRA 42
VWZ AI Heat Pump control interface module
VWL 105/6 A 130V S2 … VWL 125/6 A S2 aroTHERM 10kw

I include the complete list in case it helps anybody else. I think the fourth one was what you were looking for. I just read your earlier post, I had not spotted there was an earlier version. Seems to be working OK, subject to my previous comments, which I think are mainly down to my lack of knowledge.

Excellent! That answers my question :slight_smile: The VR42 is a replacement for the VR291 internet gateway. Mine is getting installed in a few weeks. I hope you get your queries sorted soon.

Another user has confirmed that they’re able to use this integration with the VR42.

How did you solve it, I have the same problem (not possible anymore to set/change the heating circuit from “Auto” to “Off”).


Avec ma duomax saunier, mon application android annonce le mode ECO et coupe le chauffage lorsque la température extérieure dépasse un certain seuil (réglable dans les menus).
Je ne vois aucun sensor changer lorsque cela se produit, existerait-il une information dans l’api que l’on pourrait récupérer afin de visualiser ce mode ?
Je pensais utiliser l’attribut preset_mode de climate.my_home_zone_1_circuit_0_climate, mais celui-ci est en continuellement sur ECO, donc inutilisable.

It is not solved. Still the same problem. Both in v08.x as well as v07.x.

@pdd Philipp, anything you could advise here?

est-il possible que quelqu un prenne le temps de m’expliquer “simplement” comment installer la fonction Saunier Duval… HomeAssistant ne trouve pas MyVaillant dans les composant
le lien comme ci dessous ne fonctionne pas et provoque une erreur

j’ai achete une Green Box et je tourne en rond…


tu as bien installé l’intégration dans HACS ?
si oui, elle doit être visible dans HACS/intégration.
puis après avoir redémarré tu doit l’ajouter dans paramètres/appareils et services/intégration.

Bonjour @telenaze
Merci pour la réponse, mais justement je n’arrive pas à “installer l’intégration”
je clique sur lien indiqué, mais le système répond


Cette intégration ne prend pas en charge la configuration via l’interface utilisateur. Si vous avez suivi ce lien depuis le site web de Home Assistant, assurez-vous que vous exécutez la dernière version de Home Assistant.

donc je n’arrive pas à aller plus loin…
je suis certain que c’est très simple, mais… Je coince


c’est dans HACS que ça bloque ?

Je viens de comprendre que j’avais HA mais pas HACS… Donc je suis en train de l’installer… :slight_smile: