Netatmo in HA 0.105

Can i have a live stream in lovelace?
The only thing i can see now is a black image and it says “recording”.
Is it a bad idea to have a live stream on a rsp4?

Did you try to refresh your browser?

Yes, and i have cleared cache and history. have i used the wrong card in lovelace?


Not sure if it has been addressed before (I could not find anythinig), but is there an easy way to access the video of an event from inside Home Assistant?
According to the official docs, the procedure should be:

Step 1: Retrieve the camera URL

Use Gethomedata method for the user. In the array “cameras”, retrieve the vpn_url for the camera you’re interested in

Step 2: Retrieve the video_id

Use Gethomedata, Getnextevents, Getlasteventof or Geteventsuntil to retrieve the video_id of the events array.

Step 3: Call the m3u8 index with the camera_url and the video id

If your app and the camera are on the same local network, add /camera_url/vod/(your_video_id)/index_local.m3u8 to access the video. If not, add /camera_url/vod/(your_video_id)/index.m3u8 to access the video

Step 1 is probably easy enough within the integration.
But is there an easy way to do any of the calls from Step 2 to retrieve the video_id?

Ideally I would love to create something like a “Calendar card” in Lovelace to list events with a clickable link to the videos. And an option to save the videos locally.
Possibly even an automation to auto-download all videos from events of a certain type (e.g. “event_data - type: animal”)

Please open a feature request for this.

Thanks, done:

1 Like

I still can’t see anything? What am i missing? Why is it not working?

Recording is misleading. Why it isn’t working for you can have multiple reasons. To debug this please open a separate thread or contact me on Discord.

To everyone interested in the current development I invite you to take a look at what’s ahead.

Like many others here I had troubles getting my Netatmo Smart Weather Station working. I saw all entities in lovelace, but there were no values.

Reading again all suggestions here, I commented out all corresponding lines in configuration.yaml, then removed the Netatmo existing integration (Configuration > Integrations), reinstalled the Netatmo ingetration and linked with (logged in at) Netatmo where prompted. I got the message “Done, your account is now linked”. Then I rebooted my HA.
BTW, I’m running Home Assistant 0.111.4

To my surprise I found all values present in the Netatmo page in lovelace! I didn’t uncomment any Netatmo lines in my configuration.yaml and yet all values are there!

Is this new in the configuration? All instructions I find around here about this subject tell me to have some lines in configuration.yaml:

  client_id: !secret netatmo_client_id.          # from netatmo
  client_secret: !secret netatmo_client_secret.  # from netatmo

So, what is going on here? Is this new?

You can use your own Netatmo dev account or you can use HA Cloud Linking. The latter is fine as long as you don’t want to use a Netatmo camera.


had a netatmo thermostat working until 0.107.1 version. Today I have updated to 0.111 and suddenly it stopped working.

I saw that there were breaking changes, something related to webhooks, and those only works in ports 443 and 80. Those webhooks are not for the thermostat (the only netatmo device that I have).

In my setup, I am using duckdns with port forwarding, and I use the port 8123 to access my HA instance, and I don’t want to change the port, because I had to change a lot of stuff, and also those ports are busy.

I have tryied to remove the integration and set up again, It looks like it connects properly to my netatmo dev account, but I doesn’t find any device,

The only error that I have is

Copy to clipboard

Logger: pyatmo.thermostat
Source: components/netatmo/
First occurred: 21:20:12 (1 occurrences)
Last logged: 21:20:12

Errors in response: {'status': 'ok', 'time_server': 1593285613, 'body': {'home': {'id': 'some id'}, 'errors': [{'code': 6, 'id': 'a mac address'}]}}

I have my client id and secret properly configured in configuration.yaml

Someone can point me how can I solve this without changing the ports if possible?

same here, suddenly yesterday after a non related reboot the integration stopped working.
I was already on the latest HA version…

File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 946, in raise_for_status
aiohttp.client_exceptions.ClientResponseError: 400, message=’’, url='

resetted the key’s on, also created a new app there.
All doesn’t help

Do you have your public url with the port 80 or 443? I think that this is my issue but I would like to confirm

  1. i removed the integration and after re-adding everything is fine again…

I have made available my HA instance in the port 443 and I still have the issue. Maybe @cgtobi can help?

The integration connects fine with netatmo, and gets registered (through config.yml)
The webhooks are not banned
I see in the logs:

2020-06-28 14:26:37 INFO (MainThread) [homeassistant.components.netatmo] Register Netatmo webhook:[a id]

If I access trough browser, It says 405: Method Not Allowed (dunno if I need more params and call from any API client)

I don’t have netatmo error logs. This are the other logs with “netatmo” string. logger set as “info”. Should I look for another thing?

	Line 175: 2020-06-28 14:26:10 INFO (MainThread) [homeassistant.setup] Setting up netatmo
	Line 185: 2020-06-28 14:26:11 INFO (MainThread) [homeassistant.setup] Setup of domain netatmo took 0.1 seconds.
	Line 438: 2020-06-28 14:26:12 INFO (MainThread) [] Setting up camera.netatmo
	Line 439: 2020-06-28 14:26:12 INFO (MainThread) [homeassistant.components.sensor] Setting up sensor.netatmo
	Line 447: 2020-06-28 14:26:12 INFO (MainThread) [homeassistant.components.climate] Setting up climate.netatmo

I don’t see more things than

Errors in response: {'status': 'ok', 'time_server': 1593354373, 'body': {'home': {'id': 'a id'}, 'errors': [{'code': 6, 'id': 'a mac'}]}}

No entities in the component.

I am out of ideas now, what can I do or look for?

My setup is Home Assistant (not hassio), in a python env, port 443 forwarded to 8123 in the router. No reverse proxy, and this is my http is

  ssl_certificate: HIDDEN AND WORKING
  server_port: 8123

Ok, solved. As usual, was the user fault.

Looks like the relay failed at the moment of the update (Murphy law) and it wasn’t even accesible by the netatmo app. An old unplug and plug solved the issue :sweat_smile:

Sorry for the noise

1 Like

Glad to hear it’s working again.

Although it’s not required and doesn’t add functionality right now I suggest to get webhook working. It’ll improve responsiveness in an upcoming release.

Check the pre-release custom component for more info: Testers wanted - Netatmo integration

Sure, now I have it working, but if possible I recommend to make it available in other ports, as tons of users have their instance only available in the default 8123 port

There is nothing I can do about the port since that is dictated by Netatmo.