Network Issues - Can Reach Observer, but Not Home Assistant

I’m completely new to Home Assistant and desperately trying to get off of Samsung SmartThings. I’ve scrounged an Intel NUC, installed Home Assistant Operating System by flashing haos_generic-x86-64-10.5 to the SSD with Etcher. I’ve hooked up the NUC to ethernet and booted, but I can’t seem to connect to homeassistant.local:8123.

Curiously, I can access Home Assistant Observer on http://homeassistant.local:4357/ and receive messages of Connected, Supported, and Healthy.

When I attempt to connect to Home Assistant at http://homeassistant.local:8123/, I receive a ERR_CONNECTION_REFUSED response. I’ve tried both Chrome and Safari, and both provide the same results. Can someone please help me understand what’s going on?

Thanks.

try IPADRESS:8123

Same result. I can get to Observer with IPADDRESS:4357, but I get ERR_CONNECTION_REFUSED when I try to go to IPADDRESS:8123.

What is the IP address of the Home Assistant server?
What is the IP address of the PC?

From a PC on the same network, open a cmd line and enter:
ping homeassistant.local /4
This should respond with the IP address for homeassistant.local.

Alternately,

Do you have a display plugged into the NUC? If so, it should give you the IP address. Mine, for example is 192.168.1.70, so to go into Home Assistant, I can enter http://192.168.1.70 or http://homeassistant.local
(Both are identical).

Tell us what the responses to the pings are and what do you see on the display on the NUC.

Pinging homeassistant.local returns unknown host.

➜  ~ ping homeassistant.local   
ping: cannot resolve homeassistant.local: Unknown host

This seems strange to me given that navigating to http://homeassistant.local:4357 in Chrome on the same computer successfully loads Home Assistant Observer.

Here is the display on the NUC:

I find it curious that the NUC seems to get an IPv6 address, but not an IPv4. I decided to try navigating to http://[fd6e:7763:6711::862]:4357 in Chrome and received the same Home Assistant Observer status of Connected, Supported, and Healthy. Trying to navigate to http://[fd6e:7763:6711::862]:8123, however, still gives me the same ERR_CONNECTION_REFUSED.

I poked around at the ha > prompt a bit and found the command supervisor logs, and this returned a bunch of messages repeatedly stating:

WARNING (MainThread) [supervisor.jobs] 'Updater.fetch_data' blocked from execution, no supervisor internet connection
WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec

Oh, also, not too surprising, but a ping6 fd6e:7763:6711::862 works fine.

➜ ~ ping6 fd6e:7763:6711::862
PING6(56=40+8+8 bytes) fd6e:7763:6711:0:cb:82fe:f55d:3a5b --> fd6e:7763:6711::862
16 bytes from fd6e:7763:6711::862, icmp_seq=0 hlim=64 time=8.856 ms
16 bytes from fd6e:7763:6711::862, icmp_seq=1 hlim=64 time=6.575 ms
16 bytes from fd6e:7763:6711::862, icmp_seq=2 hlim=64 time=3.506 ms
16 bytes from fd6e:7763:6711::862, icmp_seq=3 hlim=64 time=7.217 ms
16 bytes from fd6e:7763:6711::862, icmp_seq=4 hlim=64 time=3.652 ms
16 bytes from fd6e:7763:6711::862, icmp_seq=5 hlim=64 time=3.578 ms
16 bytes from fd6e:7763:6711::862, icmp_seq=6 hlim=64 time=4.321 ms

But I know less than nothing about IPv6 addressing, so I have no idea if this is relevant or not.

Is IPV4 along with IPV6 enabled on the network/router? When you set up the HA did you enable both IPV4 and IPV6?

Did you use DHCP or static IP addressing on the NUC/HA?

Is this installed a container or VM? Did you do the network share addressing setups/forwarding?

Again:

Can you ping your router?

My apologies. I missed that question.
My laptop IP address is 192.168.1.25.
I can successfully ping my router at 192.168.1.1, and I can access the internet.

I would assume both IPv4 and IPv6 are enabled, as my laptop has an IPv4 address (192.168.1.25) and HA appears to have an IPv6 address (fd6e:7763:6711::862), but it’s a crappy Starlink router, so there are pretty much no controls or options.

I flashed my NUC’s SSD with Home Assistant OS using the haos_generic-x86-64-10.5.img.xz image as directed by the Generic x86-64 Installation Instructions. I don’t know what it enables by default, but I’ve tried net update eno1 --ipv4-method auto, net update eno1 --ipv6-method auto, net update eno1 --ipv6-method disabled (this one obviously killed all network connectivity, including HA Observer).

If I don’t change it, I’m guessing it’s using DHCP. The Starlink router doesn’t let me reserve IPs, so I don’t know that static would be a good method with my current setup.

I don’t exactly know what this question means, but I flashed the SSD on my Intel NUC with Home Assistant OS, so I’m not sure if this question applies to my situation.

Thank you for trying to help me. Please let me know if there’s any additional information that I can provide to help us understand what’s going on.

Could be crappy Balena Etcher again

Very doubtful. Balena works OK if you download the binary and flash directly to the boot device. It craps out when doing a burn from URL.

I didn’t experience any noticeable anomalies while flashing the NUC’s SSD with the downloaded image through Balena Etcher. I certainly wasn’t brave enough to let BE flash from a URL.

You have done everything correctly. I have never seen an install of the X86 binary fail to get an IPV4 address.

Try rebooting the router. The router is also your DHCP server, which assigns the IPV4 addresses, so rebooting the router might resolve the problem.

On your PC, download the Advanced IP Scanner. Run the IP Scanner. When it’s finished, look for your HomeAssistant server. Here is how mine presents:

From here you can see the IPV4 address and the computer’s MAC address.

The OFFICIAL nomenclature is “Permanent Lease”, but different routers use different terminology. (I can imagine the tech support calls- “What do you mean lease? I own my router”). It refers to the lease time of the DHCP IP address assignment. As long as that lease time has not expired, when the DHCP server sees the same MAC address, it will reassign the same IP address. A permanent lease never expires, so for all practical purposes it acts like a static IP address (without the headaches). So, look through the router manual for “fixed IP, lease, or reserved”. You may find a reference to static IP, but that usually means the IP address of your router. Don’t go there.

I am not a fan of static IP addresses of my network devices. My IP scan shows that I have 142 devices on my network. Can you imagine the nightmare of documentation to keep track of this many IP assignments. That’s the beauty of DHCP. You don’t have to do anything. There’s a reason that using DHCP is the default.

Don’t worry about containers, Docker, VM or Proxmox. Since you are installing HAOS directly to the boot device, there is no need at all to add yet another layer to your installation. You only need one of those if you are doing other things on the NUC besides Home Asistant.

BTW, most browsers can’t handle IPV6 addresses, so no surprise that http://fd6e:7763:6711::862:8123 won’t work, but ping will.

What version of HAOS did you use?

See: HassOS installation/network problem on Intel NUC - #14 by karlg

Is this a recent install? Do you remember your balena etcher spyware version? :thinking:

That times are probably over :put_litter_in_its_place:

Home Assistant should really do the move (like many other FOSS projects did already) and dumb that badware etcher ones and for all (remove it from all docs and suggest to don’t use it!).

I thought this, too, but you can imagine my surprise to find that http://[fd6e:7763:6711::862]:4357]/ DOES appear to reach my Home Assistant NUC and show me a good Observer status. Replacing :4357 with :8123 gives me a connection refused (as if the port is not open) rather than a host unreachable (no device found at this IP address) error. That’s what seems incredibly strange to me.

Screenshot 2023-09-12 at 11.54.55 AM

I flashed my NUC’s SSD with Home Assistant OS using the haos_generic-x86-64-10.5.img.xz image as directed by the Generic x86-64 Installation Instructions.

Yes, this is a brand new install that I attempted this weekend with Belena Etcher Version 1.18.11

Spyware? I don’t know much about Etcher (I have used it with Raspberry Pi installations before, though) other than the fact that the official Home Assistant installation guide told me to use it.

I suppose I could try usbimager, but if Etcher is spyware, I’m not sure that a random recommendation over the internet for a different tool really boosts my confidence in THAT tool not being spyware.